Update to 2.6.17

This commit is contained in:
Christopher Meng 2014-06-19 18:08:41 +08:00
parent c12243b37b
commit e205ef322f
8 changed files with 45 additions and 59 deletions

1
.gitignore vendored
View File

@ -13,3 +13,4 @@
/redis-2.6.13.tar.gz
/redis-2.6.16.tar.gz
/redis-2.8.11.tar.gz
/redis-2.6.17.tar.gz

View File

@ -1,9 +1,9 @@
Index: redis-2.8.11/deps/Makefile
Index: redis-2.6.17/deps/Makefile
===================================================================
--- redis-2.8.11.orig/deps/Makefile
+++ redis-2.8.11/deps/Makefile
--- redis-2.6.17.orig/deps/Makefile
+++ redis-2.6.17/deps/Makefile
@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
LUA_CFLAGS= -D__C99FEATURES__=1
LUA_CFLAGS= -D__C99FEATURES__=1
endif
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
@ -11,10 +11,10 @@ Index: redis-2.8.11/deps/Makefile
LUA_LDFLAGS+= $(LDFLAGS)
lua: .make-prerequisites
Index: redis-2.8.11/deps/linenoise/Makefile
Index: test/redis-2.6.17/deps/linenoise/Makefile
===================================================================
--- redis-2.8.11.orig/deps/linenoise/Makefile
+++ redis-2.8.11/deps/linenoise/Makefile
--- redis-2.6.17.orig/deps/linenoise/Makefile
+++ redis-2.6.17/deps/linenoise/Makefile
@@ -2,7 +2,7 @@ STD=
WARN= -Wall
OPT= -Os

View File

@ -1,8 +1,8 @@
Index: redis-2.8.11/redis.conf
Index: redis-2.6.17/redis.conf
===================================================================
--- redis-2.8.11.orig/redis.conf
+++ redis-2.8.11/redis.conf
@@ -34,11 +34,11 @@
--- redis-2.6.17.orig/redis.conf
+++ redis-2.6.17/redis.conf
@@ -14,11 +14,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
# Note that Redis will write a pid file in /var/run/redis.pid when daemonized.
@ -16,16 +16,16 @@ Index: redis-2.8.11/redis.conf
# Accept connections on the specified port, default is 6379.
# If port 0 is specified Redis will not listen on a TCP socket.
@@ -61,7 +61,7 @@ tcp-backlog 511
# Examples:
@@ -27,7 +27,7 @@ port 6379
# If you want you can bind a single interface, if the bind option is not
# specified all the interfaces will listen for incoming connections.
#
# bind 192.168.1.100 10.0.0.1
-# bind 127.0.0.1
+bind 127.0.0.1
# Specify the path for the Unix socket that will be used to listen for
# Specify the path for the unix socket that will be used to listen for
# incoming connections. There is no default, so Redis will not listen
@@ -87,7 +87,7 @@ timeout 0
@@ -53,7 +53,7 @@ timeout 0
# On other kernels the period depends on the kernel configuration.
#
# A reasonable value for this option is 60 seconds.
@ -34,16 +34,16 @@ Index: redis-2.8.11/redis.conf
# Specify the server verbosity level.
# This can be one of:
@@ -100,7 +100,7 @@ loglevel notice
# Specify the log file name. Also the empty string can be used to force
@@ -66,7 +66,7 @@ loglevel notice
# Specify the log file name. Also 'stdout' can be used to force
# Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
-logfile ""
-logfile stdout
+logfile /var/log/redis/redis.log
# To enable logging to the system logger, just set 'syslog-enabled' to yes,
# and optionally update the other syslog parameters to suit your needs.
@@ -184,7 +184,7 @@ dbfilename dump.rdb
@@ -150,7 +150,7 @@ dbfilename dump.rdb
# The Append Only File will also be created inside this directory.
#
# Note that you must specify a directory here, not a file name.

View File

@ -0,0 +1,15 @@
Index: redis-2.6.17/src/Makefile
===================================================================
--- redis-2.6.17.orig/src/Makefile
+++ redis-2.6.17/src/Makefile
@@ -72,8 +72,8 @@ endif
ifeq ($(MALLOC),jemalloc)
DEPENDENCY_TARGETS+= jemalloc
- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
+ FINAL_LIBS+= -ljemalloc -ldl
endif
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)

View File

@ -1,12 +0,0 @@
Index: redis-2.8.11/tests/test_helper.tcl
===================================================================
--- redis-2.8.11.orig/tests/test_helper.tcl
+++ redis-2.8.11/tests/test_helper.tcl
@@ -33,7 +33,6 @@ set ::all_tests {
integration/replication-2
integration/replication-3
integration/replication-4
- integration/replication-psync
integration/aof
integration/rdb
integration/convert-zipmap-hash-on-load

View File

@ -1,15 +0,0 @@
Index: redis-2.8.11/src/Makefile
===================================================================
--- redis-2.8.11.orig/src/Makefile
+++ redis-2.8.11/src/Makefile
@@ -84,8 +84,8 @@ endif
ifeq ($(MALLOC),jemalloc)
DEPENDENCY_TARGETS+= jemalloc
- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
+ FINAL_LIBS+= -ljemalloc -ldl
endif
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)

View File

@ -3,7 +3,7 @@
%global with_perftools 0
# Prior to redis 2.8 sentinel didn't work correctly.
%global with_sentinel 1
%global with_sentinel 0
%if 0%{?fedora} >= 15 || 0%{?el} >= 7
%global with_systemd 1
@ -19,7 +19,7 @@
%endif
Name: redis
Version: 2.8.11
Version: 2.6.17
Release: 1%{?dist}
Summary: A persistent caching system, key-value and data structures database
License: BSD
@ -32,11 +32,11 @@ Source4: %{name}.tmpfiles
Source5: %{name}-sentinel.init
Source6: %{name}-server.init
# Update configuration for Fedora
Patch0: redis-2.8.11-redis-conf-location-variables.patch
Patch1: redis-2.8.11-deps-library-fPIC-performance-tuning.patch
Patch2: redis-2.8.11-use-system-jemalloc.patch
Patch0: redis-2.6.17-redis-conf-location-variables.patch
Patch1: redis-2.6.17-deps-library-fPIC-performance-tuning.patch
Patch2: redis-2.6.17-use-system-jemalloc.patch
# tests/integration/replication-psync.tcl failed on slow machines(GITHUB #1417)
Patch3: redis-2.8.11-disable-test-failed-on-slow-machine.patch
Patch3: redis-2.6.17-disable-test-failed-on-slow-machine.patch
%if 0%{?with_perftools}
BuildRequires: gperftools-devel
%else
@ -240,11 +240,8 @@ fi
%endif
%changelog
* Wed Jun 18 2014 Christopher Meng <rpm@cicku.me> - 2.8.11-1
- Update to 2.8.11
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.16-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Wed Jun 18 2014 Christopher Meng <rpm@cicku.me> - 2.6.17-1
- Update to 2.6.17
* Fri Sep 06 2013 Fabian Deutsch <fabian.deutsch@gmx.de> - 2.6.16-1
- Update to 2.6.16

View File

@ -1 +1 @@
196e0cf387d8885439add8a3e1cab469 redis-2.8.11.tar.gz
918d74591e272e4419cba5beef67e995 redis-2.6.17.tar.gz