Update to redis 4.0.2 upstream release.

Make redis-devel a noarch package as Remi suggests,
first of many changes to come before 4.x builds are
ready to go.
This commit is contained in:
Nathan Scott 2017-09-27 12:17:46 +10:00
parent 74836e8db5
commit ac2422ae25
5 changed files with 28 additions and 44 deletions

2
.gitignore vendored
View File

@ -34,3 +34,5 @@ clog
/redis-3.2.8.tar.gz
/redis-3.2.9.tar.gz
/redis-3.2.10.tar.gz
/redis-3.2.11.tar.gz
/redis-4.0.2.tar.gz

View File

@ -1,4 +1,4 @@
From ed77684a7eb20635e7f8f8f3ead277c3c48182fe Mon Sep 17 00:00:00 2001
From c7958ad1c0d615b81276ec2d4dbc1bf6a67dcc4d Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Thu, 8 Sep 2016 14:51:15 +0200
Subject: [PATCH 1/2] 1st man pageis for - redis-cli - redis-benchmark -
@ -648,5 +648,5 @@ index 0000000..1e0c9c9
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
--
2.9.3
2.13.5

View File

@ -1,4 +1,4 @@
From a7e5d1dab11be34fafe80180f58411f02cd98026 Mon Sep 17 00:00:00 2001
From 992c773e70462a6fbe1536e18e673c9ab55d5901 Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Fri, 9 Sep 2016 17:23:27 +0200
Subject: [PATCH 2/2] install redis-check-rdb as a symlink instead of duplicating
@ -9,7 +9,7 @@ Subject: [PATCH 2/2] install redis-check-rdb as a symlink instead of duplicating
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/Makefile b/src/Makefile
index 4a8a326..a1bbfe9 100644
index fdbe36a..c3083f8 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -287,6 +287,6 @@ install: all
@ -22,5 +22,5 @@ index 4a8a326..a1bbfe9 100644
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_AOF_NAME)
--
2.9.3
2.13.5

View File

@ -17,8 +17,8 @@
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: redis
Version: 4.0.1
Release: 2%{?dist}
Version: 4.0.2
Release: 1%{?dist}
Summary: A persistent key-value database
License: BSD
URL: http://redis.io
@ -32,8 +32,8 @@ Source6: %{name}-shutdown
Source7: %{name}-limit-systemd
Source8: %{name}-limit-init
# To refresh patches:
# tar xf redis-xxx.tar.gz && cd redis-xxx && git init && git add . && git commit -m "%{version} baseline"
# git am %{patches}
# tar xf redis-xxx.tar.gz && cd redis-xxx && git init && git add . && git commit -m "%%{version} baseline"
# git am %%{patches}
# Then refresh your patches
# git format-patch HEAD~<number of expected patches>
# Update configuration for Fedora
@ -100,6 +100,7 @@ You can use Redis from most programming languages also.
%package devel
Summary: Development header for Redis module development
BuildArch: noarch
# Header-Only Library (https://fedoraproject.org/wiki/Packaging:Guidelines)
Provides: %{name}-static = %{version}-%{release}
@ -125,46 +126,27 @@ rm -frv deps/jemalloc
%patch0001 -p1
%patch0002 -p1
# No hidden build.
sed -i -e 's|\t@|\t|g' deps/lua/src/Makefile
sed -i -e 's|$(QUIET_CC)||g' src/Makefile
sed -i -e 's|$(QUIET_LINK)||g' src/Makefile
sed -i -e 's|$(QUIET_INSTALL)||g' src/Makefile
# Use system jemalloc library
sed -i -e '/cd jemalloc && /d' deps/Makefile
sed -i -e 's|../deps/jemalloc/lib/libjemalloc.a|-ljemalloc -ldl|g' src/Makefile
sed -i -e 's|-I../deps/jemalloc.*|-DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc|g' src/Makefile
# Ensure deps are built with proper flags
sed -i -e 's|$(CFLAGS)|%{optflags} -fPIC|g' deps/Makefile
sed -i -e 's|OPTIMIZATION?=-O3|OPTIMIZATION=%{optflags}|g' deps/hiredis/Makefile
sed -i -e 's|$(LDFLAGS)|%{?__global_ldflags}|g' deps/hiredis/Makefile
sed -i -e 's|$(CFLAGS)|%{optflags} -fPIC|g' deps/linenoise/Makefile
sed -i -e 's|$(LDFLAGS)|%{?__global_ldflags}|g' deps/linenoise/Makefile
# Configuration file changes and additions
sed -i -e 's|^logfile .*$|logfile /var/log/redis/redis.log|g' redis.conf
sed -i -e '$ alogfile /var/log/redis/sentinel.log' sentinel.conf
sed -i -e 's|^dir .*$|dir /var/lib/redis|g' redis.conf
%if 0%{?with_systemd}
sed -i -e 's|^supervised .*$|supervised systemd|g' redis.conf
sed -i -e '$ asupervised systemd|g' sentinel.conf
%if 0%{?with_perftools}
%global malloc_flags MALLOC=tcmalloc
%else
%global malloc_flags MALLOC=jemalloc
%endif
%global make_flags DEBUG="" V="echo" LDFLAGS="%{?__global_ldflags}" CFLAGS+="%{optflags} -fPIC" %{malloc_flags} INSTALL="install -p" PREFIX=%{buildroot}%{_prefix}
%build
make %{?_smp_mflags} \
DEBUG="" \
LDFLAGS="%{?__global_ldflags}" \
CFLAGS+="%{optflags} -fPIC" \
LUA_LDFLAGS+="%{?__global_ldflags}" \
%if 0%{?with_perftools}
MALLOC=tcmalloc \
%else
MALLOC=jemalloc \
%endif
INSTALL="install -p" PREFIX=%{buildroot}%{_prefix} \
all
make %{?_smp_mflags} %{make_flags} all
%install
make install INSTALL="install -p" PREFIX=%{buildroot}%{_prefix}
make %{make_flags} install
# Filesystem.
install -d %{buildroot}%{_sharedstatedir}/%{name}
@ -306,16 +288,16 @@ fi
%changelog
* Wed Sep 06 2017 Nathan Scott <nathans@redhat.com> - 4.0.1-2
- Switch to using Type=notify for Redis systemd services (RHBZ #1172841)
- Add Provides:bundled hiredis, linenoise, lua-libs clauses (RHBZ #788500)
* Mon Aug 14 2017 Nathan Scott <nathans@redhat.com> - 4.0.1-1
- Upstream 4.0.1 release. (RHBZ #1389592)
* Wed Sep 27 2017 Nathan Scott <nathans@redhat.com> - 4.0.2-1
- Upstream 4.0.2 release. (RHBZ #1389592)
- Add redis-devel for loadable module development.
- Provide redis-check-aof as a symlink to redis-server also now.
* Tue Sep 26 2017 Nathan Scott <nathans@redhat.com> - 3.2.11-1
- Upstream 3.2.11 bug-fix-only release
- Switch to using Type=notify for Redis systemd services (RHBZ #1172841)
- Add Provides:bundled hiredis, linenoise, lua-libs clauses (RHBZ #788500)
* Mon Aug 14 2017 Nathan Scott <nathans@redhat.com> - 3.2.10-2
- Add redis-trib based on patch from Sebastian Saletnik. (RHBZ #1215654)

View File

@ -1 +1 @@
SHA512 (redis-4.0.1.tar.gz) = 62dec537aebd12340b9642f5f8b07fd98757c9e648dcd539a0411f207db3495923c5a6a9941036c56b2d574ee38b46d08558668111e322345ef549f93fada26f
SHA512 (redis-4.0.2.tar.gz) = 1458909c6fc16cff8ca5e6dddff23b988ee1e447f2d0bccf5941553b22bab6abb851732b3fe53dafb8a69d6c0939c3ce7e0686d51e03be720fb018c038d3b1b4