Merge branch 'master' into epel7
This commit is contained in:
commit
6809ff675f
10
.gitignore
vendored
10
.gitignore
vendored
@ -17,4 +17,14 @@
|
||||
/redis-2.8.13.tar.gz
|
||||
/redis-2.8.14.tar.gz
|
||||
/redis-2.8.15.tar.gz
|
||||
/redis-2.8.17.tar.gz
|
||||
/redis-2.8.18.tar.gz
|
||||
/redis-2.8.19.tar.gz
|
||||
/redis-3.0.0.tar.gz
|
||||
/redis-3.0.1.tar.gz
|
||||
/redis-3.0.2.tar.gz
|
||||
/redis-3.0.3.tar.gz
|
||||
/redis-3.0.4.tar.gz
|
||||
/redis-3.0.5.tar.gz
|
||||
/redis-3.0.6.tar.gz
|
||||
/redis-3.2.3.tar.gz
|
||||
|
43
0001-redis-3.2.3-redis-conf.patch
Normal file
43
0001-redis-3.2.3-redis-conf.patch
Normal file
@ -0,0 +1,43 @@
|
||||
From 2875336337c14d15878fcc36de83cea350fc47f1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Fri, 5 Dec 2014 14:11:15 +0100
|
||||
Subject: [PATCH 1/5] redis 3.2.3: redis conf
|
||||
|
||||
---
|
||||
redis.conf | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/redis.conf b/redis.conf
|
||||
index 22e00bc..46a0154 100644
|
||||
--- a/redis.conf
|
||||
+++ b/redis.conf
|
||||
@@ -147,7 +147,7 @@ supervised no
|
||||
#
|
||||
# Creating a pid file is best effort: if Redis is not able to create it
|
||||
# nothing bad happens, the server will start and run normally.
|
||||
-pidfile /var/run/redis_6379.pid
|
||||
+pidfile /var/run/redis/redis.pid
|
||||
|
||||
# Specify the server verbosity level.
|
||||
# This can be one of:
|
||||
@@ -160,7 +160,7 @@ loglevel notice
|
||||
# Specify the log file name. Also the empty string can be used to force
|
||||
# Redis to log on the standard output. Note that if you use standard
|
||||
# output for logging but daemonize, logs will be sent to /dev/null
|
||||
-logfile ""
|
||||
+logfile /var/log/redis/redis.log
|
||||
|
||||
# To enable logging to the system logger, just set 'syslog-enabled' to yes,
|
||||
# and optionally update the other syslog parameters to suit your needs.
|
||||
@@ -244,7 +244,7 @@ dbfilename dump.rdb
|
||||
# The Append Only File will also be created inside this directory.
|
||||
#
|
||||
# Note that you must specify a directory here, not a file name.
|
||||
-dir ./
|
||||
+dir /var/lib/redis
|
||||
|
||||
################################# REPLICATION #################################
|
||||
|
||||
--
|
||||
2.9.0
|
||||
|
53
0002-redis-3.2.3-deps-library-fPIC-performance-tuning.patch
Normal file
53
0002-redis-3.2.3-deps-library-fPIC-performance-tuning.patch
Normal file
@ -0,0 +1,53 @@
|
||||
From 0a7d1df14b256dc77249f8d5d0d483b1b4a6c97d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Mon, 8 Dec 2014 10:02:54 +0100
|
||||
Subject: [PATCH 2/5] redis 3.2.3: deps library fPIC performance tuning
|
||||
|
||||
---
|
||||
deps/Makefile | 2 +-
|
||||
deps/geohash-int/Makefile | 2 +-
|
||||
deps/linenoise/Makefile | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/deps/Makefile b/deps/Makefile
|
||||
index 1c10bce..14839de 100644
|
||||
--- a/deps/Makefile
|
||||
+++ b/deps/Makefile
|
||||
@@ -59,7 +59,7 @@ ifeq ($(uname_S),SunOS)
|
||||
LUA_CFLAGS= -D__C99FEATURES__=1
|
||||
endif
|
||||
|
||||
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS)
|
||||
+LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS) -fPIC
|
||||
LUA_LDFLAGS+= $(LDFLAGS)
|
||||
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
|
||||
# challenging to cross-compile lua (and redis). These defines make it easier
|
||||
diff --git a/deps/geohash-int/Makefile b/deps/geohash-int/Makefile
|
||||
index b7c2595..d8b5b40 100644
|
||||
--- a/deps/geohash-int/Makefile
|
||||
+++ b/deps/geohash-int/Makefile
|
||||
@@ -2,7 +2,7 @@ STD=
|
||||
WARN= -Wall
|
||||
OPT= -O2
|
||||
|
||||
-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
|
||||
+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
|
||||
R_LDFLAGS= $(LDFLAGS)
|
||||
DEBUG= -g
|
||||
|
||||
diff --git a/deps/linenoise/Makefile b/deps/linenoise/Makefile
|
||||
index 1dd894b..712f2a6 100644
|
||||
--- a/deps/linenoise/Makefile
|
||||
+++ b/deps/linenoise/Makefile
|
||||
@@ -2,7 +2,7 @@ STD=
|
||||
WARN= -Wall
|
||||
OPT= -Os
|
||||
|
||||
-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
|
||||
+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
|
||||
R_LDFLAGS= $(LDFLAGS)
|
||||
DEBUG= -g
|
||||
|
||||
--
|
||||
2.9.0
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 2d056b8da3fb3ee4480b7849eefae6637e9ed22c Mon Sep 17 00:00:00 2001
|
||||
From 851ea8154a2a8e974d1588be3d6d38262ca2ae33 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Mon, 8 Dec 2014 10:04:18 +0100
|
||||
Subject: [PATCH 4/5] redis 2.8.18: disable test failed on slow machine
|
||||
@ -8,10 +8,10 @@ Subject: [PATCH 4/5] redis 2.8.18: disable test failed on slow machine
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/tests/test_helper.tcl b/tests/test_helper.tcl
|
||||
index d1ebde1..369ebc2 100644
|
||||
index 9a6e673..0891619 100644
|
||||
--- a/tests/test_helper.tcl
|
||||
+++ b/tests/test_helper.tcl
|
||||
@@ -33,7 +33,6 @@ set ::all_tests {
|
||||
@@ -36,7 +36,6 @@ set ::all_tests {
|
||||
integration/replication-2
|
||||
integration/replication-3
|
||||
integration/replication-4
|
||||
@ -20,5 +20,5 @@ index d1ebde1..369ebc2 100644
|
||||
integration/rdb
|
||||
integration/convert-zipmap-hash-on-load
|
||||
--
|
||||
2.1.0
|
||||
2.9.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 35e87543975c05e3f4d07de7c1dba2f7b88add59 Mon Sep 17 00:00:00 2001
|
||||
From 9502fee0927389b6feb274f2778dfb0b7b4a1459 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
||||
Date: Sat, 13 Sep 2014 14:03:04 +0200
|
||||
Subject: [PATCH 5/5] redis 2.8.18: sentinel configuration file fix
|
||||
@ -23,5 +23,5 @@ index 39d1044..543d40d 100644
|
||||
|
||||
|
||||
--
|
||||
2.1.0
|
||||
2.9.0
|
||||
|
||||
|
@ -17,6 +17,7 @@ CONFIG_FILE="/etc/$SERVICE_NAME.conf"
|
||||
# Use awk to retrieve host, port from config file
|
||||
HOST=`awk '/^[[:blank:]]*bind/ { print $2 }' $CONFIG_FILE`
|
||||
PORT=`awk '/^[[:blank:]]*port/ { print $2 }' $CONFIG_FILE`
|
||||
PASS=`awk '/^[[:blank:]]*requirepass/ { print $2 }' $CONFIG_FILE`
|
||||
|
||||
# Just in case, use default host, port
|
||||
HOST=${HOST:-127.0.0.1}
|
||||
@ -26,5 +27,9 @@ else
|
||||
PORT=${PORT:-26739}
|
||||
fi
|
||||
|
||||
# Setup additional parameters
|
||||
# e.g password-protected redis instances
|
||||
[ -z "$PASS" ] || ADDITIONAL_PARAMS="-a $PASS"
|
||||
|
||||
# shutdown the service properly
|
||||
$REDIS_CLI -h $HOST -p $PORT shutdown
|
||||
$REDIS_CLI -h $HOST -p $PORT $ADDITIONAL_PARAMS shutdown
|
||||
|
@ -1,4 +1,4 @@
|
||||
/var/log/redis/redis.log {
|
||||
/var/log/redis/*.log {
|
||||
weekly
|
||||
rotate 10
|
||||
copytruncate
|
||||
|
101
redis.spec
101
redis.spec
@ -11,8 +11,8 @@
|
||||
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
|
||||
|
||||
Name: redis
|
||||
Version: 2.8.19
|
||||
Release: 2%{?dist}
|
||||
Version: 3.2.3
|
||||
Release: 1%{?dist}
|
||||
Summary: A persistent key-value database
|
||||
License: BSD
|
||||
URL: http://redis.io
|
||||
@ -32,8 +32,8 @@ Source9: %{name}-limit-init
|
||||
# Then refresh your patches
|
||||
# git format-patch HEAD~<number of expected patches>
|
||||
# Update configuration for Fedora
|
||||
Patch0001: 0001-redis-2.8.18-redis-conf.patch
|
||||
Patch0002: 0002-redis-2.8.18-deps-library-fPIC-performance-tuning.patch
|
||||
Patch0001: 0001-redis-3.2.3-redis-conf.patch
|
||||
Patch0002: 0002-redis-3.2.3-deps-library-fPIC-performance-tuning.patch
|
||||
Patch0003: 0003-redis-2.8.18-use-system-jemalloc.patch
|
||||
# tests/integration/replication-psync.tcl failed on slow machines(GITHUB #1417)
|
||||
Patch0004: 0004-redis-2.8.18-disable-test-failed-on-slow-machine.patch
|
||||
@ -198,10 +198,11 @@ chkconfig --add %{name}-sentinel
|
||||
%systemd_preun %{name}-sentinel.service
|
||||
%else
|
||||
if [ $1 -eq 0 ] ; then
|
||||
service %{name} stop &> /dev/null
|
||||
chkconfig --del %{name} &> /dev/null
|
||||
service %{name}-sentinel stop &> /dev/null
|
||||
chkconfig --del %{name}-sentinel &> /dev/null
|
||||
service %{name} stop &> /dev/null
|
||||
chkconfig --del %{name} &> /dev/null
|
||||
service %{name}-sentinel stop &> /dev/null
|
||||
chkconfig --del %{name}-sentinel &> /dev/null
|
||||
fi
|
||||
%endif
|
||||
|
||||
%postun
|
||||
@ -218,7 +219,7 @@ fi
|
||||
%files
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
|
||||
%doc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README.md
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
|
||||
%attr(0644, redis, root) %config(noreplace) %{_sysconfdir}/%{name}.conf
|
||||
%attr(0644, redis, root) %config(noreplace) %{_sysconfdir}/%{name}-sentinel.conf
|
||||
@ -240,19 +241,72 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/security/limits.d/95-%{name}.conf
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 4 2016 Haïkel Guémar <hguemar@fedoraproject.org> - 3.2.3-1
|
||||
- Upstream 3.2.3
|
||||
- Security fix for CVE-2013-7458 (redis-cli history world readable)
|
||||
- RHBZ#1363670 RHBZ#1363671
|
||||
|
||||
* Mon Feb 8 2016 Haïkel Guémar <hguemar@fedoraproject.org> - 3.0.6-3
|
||||
- Fix redis-shutdown to handle password-protected instances shutdown
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Sat Dec 19 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 3.0.6-1
|
||||
- Upstream 3.0.6 (RHBZ#1272281)
|
||||
|
||||
* Fri Oct 16 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 3.0.5-1
|
||||
- Upstream 3.0.5
|
||||
- Fix slave/master replication hanging forever in certain case
|
||||
|
||||
* Mon Sep 07 2015 Christopher Meng <rpm@cicku.me> - 3.0.4-1
|
||||
- Update to 3.0.4
|
||||
|
||||
* Sun Aug 30 2015 Christopher Meng <rpm@cicku.me> - 3.0.3-2
|
||||
- Rebuilt for jemalloc 4.0.0
|
||||
|
||||
* Tue Jul 21 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 3.0.3-1
|
||||
- Upstream 3.0.3
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Jun 04 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 3.0.2-1
|
||||
- Upstream 3.0.2 (RHBZ #1228245)
|
||||
- Fix Lua sandbox escape and arbitrary code execution (RHBZ #1228331)
|
||||
|
||||
* Sat May 09 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 3.0.1-1
|
||||
- Upstream 3.0.1 (RHBZ #1208322)
|
||||
|
||||
* Tue Apr 14 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-2
|
||||
- rotate /var/log/redis/sentinel.log
|
||||
|
||||
* Thu Apr 2 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 3.0.0-1
|
||||
- Upstream 3.0.0 (RHBZ #1208322)
|
||||
|
||||
* Thu Mar 26 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.19-2
|
||||
- Fix redis-shutdown on multiple NIC setup (RHBZ #1201237)
|
||||
|
||||
* Thu Feb 26 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.19-1
|
||||
* Fri Feb 27 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.19-1
|
||||
- Upstream 2.8.19 (RHBZ #1175232)
|
||||
- Fix permissions (RHBZ #1182913)
|
||||
- Add limits config file
|
||||
- Fix permissions for tmpfiles (RHBZ #1182913)
|
||||
- Add limits config files
|
||||
- Spec cleanups
|
||||
|
||||
* Tue Dec 09 2014 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.18-1
|
||||
* Fri Dec 05 2014 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.18-1
|
||||
- Upstream 2.8.18
|
||||
- Backport init scripts fixes from rawhide
|
||||
- Rebased patches
|
||||
|
||||
* Sat Sep 20 2014 Remi Collet <remi@fedoraproject.org> - 2.8.17-1
|
||||
- Upstream 2.8.17
|
||||
- fix redis-sentinel service unit file for systemd
|
||||
- fix redis-shutdown for sentinel
|
||||
- also use redis-shutdown in init scripts
|
||||
|
||||
* Wed Sep 17 2014 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.15-2
|
||||
- Minor fix to redis-shutdown (from Remi Collet)
|
||||
|
||||
* Sat Sep 13 2014 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.15-1
|
||||
- Upstream 2.8.15 (critical bugfix for sentinel)
|
||||
@ -265,25 +319,10 @@ fi
|
||||
- Backport fixes from Remi Collet repository (ie: sentinel working)
|
||||
|
||||
* Thu Sep 11 2014 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.14-1
|
||||
- Upstream 2.8.14
|
||||
- Upstream 2.8.14 (RHBZ #1136287)
|
||||
- Bugfix for lua scripting users (server crash)
|
||||
- Refresh patches
|
||||
|
||||
* Tue Jul 29 2014 Warren Togami <warren@slickage.com> - 2.8.13-3
|
||||
- Revert rename redis.service to redis-server (4 years as packaged service name).
|
||||
- Revert "daemonize yes" in default redis.conf
|
||||
systemd handles background and process tracking on its own, this broke systemd launch.
|
||||
- Revert redis.init as it too handled daemonizing.
|
||||
- Revert tcp-keepalive default to 0.
|
||||
- Revert ExecStartPre hack, /var/lib/redis is owned by the package.
|
||||
No %ghost directories, just own it.
|
||||
- FIXME: sentinel is broken, mispackaged and quite possibly belongs in an entirely separate package
|
||||
because it is not meant to be used concurrently with the ordinary systemd redis and it requires
|
||||
a highly specialized custom configuration.
|
||||
|
||||
* Wed Jul 23 2014 Warren Togami <warren@slickage.com> - 2.8.13-2
|
||||
- Fix detection of EL7: systemd unit was missing
|
||||
- Fix detection of EL5
|
||||
- backport spec from EPEL7 (thanks Warren)
|
||||
|
||||
* Wed Jul 16 2014 Christopher Meng <rpm@cicku.me> - 2.8.13-1
|
||||
- Update to 2.8.13
|
||||
|
Loading…
Reference in New Issue
Block a user