Upstream 2.8.14

- Bugfix for lua scripting users (server crash)
- Refresh patches
This commit is contained in:
Haïkel Guémar 2014-09-11 14:01:43 +02:00
parent 0e9ad48734
commit 0f697cdea9
7 changed files with 85 additions and 29 deletions

1
.gitignore vendored
View File

@ -15,3 +15,4 @@
/redis-2.8.11.tar.gz
/redis-2.8.12.tar.gz
/redis-2.8.13.tar.gz
/redis-2.8.14.tar.gz

View File

@ -1,7 +1,17 @@
Index: redis-2.8.11/deps/Makefile
===================================================================
--- redis-2.8.11.orig/deps/Makefile
+++ redis-2.8.11/deps/Makefile
From 654ea4a4536bd154a58588ede616fe7ddb3b01a1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
Date: Thu, 11 Sep 2014 13:40:54 +0200
Subject: [PATCH 2/4] patch1
---
deps/Makefile | 2 +-
deps/linenoise/Makefile | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/deps/Makefile b/deps/Makefile
index e183ede..9dcb6b1 100644
--- a/deps/Makefile
+++ b/deps/Makefile
@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
LUA_CFLAGS= -D__C99FEATURES__=1
endif
@ -9,12 +19,12 @@ Index: redis-2.8.11/deps/Makefile
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
+LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS) -fPIC
LUA_LDFLAGS+= $(LDFLAGS)
lua: .make-prerequisites
Index: redis-2.8.11/deps/linenoise/Makefile
===================================================================
--- redis-2.8.11.orig/deps/linenoise/Makefile
+++ redis-2.8.11/deps/linenoise/Makefile
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
# challenging to cross-compile lua (and redis). These defines make it easier
diff --git a/deps/linenoise/Makefile b/deps/linenoise/Makefile
index 1dd894b..712f2a6 100644
--- a/deps/linenoise/Makefile
+++ b/deps/linenoise/Makefile
@@ -2,7 +2,7 @@ STD=
WARN= -Wall
OPT= -Os
@ -24,3 +34,6 @@ Index: redis-2.8.11/deps/linenoise/Makefile
R_LDFLAGS= $(LDFLAGS)
DEBUG= -g
--
1.9.3

View File

@ -1,7 +1,16 @@
Index: redis-2.8.11/tests/test_helper.tcl
===================================================================
--- redis-2.8.11.orig/tests/test_helper.tcl
+++ redis-2.8.11/tests/test_helper.tcl
From 88d8fa644b2d2fa73802d22fb710181e04c80496 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
Date: Thu, 11 Sep 2014 13:42:01 +0200
Subject: [PATCH 4/4] patch3
---
tests/test_helper.tcl | 1 -
1 file changed, 1 deletion(-)
diff --git a/tests/test_helper.tcl b/tests/test_helper.tcl
index 5f958e5..bcd258a 100644
--- a/tests/test_helper.tcl
+++ b/tests/test_helper.tcl
@@ -33,7 +33,6 @@ set ::all_tests {
integration/replication-2
integration/replication-3
@ -10,3 +19,6 @@ Index: redis-2.8.11/tests/test_helper.tcl
integration/aof
integration/rdb
integration/convert-zipmap-hash-on-load
--
1.9.3

View File

@ -1,7 +1,17 @@
diff -urN redis-2.8.13.orig/redis.conf redis-2.8.13/redis.conf
--- redis-2.8.13.orig/redis.conf 2014-07-14 05:48:14.000000000 -1000
+++ redis-2.8.13/redis.conf 2014-07-29 02:35:49.053847503 -1000
@@ -38,7 +38,7 @@
From 7a50ab1720aba8fb9efc3be1ac354dfe726ef6d8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
Date: Thu, 11 Sep 2014 13:40:31 +0200
Subject: [PATCH 1/4] patch0
---
redis.conf | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/redis.conf b/redis.conf
index 9209ed3..d22e705 100644
--- a/redis.conf
+++ b/redis.conf
@@ -38,7 +38,7 @@ daemonize no
# When running daemonized, Redis writes a pid file in /var/run/redis.pid by
# default. You can specify a custom pid file location here.
@ -10,7 +20,7 @@ diff -urN redis-2.8.13.orig/redis.conf redis-2.8.13/redis.conf
# Accept connections on the specified port, default is 6379.
# If port 0 is specified Redis will not listen on a TCP socket.
@@ -61,7 +61,7 @@
@@ -61,7 +61,7 @@ tcp-backlog 511
# Examples:
#
# bind 192.168.1.100 10.0.0.1
@ -19,7 +29,7 @@ diff -urN redis-2.8.13.orig/redis.conf redis-2.8.13/redis.conf
# Specify the path for the Unix socket that will be used to listen for
# incoming connections. There is no default, so Redis will not listen
@@ -100,7 +100,7 @@
@@ -100,7 +100,7 @@ loglevel notice
# Specify the log file name. Also the empty string can be used to force
# Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
@ -28,7 +38,7 @@ diff -urN redis-2.8.13.orig/redis.conf redis-2.8.13/redis.conf
# To enable logging to the system logger, just set 'syslog-enabled' to yes,
# and optionally update the other syslog parameters to suit your needs.
@@ -184,7 +184,7 @@
@@ -184,7 +184,7 @@ dbfilename dump.rdb
# The Append Only File will also be created inside this directory.
#
# Note that you must specify a directory here, not a file name.
@ -37,3 +47,6 @@ diff -urN redis-2.8.13.orig/redis.conf redis-2.8.13/redis.conf
################################# REPLICATION #################################
--
1.9.3

View File

@ -1,8 +1,17 @@
Index: redis-2.8.11/src/Makefile
===================================================================
--- redis-2.8.11.orig/src/Makefile
+++ redis-2.8.11/src/Makefile
@@ -84,8 +84,8 @@ endif
From cfc0d8db5d3ca86aff0c2707d51b9180c407f258 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
Date: Thu, 11 Sep 2014 13:41:17 +0200
Subject: [PATCH 3/4] patch2
---
src/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/Makefile b/src/Makefile
index 8b3e959..af6a4fe 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -90,8 +90,8 @@ endif
ifeq ($(MALLOC),jemalloc)
DEPENDENCY_TARGETS+= jemalloc
@ -13,3 +22,6 @@ Index: redis-2.8.11/src/Makefile
endif
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
--
1.9.3

View File

@ -23,8 +23,8 @@
%endif
Name: redis
Version: 2.8.13
Release: 3%{?dist}
Version: 2.8.14
Release: 1%{?dist}
Summary: A persistent caching system, key-value and data structures database
License: BSD
URL: http://redis.io
@ -249,6 +249,11 @@ fi
%endif
%changelog
* Thu Sep 11 2014 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8.14-1
- Upstream 2.8.14
- Bugfix for lua scripting users (server crash)
- Refresh patches
* Tue Jul 29 2014 Warren Togami <warren@slickage.com> - 2.8.13-3
- Revert rename redis.service to redis-server (4 years as packaged service name).
- Revert "daemonize yes" in default redis.conf

View File

@ -1 +1 @@
ea92053cbb6f4eb8a4347dbaac7d7dff redis-2.8.13.tar.gz
5005c764bf8760ef661c8b198bb01780 redis-2.8.14.tar.gz