add macros defining arches so language stacks can add new arches without adding the arches to every spec file

macros are needed at srpm creation time so live here
This commit is contained in:
Dennis Gilmore 2011-05-27 11:30:20 -05:00
parent f6ccdd625f
commit 1e51f9b0b7
2 changed files with 43 additions and 1 deletions

View File

@ -0,0 +1,32 @@
diff -uNr redhat-rpm-config-9.1.0-orig/macros.ghc redhat-rpm-config-9.1.0/macros.ghc
--- redhat-rpm-config-9.1.0-orig/macros.ghc 1969-12-31 18:00:00.000000000 -0600
+++ redhat-rpm-config-9.1.0/macros.ghc 2011-05-27 10:19:29.504287354 -0500
@@ -0,0 +1,2 @@
+# macro defining the archs that ghc runs on in fedora
+%ghc_arches %{ix86} x86_64 ppc ppc64 alpha sparcv9
diff -uNr redhat-rpm-config-9.1.0-orig/macros.mono redhat-rpm-config-9.1.0/macros.mono
--- redhat-rpm-config-9.1.0-orig/macros.mono 1969-12-31 18:00:00.000000000 -0600
+++ redhat-rpm-config-9.1.0/macros.mono 2011-05-27 10:59:00.348201750 -0500
@@ -0,0 +1,2 @@
+# arches that mono builds on
+%mono_arches %{ix86} x86_64 sparc sparcv9 ia64 %{arm} alpha s390x ppc ppc64
diff -uNr redhat-rpm-config-9.1.0-orig/macros.ocaml redhat-rpm-config-9.1.0/macros.ocaml
--- redhat-rpm-config-9.1.0-orig/macros.ocaml 1969-12-31 18:00:00.000000000 -0600
+++ redhat-rpm-config-9.1.0/macros.ocaml 2011-05-27 10:42:10.638194240 -0500
@@ -0,0 +1,2 @@
+# arches that ocaml runs on
+%ocaml_arches alpha %{arm} %{ix86} ia64 x86_64 ppc sparc sparcv9 ppc64
diff -uNr redhat-rpm-config-9.1.0-orig/Makefile redhat-rpm-config-9.1.0/Makefile
--- redhat-rpm-config-9.1.0-orig/Makefile 2010-02-02 03:24:04.000000000 -0600
+++ redhat-rpm-config-9.1.0/Makefile 2011-05-27 10:43:34.898205307 -0500
@@ -11,7 +11,10 @@
install:
mkdir -p $(DESTDIR)/usr/lib/rpm/redhat
cp -pr * $(DESTDIR)/usr/lib/rpm/redhat/
+ mkdir -p $(DESTDIR)/etc/rpm
+ cp -pr macros.* $(DESTDIR)/etc/rpm/
rm -f $(DESTDIR)/usr/lib/rpm/redhat/Makefile
+ rm -f $(DESTDIR)/usr/lib/rpm/redhat/macros.*
tag-archive:
@git tag -a $(CVSTAG) -m "$(NAME)-$(VERSION) release"

View File

@ -1,7 +1,7 @@
Summary: Red Hat specific rpm configuration files
Name: redhat-rpm-config
Version: 9.1.0
Release: 5%{?dist}
Release: 6%{?dist}
# No version specified.
License: GPL+
Group: Development/System
@ -11,6 +11,12 @@ Patch0: redhat-rpm-config-9.1.0-strict-python-bytecompile.patch
Patch1: redhat-rpm-config-9.1.0-fix-requires.patch
Patch2: redhat-rpm-config-9.1.0-no-strip-note.patch
Patch3: redhat-rpm-config-9.1.0-pkgconfig-private.patch
# the macros defined by this patch are for things that need to be defined
# at srpm creation time when it is not feasable to require the base packages
# that would otherwise be providing the macros. other language/arch specific
# macros should not be defined here but instead in the base packages that can
# be pulled in at rpm build time, this is specific for srpm creation.
Patch4: redhat-rpm-config-9.1.0-arches-macros.patch
BuildArch: noarch
Requires: mktemp
Requires: rpm >= 4.6.0
@ -26,6 +32,7 @@ Red Hat specific rpm configuration files.
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%build
@ -45,6 +52,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_prefix}/lib/rpm/redhat
%changelog
* Fri May 28 2011 Dennis Gilmore <dennis@ausil.us> - 9.1.0-6
- add some specific macros needed at srpm creation time
* Thu May 27 2010 Panu Matilainen <pmatilai@redhat.com> - 9.1.0-5
- adjust to new pkg-config behavior wrt private dependencies (#596433)