Migrate to rawhide
This commit is contained in:
parent
c65e2a77a6
commit
3ba56c063d
@ -1,2 +1,3 @@
|
||||
lsb-release-1.4.tar.gz
|
||||
redhat-lsb-1.3.tar.bz2
|
||||
redhat-lsb-3.0-1.tar.bz2
|
||||
|
26
lsb-release-2.0-disable-etc-lsb-release.patch
Normal file
26
lsb-release-2.0-disable-etc-lsb-release.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- lsb-release-2.0.orig/lsb_release 2004-07-01 03:30:34.000000000 +1000
|
||||
+++ lsb-release-2.0/lsb_release 2005-08-03 23:31:58.000000000 +1000
|
||||
@@ -188,15 +188,6 @@
|
||||
|
||||
# Get/Init LSB infos (maybe Distrib infos too)
|
||||
GetLSBInfo() {
|
||||
- if [ -f "$INFO_ROOT/$INFO_LSB_FILE" ]
|
||||
- then
|
||||
- # should init at least LSB_VERSION
|
||||
- . "$INFO_ROOT/$INFO_LSB_FILE"
|
||||
- fi
|
||||
- if [ -z "$LSB_VERSION" ]
|
||||
- then
|
||||
- LSB_VERSION=$MSG_NA
|
||||
- else
|
||||
# if we found LSB_VERSION, continue to look in directory
|
||||
if [ -d "$INFO_ROOT/$INFO_LSB_DIR" ]
|
||||
then
|
||||
@@ -205,7 +196,6 @@
|
||||
LSB_VERSION=$LSB_VERSION:`basename $tag`
|
||||
done
|
||||
fi
|
||||
- fi
|
||||
}
|
||||
|
||||
# Get the whole distrib information string (from ARG $1 file)
|
BIN
lsb-release-2.0.tar.gz
Normal file
BIN
lsb-release-2.0.tar.gz
Normal file
Binary file not shown.
156
redhat-lsb.spec
156
redhat-lsb.spec
@ -1,5 +1,5 @@
|
||||
# Define this to link to which library version
|
||||
%define lsbsover 1 2
|
||||
%define lsbsover 3
|
||||
|
||||
%ifarch %{ix86}
|
||||
%define ldso ld-linux.so.2
|
||||
@ -42,48 +42,49 @@
|
||||
%define qual %{nil}
|
||||
%endif
|
||||
|
||||
%define lsbrelver 1.4
|
||||
%define lsbrelver 2.0
|
||||
%define srcrelease 1
|
||||
|
||||
Summary: LSB support for Red Hat Linux
|
||||
Name: redhat-lsb
|
||||
Version: 1.3
|
||||
Release: 10.1
|
||||
Version: 3.0
|
||||
Release: 9
|
||||
URL: http://www.linuxbase.org/
|
||||
Source0: %{name}-%{version}.tar.bz2
|
||||
Source0: %{name}-%{version}-%{srcrelease}.tar.bz2
|
||||
Source1: http://prdownloads.sourceforge.net/lsb/lsb-release-%{lsbrelver}.tar.gz
|
||||
Patch0: lsb-release-2.0-disable-etc-lsb-release.patch
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
# dependency for primary LSB application for v1.3
|
||||
Provides: lsb = %{version}
|
||||
# dependency for primary LSB application for v2.0
|
||||
# dependency for primary LSB application for v2.0 and v3.0
|
||||
%ifarch %{ix86}
|
||||
Provides: lsb-core-ia32 = %{version}
|
||||
%define archname ia32
|
||||
%endif
|
||||
%ifarch ia64
|
||||
Provides: lsb-core-ia64 = %{version}
|
||||
%define archname ia64
|
||||
%endif
|
||||
%ifarch ppc
|
||||
Provides: lsb-core-ppc32 = %{version}
|
||||
%define archname ppc32
|
||||
%endif
|
||||
%ifarch ppc64
|
||||
Provides: lsb-core-ppc64 = %{version}
|
||||
%define archname ppc64
|
||||
%endif
|
||||
%ifarch s390
|
||||
Provides: lsb-core-s390 = %{version}
|
||||
%define archname s390
|
||||
%endif
|
||||
%ifarch s390x
|
||||
Provides: lsb-core-s390x = %{version}
|
||||
%define archname s390x
|
||||
%endif
|
||||
%ifarch x86_64
|
||||
Provides: lsb-core-amd64 = %{version}
|
||||
%define archname amd64
|
||||
%endif
|
||||
Provides: lsb-core-%{archname} = %{version}
|
||||
Provides: lsb-graphics-%{archname} = %{version}
|
||||
Provides: lsb-core-noarch = %{version}
|
||||
Provides: lsb-graphics-noarch = %{version}
|
||||
|
||||
%ifarch ia64 ppc64 s390x x86_64
|
||||
%define qual ()(64bit)
|
||||
%else
|
||||
%define qual %{nil}
|
||||
%endif
|
||||
ExclusiveArch: i386 ia64 x86_64 ppc ppc64 s390 s390x
|
||||
|
||||
%ifarch %{ix86}
|
||||
@ -91,6 +92,7 @@ ExclusiveArch: i386 ia64 x86_64 ppc ppc64 s390 s390x
|
||||
Requires: libcrypt.so.1
|
||||
Requires: libc.so.6
|
||||
Requires: libdl.so.2
|
||||
Requires: libgcc_s.so.1
|
||||
Requires: libm.so.6
|
||||
Requires: libpthread.so.0
|
||||
%endif
|
||||
@ -100,6 +102,7 @@ Requires: libpthread.so.0
|
||||
Requires: libcrypt.so.1()(64bit)
|
||||
Requires: libc.so.6.1()(64bit)
|
||||
Requires: libdl.so.2()(64bit)
|
||||
Requires: libgcc_s.so.1()(64bit)
|
||||
Requires: libm.so.6.1()(64bit)
|
||||
Requires: libpthread.so.0()(64bit)
|
||||
%endif
|
||||
@ -109,6 +112,7 @@ Requires: libpthread.so.0()(64bit)
|
||||
Requires: libcrypt.so.1
|
||||
Requires: libc.so.6
|
||||
Requires: libdl.so.2
|
||||
Requires: libgcc_s.so.1
|
||||
Requires: libm.so.6
|
||||
Requires: libpthread.so.0
|
||||
%endif
|
||||
@ -118,6 +122,7 @@ Requires: libpthread.so.0
|
||||
Requires: libcrypt.so.1()(64bit)
|
||||
Requires: libc.so.6()(64bit)
|
||||
Requires: libdl.so.2()(64bit)
|
||||
Requires: libgcc_s.so.1()(64bit)
|
||||
Requires: libm.so.6()(64bit)
|
||||
Requires: libpthread.so.0()(64bit)
|
||||
%endif
|
||||
@ -127,6 +132,7 @@ Requires: libpthread.so.0()(64bit)
|
||||
Requires: libcrypt.so.1
|
||||
Requires: libc.so.6
|
||||
Requires: libdl.so.2
|
||||
Requires: libgcc_s.so.1
|
||||
Requires: libm.so.6
|
||||
Requires: libpthread.so.0
|
||||
%endif
|
||||
@ -136,15 +142,17 @@ Requires: libpthread.so.0
|
||||
Requires: libcrypt.so.1()(64bit)
|
||||
Requires: libc.so.6()(64bit)
|
||||
Requires: libdl.so.2()(64bit)
|
||||
Requires: libgcc_s.so.1()(64bit)
|
||||
Requires: libm.so.6()(64bit)
|
||||
Requires: libpthread.so.0()(64bit)
|
||||
%endif
|
||||
|
||||
%ifarch x86_64
|
||||
# archLSB X86-64 Base Libraries
|
||||
# archLSB AMD64 Base Libraries
|
||||
Requires: libcrypt.so.1()(64bit)
|
||||
Requires: libc.so.6()(64bit)
|
||||
Requires: libdl.so.2()(64bit)
|
||||
Requires: libgcc_s.so.1()(64bit)
|
||||
Requires: libm.so.6()(64bit)
|
||||
Requires: libpthread.so.0()(64bit)
|
||||
%endif
|
||||
@ -153,9 +161,13 @@ Requires: libpthread.so.0()(64bit)
|
||||
Requires: libpthread.so.0%{qual}
|
||||
Requires: libgcc_s.so.1%{qual}
|
||||
Requires: libdl.so.2%{qual}
|
||||
Requires: librt.so.1%{qual}
|
||||
Requires: libcrypt.so.1%{qual}
|
||||
Requires: libpam.so.0%{qual}
|
||||
|
||||
# LSB Base C++
|
||||
Requires: libstdc++.so.6%{qual}
|
||||
|
||||
# gLSB Utility Libraries
|
||||
Requires: libz.so.1%{qual}
|
||||
Requires: libncurses.so.5%{qual}
|
||||
@ -163,14 +175,14 @@ Requires: libutil.so.1%{qual}
|
||||
|
||||
# gLSB Graphics Libraries
|
||||
Requires: libX11.so.6%{qual}
|
||||
Requires: libXext.so.6%{qual}
|
||||
Requires: libSM.so.6%{qual}
|
||||
Requires: libICE.so.6%{qual}
|
||||
Requires: libXt.so.6%{qual}
|
||||
Requires: libXext.so.6%{qual}
|
||||
Requires: libXi.so.6%{qual}
|
||||
Requires: libGL.so.1%{qual}
|
||||
|
||||
# gLSB Command and Utilities
|
||||
Requires: /bin/awk
|
||||
Requires: /bin/basename
|
||||
Requires: /bin/cat
|
||||
Requires: /bin/chgrp
|
||||
@ -178,24 +190,21 @@ Requires: /bin/chmod
|
||||
Requires: /bin/chown
|
||||
Requires: /bin/cp
|
||||
Requires: /bin/cpio
|
||||
Requires: /bin/cut
|
||||
Requires: /bin/date
|
||||
Requires: /bin/dd
|
||||
Requires: /bin/df
|
||||
Requires: /bin/dmesg
|
||||
Requires: /bin/echo
|
||||
Requires: /bin/ed
|
||||
Requires: /bin/egrep
|
||||
Requires: /bin/env
|
||||
Requires: /bin/false
|
||||
Requires: /bin/fgrep
|
||||
Requires: /bin/gettext
|
||||
Requires: /bin/grep
|
||||
Requires: /bin/gunzip
|
||||
Requires: /bin/gzip
|
||||
Requires: /bin/hostname
|
||||
Requires: /bin/kill
|
||||
Requires: /bin/ln
|
||||
Requires: /bin/ls
|
||||
#Requires: /bin/mailx
|
||||
Requires: mailx
|
||||
Requires: /bin/mkdir
|
||||
Requires: /bin/mknod
|
||||
Requires: /bin/mktemp
|
||||
@ -225,6 +234,7 @@ Requires: /sbin/shutdown
|
||||
Requires: /usr/bin/[
|
||||
Requires: /usr/bin/ar
|
||||
Requires: /usr/bin/at
|
||||
Requires: /usr/bin/awk
|
||||
Requires: /usr/bin/batch
|
||||
Requires: /usr/bin/bc
|
||||
Requires: /usr/bin/chfn
|
||||
@ -235,9 +245,11 @@ Requires: /usr/bin/col
|
||||
Requires: /usr/bin/comm
|
||||
Requires: /usr/bin/crontab
|
||||
Requires: /usr/bin/csplit
|
||||
Requires: /usr/bin/cut
|
||||
Requires: /usr/bin/diff
|
||||
Requires: /usr/bin/dirname
|
||||
Requires: /usr/bin/du
|
||||
Requires: /usr/bin/env
|
||||
Requires: /usr/bin/expand
|
||||
Requires: /usr/bin/expr
|
||||
Requires: /usr/bin/file
|
||||
@ -245,7 +257,10 @@ Requires: /usr/bin/find
|
||||
Requires: /usr/bin/fold
|
||||
Requires: /usr/bin/gencat
|
||||
Requires: /usr/bin/getconf
|
||||
Requires: /usr/bin/gettext
|
||||
Requires: /usr/bin/groups
|
||||
Requires: /usr/bin/gunzip
|
||||
Requires: /usr/bin/gzip
|
||||
Requires: /usr/bin/head
|
||||
Requires: /usr/bin/iconv
|
||||
Requires: /usr/bin/id
|
||||
@ -253,10 +268,13 @@ Requires: /usr/bin/install
|
||||
Requires: /usr/bin/ipcrm
|
||||
Requires: /usr/bin/ipcs
|
||||
Requires: /usr/bin/join
|
||||
Requires: /usr/bin/kill
|
||||
Requires: /usr/bin/killall
|
||||
Requires: /usr/bin/locale
|
||||
Requires: /usr/bin/localedef
|
||||
Requires: /usr/bin/logger
|
||||
Requires: /usr/bin/logname
|
||||
Requires: /usr/bin/lp
|
||||
Requires: /usr/bin/lpr
|
||||
Requires: /usr/bin/m4
|
||||
Requires: /usr/bin/make
|
||||
@ -272,13 +290,12 @@ Requires: /usr/bin/passwd
|
||||
Requires: /usr/bin/paste
|
||||
Requires: /usr/bin/patch
|
||||
Requires: /usr/bin/pathchk
|
||||
Requires: /usr/bin/pax
|
||||
Requires: /usr/bin/pr
|
||||
Requires: /usr/bin/printf
|
||||
Requires: /usr/bin/renice
|
||||
Requires: /usr/bin/rsync
|
||||
Requires: /usr/bin/split
|
||||
Requires: /usr/bin/strip
|
||||
Requires: /usr/bin/sum
|
||||
Requires: /usr/bin/tail
|
||||
Requires: /usr/bin/tee
|
||||
Requires: /usr/bin/test
|
||||
@ -310,6 +327,7 @@ installed on the system.
|
||||
|
||||
%prep
|
||||
%setup -q -a 1
|
||||
%patch0 -p 0
|
||||
|
||||
%build
|
||||
cd lsb-release-%{lsbrelver}
|
||||
@ -318,59 +336,102 @@ make
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
mkdir -p $RPM_BUILD_ROOT/etc $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT/%{_mandir} \
|
||||
$RPM_BUILD_ROOT/%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb
|
||||
$RPM_BUILD_ROOT/%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
|
||||
$RPM_BUILD_ROOT/etc/lsb-release.d/ $RPM_BUILD_ROOT/usr/sbin/
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
cd lsb-release-%{lsbrelver}
|
||||
make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
|
||||
cd ..
|
||||
cat > $RPM_BUILD_ROOT/etc/lsb-release <<EOF
|
||||
LSB_VERSION="1.3"
|
||||
EOF
|
||||
touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.0-%{archname}
|
||||
touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.0-noarch
|
||||
touch $RPM_BUILD_ROOT/etc/lsb-release.d/graphics-3.0-%{archname}
|
||||
touch $RPM_BUILD_ROOT/etc/lsb-release.d/graphics-3.0-noarch
|
||||
|
||||
for LSBVER in %{lsbsover}; do
|
||||
ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
|
||||
done
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/bin
|
||||
|
||||
ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
|
||||
ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
|
||||
ln -snf mail $RPM_BUILD_ROOT/bin/mailx
|
||||
|
||||
gcc -Os -static -o redhat_lsb_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
|
||||
-DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE
|
||||
install -m 700 redhat_lsb_trigger.%{_target_cpu} \
|
||||
$RPM_BUILD_ROOT/usr/sbin/redhat_lsb_trigger.%{_target_cpu}
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%triggerpostun -- glibc
|
||||
%ifnarch %{ix86}
|
||||
/sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
|
||||
%else
|
||||
if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
|
||||
/sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso} || :
|
||||
else
|
||||
/sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
|
||||
fi
|
||||
%endif
|
||||
if [ -x /usr/sbin/redhat_lsb_trigger.%{_target_cpu} ]; then
|
||||
/usr/sbin/redhat_lsb_trigger.%{_target_cpu}
|
||||
fi
|
||||
|
||||
%ifarch %{ix86}
|
||||
%post
|
||||
# make this softlink again for /emul
|
||||
if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
|
||||
/sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso} || :
|
||||
for LSBVER in %{lsbsover}; do
|
||||
/sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
|
||||
done
|
||||
fi
|
||||
%endif
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%config /etc/lsb-release
|
||||
/etc/redhat-lsb
|
||||
%dir /etc/lsb-release.d
|
||||
/etc/lsb-release.d/*
|
||||
%{_mandir}/*/*
|
||||
%{_bindir}/*
|
||||
/bin/mailx
|
||||
/usr/lib/lsb
|
||||
/lib/lsb
|
||||
/%{_lib}/*
|
||||
/usr/sbin/redhat_lsb_trigger.%{_target_cpu}
|
||||
|
||||
%changelog
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
* Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
|
||||
- Migrated back to rawhide
|
||||
|
||||
* Thu Mar 17 2005 Leon Ho <llch@redhat.com> 1.3-10
|
||||
* Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
|
||||
- Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
|
||||
|
||||
* Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
|
||||
- Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
|
||||
depends on /etc/lsb-release.d/ (Advised by LSB committee)
|
||||
- Removed /etc/lsb-release (Advised by LSB committee)
|
||||
|
||||
* Mon Aug 1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
|
||||
- Made the /etc/lsb-release useful (RH#154605)
|
||||
- Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
|
||||
- Fixed AMD64 base libraries requirement parsing (RH#154605)
|
||||
|
||||
* Fri Jul 29 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
|
||||
- Fixed redhat-lsb's mkredhat-lsb on fetching lib and cmd requirements (RH#154605)
|
||||
- Changed explicit mailx command requirement to package requirements (RH#164124)
|
||||
- Added mailx symlink to /bin/mail (RH#164124)
|
||||
- Added lsb-core-noarch and lsb-graphics-noarch and lsb-graphics-{arch} requirements (RH#164468)
|
||||
- Added requirements from lsb_release command on lsb-release.d and deps. (RH#164468)
|
||||
|
||||
* Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
|
||||
- Rebuilt
|
||||
|
||||
* Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
|
||||
- Disabled support for LSB 1.3 and 2.0
|
||||
|
||||
* Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
|
||||
- Upgraded to lsb-release 2.0
|
||||
|
||||
* Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
|
||||
- Moved to LSB 3.0
|
||||
|
||||
* Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
|
||||
- Fixed ix86 package with ia32 emul support
|
||||
|
||||
* Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
|
||||
- Sync what we have changed on the branches
|
||||
@ -423,4 +484,3 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
|
||||
- Initial build.
|
||||
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user