Upgrade to 1.1.1

This commit is contained in:
leigh123linux 2016-09-28 10:42:12 +01:00
parent f7effb27b5
commit bade14233f
5 changed files with 135 additions and 132 deletions

1
.gitignore vendored
View File

@ -25,3 +25,4 @@
/libtorrent-rasterbar-1.0.8.tar.gz
/libtorrent-rasterbar-1.0.9.tar.gz
/libtorrent-rasterbar-1.1.0.tar.gz
/libtorrent-rasterbar-1.1.1.tar.gz

View File

@ -1,118 +0,0 @@
diff --git a/include/libtorrent/Makefile.am b/include/libtorrent/Makefile.am
index 1dc2866..c7a9f2b 100644
--- a/include/libtorrent/Makefile.am
+++ b/include/libtorrent/Makefile.am
@@ -123,9 +123,6 @@ nobase_include_HEADERS = \
xml_parse.hpp \
\
$(GEOIP_H) \
- tommath.h \
- tommath_class.h \
- tommath_superclass.h \
\
aux_/session_impl.hpp \
\
diff --git a/include/libtorrent/Makefile.in b/include/libtorrent/Makefile.in
index fd47a89..3bc5dce 100644
--- a/include/libtorrent/Makefile.in
+++ b/include/libtorrent/Makefile.in
@@ -153,7 +153,7 @@ am__nobase_include_HEADERS_DIST = address.hpp add_torrent_params.hpp \
udp_tracker_connection.hpp union_endpoint.hpp upnp.hpp \
utp_socket_manager.hpp utp_stream.hpp utf8.hpp version.hpp \
web_connection_base.hpp web_peer_connection.hpp xml_parse.hpp \
- GeoIP.h tommath.h tommath_class.h tommath_superclass.h \
+ GeoIP.h \
aux_/session_impl.hpp extensions/logger.hpp \
extensions/lt_trackers.hpp extensions/metadata_transfer.hpp \
extensions/smart_ban.hpp extensions/ut_metadata.hpp \
@@ -491,9 +491,6 @@ nobase_include_HEADERS = \
xml_parse.hpp \
\
$(GEOIP_H) \
- tommath.h \
- tommath_class.h \
- tommath_superclass.h \
\
aux_/session_impl.hpp \
\
diff --git a/src/Makefile.am b/src/Makefile.am
index a285470..ac378b6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -81,7 +81,6 @@ libtorrent_rasterbar_la_SOURCES = \
lt_trackers.cpp \
magnet_uri.cpp \
metadata_transfer.cpp \
- mpi.c \
natpmp.cpp \
parse_url.cpp \
pe_crypto.cpp \
@@ -129,7 +128,7 @@ libtorrent_rasterbar_la_SOURCES = \
libtorrent_rasterbar_la_LDFLAGS = -version-info $(INTERFACE_VERSION_INFO)
#libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @BOOST_FILESYSTEM_LIB@ @BOOST_THREAD_LIB@ @OPENSSL_LIBS@
-libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @OPENSSL_LIBS@
+libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @OPENSSL_LIBS@ -ltommath
#AM_CXXFLAGS= -ftemplate-depth-100 -I$(top_srcdir)/include @DEBUGFLAGS@ @OPENSSL_INCLUDES@
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/ed25519/src @DEBUGFLAGS@ @OPENSSL_INCLUDES@
diff --git a/src/Makefile.in b/src/Makefile.in
index 2a467f2..4d251cd 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -143,7 +143,7 @@ am__libtorrent_rasterbar_la_SOURCES_DIST = web_connection_base.cpp \
http_stream.cpp http_tracker_connection.cpp i2p_stream.cpp \
identify_client.cpp instantiate_connection.cpp ip_filter.cpp \
ip_voter.cpp lazy_bdecode.cpp logger.cpp lsd.cpp \
- lt_trackers.cpp magnet_uri.cpp metadata_transfer.cpp mpi.c \
+ lt_trackers.cpp magnet_uri.cpp metadata_transfer.cpp \
natpmp.cpp parse_url.cpp pe_crypto.cpp peer_connection.cpp \
piece_picker.cpp packet_buffer.cpp policy.cpp puff.cpp \
random.cpp rss.cpp session.cpp session_impl.cpp settings.cpp \
@@ -196,7 +196,7 @@ am_libtorrent_rasterbar_la_OBJECTS = web_connection_base.lo alert.lo \
http_tracker_connection.lo i2p_stream.lo identify_client.lo \
instantiate_connection.lo ip_filter.lo ip_voter.lo \
lazy_bdecode.lo logger.lo lsd.lo lt_trackers.lo magnet_uri.lo \
- metadata_transfer.lo mpi.lo natpmp.lo parse_url.lo \
+ metadata_transfer.lo natpmp.lo parse_url.lo \
pe_crypto.lo peer_connection.lo piece_picker.lo \
packet_buffer.lo policy.lo puff.lo random.lo rss.lo session.lo \
session_impl.lo settings.lo sha1.lo smart_ban.lo socket_io.lo \
@@ -526,7 +526,6 @@ libtorrent_rasterbar_la_SOURCES = \
lt_trackers.cpp \
magnet_uri.cpp \
metadata_transfer.cpp \
- mpi.c \
natpmp.cpp \
parse_url.cpp \
pe_crypto.cpp \
@@ -575,7 +574,7 @@ libtorrent_rasterbar_la_SOURCES = \
libtorrent_rasterbar_la_LDFLAGS = -version-info $(INTERFACE_VERSION_INFO)
#libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @BOOST_FILESYSTEM_LIB@ @BOOST_THREAD_LIB@ @OPENSSL_LIBS@
-libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @OPENSSL_LIBS@
+libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @OPENSSL_LIBS@ -ltommath
#AM_CXXFLAGS= -ftemplate-depth-100 -I$(top_srcdir)/include @DEBUGFLAGS@ @OPENSSL_INCLUDES@
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/ed25519/src @DEBUGFLAGS@ @OPENSSL_INCLUDES@
@@ -778,7 +777,6 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lt_trackers.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/magnet_uri.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/metadata_transfer.Plo@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mpi.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/natpmp.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/packet_buffer.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/parse_url.Plo@am__quote@
diff --git a/src/pe_crypto.cpp b/src/pe_crypto.cpp
index d758b5a..9371a48 100644
--- a/src/pe_crypto.cpp
+++ b/src/pe_crypto.cpp
@@ -42,7 +42,7 @@ POSSIBILITY OF SUCH DAMAGE.
#include "libtorrent/random.hpp"
#elif defined TORRENT_USE_TOMMATH
extern "C" {
-#include "libtorrent/tommath.h"
+#include <tommath.h>
}
#include "libtorrent/random.hpp"
#endif

View File

@ -0,0 +1,120 @@
diff -uNrp a/include/libtorrent/Makefile.am b/include/libtorrent/Makefile.am
--- a/include/libtorrent/Makefile.am 2016-08-23 05:28:09.000000000 +0100
+++ b/include/libtorrent/Makefile.am 2016-09-28 09:27:40.915763994 +0100
@@ -153,11 +153,6 @@ nobase_include_HEADERS = \
web_peer_connection.hpp \
xml_parse.hpp \
\
- tommath.h \
- tommath_class.h \
- tommath_superclass.h \
- tommath_private.h \
- \
aux_/alert_manager_variadic_emplace.hpp \
aux_/allocating_handler.hpp \
aux_/cpuid.hpp \
diff -uNrp a/include/libtorrent/Makefile.in b/include/libtorrent/Makefile.in
--- a/include/libtorrent/Makefile.in 2016-08-23 07:14:04.000000000 +0100
+++ b/include/libtorrent/Makefile.in 2016-09-28 09:36:25.481763366 +0100
@@ -492,11 +492,6 @@ nobase_include_HEADERS = \
web_peer_connection.hpp \
xml_parse.hpp \
\
- tommath.h \
- tommath_class.h \
- tommath_superclass.h \
- tommath_private.h \
- \
aux_/alert_manager_variadic_emplace.hpp \
aux_/allocating_handler.hpp \
aux_/cpuid.hpp \
diff -uNrp a/src/Makefile.am b/src/Makefile.am
--- a/src/Makefile.am 2016-08-23 05:28:09.000000000 +0100
+++ b/src/Makefile.am 2016-09-28 09:37:50.409850158 +0100
@@ -86,7 +86,6 @@ libtorrent_rasterbar_la_SOURCES = \
magnet_uri.cpp \
merkle.cpp \
metadata_transfer.cpp \
- mpi.cpp \
natpmp.cpp \
parse_url.cpp \
part_file.cpp \
@@ -151,7 +150,7 @@ libtorrent_rasterbar_la_SOURCES = \
$(KADEMLIA_SOURCES)
libtorrent_rasterbar_la_LDFLAGS = -version-info $(INTERFACE_VERSION_INFO)
-libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @OPENSSL_LIBS@
+libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @OPENSSL_LIBS@ -ltommath
AM_CPPFLAGS = -DTORRENT_BUILDING_LIBRARY -I$(top_srcdir)/include -I$(top_srcdir)/ed25519/src @DEBUGFLAGS@ @OPENSSL_INCLUDES@
AM_CFLAGS = -I$(top_srcdir)/ed25519/src -std=c99
diff -uNrp a/src/Makefile.in b/src/Makefile.in
--- a/src/Makefile.in 2016-08-23 07:14:04.000000000 +0100
+++ b/src/Makefile.in 2016-09-28 09:40:14.174918721 +0100
@@ -155,7 +155,7 @@ am__libtorrent_rasterbar_la_SOURCES_DIST
http_stream.cpp http_tracker_connection.cpp i2p_stream.cpp \
identify_client.cpp instantiate_connection.cpp ip_filter.cpp \
ip_voter.cpp lazy_bdecode.cpp lsd.cpp lt_trackers.cpp \
- magnet_uri.cpp merkle.cpp metadata_transfer.cpp mpi.cpp \
+ magnet_uri.cpp merkle.cpp metadata_transfer.cpp \
natpmp.cpp parse_url.cpp part_file.cpp pe_crypto.cpp \
performance_counters.cpp peer_connection.cpp \
peer_connection_handle.cpp peer_class.cpp peer_class_set.cpp \
@@ -220,7 +220,7 @@ am_libtorrent_rasterbar_la_OBJECTS = web
http_stream.lo http_tracker_connection.lo i2p_stream.lo \
identify_client.lo instantiate_connection.lo ip_filter.lo \
ip_voter.lo lazy_bdecode.lo lsd.lo lt_trackers.lo \
- magnet_uri.lo merkle.lo metadata_transfer.lo mpi.lo natpmp.lo \
+ magnet_uri.lo merkle.lo metadata_transfer.lo natpmp.lo \
parse_url.lo part_file.lo pe_crypto.lo performance_counters.lo \
peer_connection.lo peer_connection_handle.lo peer_class.lo \
peer_class_set.lo piece_picker.lo platform_util.lo \
@@ -554,7 +554,6 @@ libtorrent_rasterbar_la_SOURCES = \
magnet_uri.cpp \
merkle.cpp \
metadata_transfer.cpp \
- mpi.cpp \
natpmp.cpp \
parse_url.cpp \
part_file.cpp \
@@ -619,7 +618,7 @@ libtorrent_rasterbar_la_SOURCES = \
$(KADEMLIA_SOURCES)
libtorrent_rasterbar_la_LDFLAGS = -version-info $(INTERFACE_VERSION_INFO)
-libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @OPENSSL_LIBS@
+libtorrent_rasterbar_la_LIBADD = @BOOST_SYSTEM_LIB@ @OPENSSL_LIBS@ -ltommath
AM_CPPFLAGS = -DTORRENT_BUILDING_LIBRARY -I$(top_srcdir)/include -I$(top_srcdir)/ed25519/src @DEBUGFLAGS@ @OPENSSL_INCLUDES@
AM_CFLAGS = -I$(top_srcdir)/ed25519/src -std=c99
AM_LDFLAGS = @OPENSSL_LDFLAGS@
@@ -832,7 +831,6 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/magnet_uri.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/merkle.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/metadata_transfer.Plo@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mpi.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/natpmp.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/packet_buffer.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/parse_url.Plo@am__quote@
diff -uNrp a/src/pe_crypto.cpp b/src/pe_crypto.cpp
--- a/src/pe_crypto.cpp 2016-08-23 05:28:09.000000000 +0100
+++ b/src/pe_crypto.cpp 2016-09-28 09:40:59.178375010 +0100
@@ -38,7 +38,7 @@ POSSIBILITY OF SUCH DAMAGE.
#include <algorithm>
extern "C" {
-#include "libtorrent/tommath.h"
+#include <tommath.h>
}
#include "libtorrent/aux_/disable_warnings_pop.hpp"
diff -uNrp a/test/test_pe_crypto.cpp b/test/test_pe_crypto.cpp
--- a/test/test_pe_crypto.cpp 2016-08-23 05:28:10.000000000 +0100
+++ b/test/test_pe_crypto.cpp 2016-09-28 10:07:01.211776200 +0100
@@ -42,7 +42,7 @@ POSSIBILITY OF SUCH DAMAGE.
#include "test.hpp"
extern "C" {
-#include "libtorrent/tommath.h"
+#include <tommath.h>
}
#if !defined(TORRENT_DISABLE_ENCRYPTION) && !defined(TORRENT_DISABLE_EXTENSIONS)

View File

@ -15,24 +15,23 @@
%filter_setup
Name: rb_libtorrent
Version: 1.1.0
Release: 2%{?dist}
Version: 1.1.1
Release: 1%{?dist}
Summary: A C++ BitTorrent library aiming to be the best alternative
Group: System Environment/Libraries
License: BSD
URL: http://www.rasterbar.com/products/libtorrent
Source0: https://github.com/arvidn/libtorrent/releases/download/libtorrent-1_1/libtorrent-rasterbar-%{version}.tar.gz
Source0: https://github.com/arvidn/libtorrent/releases/download/libtorrent-1_1_1/libtorrent-rasterbar-%{version}.tar.gz
Source1: %{name}-README-renames.Fedora
Source2: %{name}-COPYING.Boost
Source3: %{name}-COPYING.zlib
Patch0: %{name}-1.0.1-boost_noncopyable.patch
Patch1: %{name}-1.0.6-system-tommath.patch
Patch1: %{name}-1.1.1-system-tommath.patch
BuildRequires: asio-devel
BuildRequires: boost-devel
BuildRequires: libtommath-devel
BuildRequires: pkgconfig(geoip)
BuildRequires: pkgconfig(zlib)
BuildRequires: pkgconfig(python2)
BuildRequires: python2-devel
@ -98,9 +97,9 @@ included documentation for more details.)
Summary: Python bindings for %{name}
Group: Development/Languages
License: Boost
Requires: %{name}%{?_isa} = %{version}-%{release}
Provides: %{name}-python
Obsoletes: %{name}-python < 1.0.9
Requires: %{name}%{?_isa} = %{version}-%{release}
Provides: %{name}-python
Obsoletes: %{name}-python < 1.0.9
%description python2
The %{name}-python2 package contains Python language bindings
@ -122,9 +121,9 @@ Python applications.
%prep
%setup -q -n "libtorrent-rasterbar-%{version}"
%patch0 -p1
#patch0 -p1
%patch1 -p1
rm include/libtorrent/tommath* src/mpi.c
rm include/libtorrent/tommath* src/mpi.cpp
## The RST files are the sources used to create the final HTML files; and are
## not needed.
@ -157,7 +156,6 @@ pushd build
--enable-python-binding \
--with-boost-system=boost_system \
--with-boost-python=boost_python \
--with-libgeoip=system \
--with-libiconv \
--enable-export-all
@ -178,7 +176,6 @@ pushd build-python3
--enable-python-binding \
--with-boost-system=boost_system \
--with-boost-python=boost_python%{python3_version} \
--with-libgeoip=system \
--with-libiconv \
--enable-export-all
@ -232,7 +229,7 @@ rm -fv %{buildroot}%{_libdir}/lib*.a
%{!?_licensedir:%global license %doc}
%doc AUTHORS ChangeLog
%license COPYING
%{_libdir}/libtorrent-rasterbar.so.8*
%{_libdir}/libtorrent-rasterbar.so.9*
%files devel
%doc docs/
@ -265,6 +262,9 @@ rm -fv %{buildroot}%{_libdir}/lib*.a
%endif # with_python3
%changelog
* Wed Sep 28 2016 Leigh Scott <leigh123linux@googlemail.com> - 1.1.1-1
- Upgrade to 1.1.1
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages

View File

@ -1 +1 @@
3a291044b5b33fec3e30b22a94fda31f libtorrent-rasterbar-1.1.0.tar.gz
4c635943c7ca2ca5db9fba8b04e78a3f libtorrent-rasterbar-1.1.1.tar.gz