Remove valgrind for riscv64
Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
parent
3f85f1f557
commit
d53b05981a
@ -2,7 +2,7 @@
|
||||
|
||||
Name: rapidjson
|
||||
Version: 1.1.0
|
||||
Release: 23%{?dist}
|
||||
Release: 23.0.riscv64%{?dist}
|
||||
Summary: Fast JSON parser and generator for C++
|
||||
|
||||
License: MIT
|
||||
@ -13,11 +13,16 @@ Patch0: rapidjson-1.1.0-do_not_include_gtest_src_dir.patch
|
||||
# Upstream derived patch for C++20 support
|
||||
Patch1: rapidjson-1.1.0-c++20.patch
|
||||
|
||||
# Remove valgrind for riscv64
|
||||
Patch10: remove-valgrind-unit-test.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gtest-devel
|
||||
%ifarch %{valgrind_arches}
|
||||
BuildRequires: valgrind
|
||||
%endif
|
||||
BuildRequires: doxygen
|
||||
|
||||
%description
|
||||
@ -119,6 +124,9 @@ find %{buildroot} -type f -name 'CMake*.txt' -delete
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 06 2023 David Abdurachmanov <davidlt@rivosinc.com> - 1.1.0-23.0.riscv64
|
||||
- Disable valgrind on riscv64
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
|
16
remove-valgrind-unit-test.patch
Normal file
16
remove-valgrind-unit-test.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff --git a/test/unittest/CMakeLists.txt b/test/unittest/CMakeLists.txt
|
||||
index 15d29ea..3b4f75e 100644
|
||||
--- a/test/unittest/CMakeLists.txt
|
||||
+++ b/test/unittest/CMakeLists.txt
|
||||
@@ -78,11 +78,6 @@ add_test(NAME unittest
|
||||
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/bin)
|
||||
|
||||
if(NOT MSVC)
|
||||
- # Not running SIMD.* unit test cases for Valgrind
|
||||
- add_test(NAME valgrind_unittest
|
||||
- COMMAND valgrind --leak-check=full --error-exitcode=1 ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/unittest --gtest_filter=-SIMD.*
|
||||
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/bin)
|
||||
-
|
||||
if(CMAKE_BUILD_TYPE STREQUAL "Debug")
|
||||
add_test(NAME symbol_check
|
||||
COMMAND sh -c "objdump -t -C libnamespacetest.a | grep rapidjson ; test $? -ne 0"
|
Loading…
x
Reference in New Issue
Block a user