Go to file
Marie Loise Nolden 568b758001 Add fix for compiling with qt 5.14
From FreeBSD ports tree (tcberner)

Fix with Qt5-5.14

Obtained from:
        579e559a63

--- src/common/types.h.orig     2020-04-04 10:50:56 UTC
+++ src/common/types.h
@@ -140,6 +140,7 @@ Q_DECLARE_METATYPE(QHostAddress)
 typedef QList<MsgId> MsgIdList;
 typedef QList<BufferId> BufferIdList;
 
+#if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
 /**
  * Catch-all stream serialization operator for enum types.
  *
@@ -169,6 +170,7 @@ QDataStream &operator>>(QDataStream &in, T &value) {
     value = static_cast<T>(v);
     return in;
 }
+#endif
 
 // Exceptions
2020-07-13 17:32:30 +00:00
.gitignore Update to latest upstream release, 0.13.1. 2019-02-15 16:28:14 -05:00
quassel.appdata.xml Include appstream data for client, monolithic client. 2016-09-09 14:41:03 -04:00
quassel.conf Add firewalld service for quassel, modify default config to listen on all interfaces rather than localhost. 2016-03-16 20:32:20 -04:00
quassel.spec Add fix for compiling with qt 5.14 2020-07-13 17:32:30 +00:00
quassel_0.11.1_CVE-2015-8547.diff Added security fix for CVE-2015-8547 2016-01-04 22:13:09 +01:00
quasselclient.appdata.xml Include appstream data for client, monolithic client. 2016-09-09 14:41:03 -04:00
quasselcore.service Update to latest release; quassel 0.13.0. 2018-11-19 11:31:27 -05:00
sources Update to latest upstream release, 0.13.1. 2019-02-15 16:28:14 -05:00