2e0a99261b
fixes #690087 - ripd fails to start fixes #689763 - updated to latest upstream version 0.99.18
48 lines
2.0 KiB
Diff
48 lines
2.0 KiB
Diff
commit 36de261b57eab7a7539fb6527a1f02f3898cbafd
|
|
Author: Paul Jakma <paul@quagga.net>
|
|
Date: Tue Mar 22 10:18:05 2011 +0000
|
|
|
|
build: change sense of opaque-{lsa,te} enable args to enable by default
|
|
|
|
* configure.ac: (AC_ARG_ENABLE({ospf-te,opaque-lsa})) reverse the sense to
|
|
--disable
|
|
(enable_{opaque_lsa,ospf_te}) treat as enabled unless explicitly disabled.
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 4409d20..27d26ef 100755
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -219,15 +219,14 @@ AC_ARG_WITH(libpam,
|
|
AC_ARG_ENABLE(tcp-zebra,
|
|
[ --enable-tcp-zebra enable TCP/IP socket connection between zebra and protocol daemon])
|
|
AC_ARG_ENABLE(opaque-lsa,
|
|
-[ --enable-opaque-lsa enable OSPF Opaque-LSA with OSPFAPI support (RFC2370)])
|
|
+ AC_HELP_STRING([--disable-opaque-lsa],[do not build OSPF Opaque-LSA with OSPFAPI support (RFC2370)]))
|
|
AC_ARG_ENABLE(ospfapi,
|
|
-[ --disable-ospfapi do not build OSPFAPI to access the OSPF LSA Database,
|
|
- (this is the default if --enable-opaque-lsa is not set)])
|
|
+[ --disable-ospfapi do not build OSPFAPI to access the OSPF LSA Database])
|
|
AC_ARG_ENABLE(ospfclient,
|
|
[ --disable-ospfclient do not build OSPFAPI client for OSPFAPI,
|
|
(this is the default if --disable-ospfapi is set)])
|
|
AC_ARG_ENABLE(ospf-te,
|
|
-[ --enable-ospf-te enable Traffic Engineering Extension to OSPF])
|
|
+ AC_HELP_STRING([--disable-ospf-te],[disable Traffic Engineering Extension to OSPF]))
|
|
AC_ARG_ENABLE(multipath,
|
|
[ --enable-multipath=ARG enable multipath function, ARG must be digit])
|
|
AC_ARG_ENABLE(user,
|
|
@@ -292,11 +291,11 @@ if test "${enable_tcp_zebra}" = "yes"; then
|
|
AC_DEFINE(HAVE_TCP_ZEBRA,,Use TCP for zebra communication)
|
|
fi
|
|
|
|
-if test "${enable_opaque_lsa}" = "yes"; then
|
|
+if test "${enable_opaque_lsa}" != "no"; then
|
|
AC_DEFINE(HAVE_OPAQUE_LSA,,OSPF Opaque LSA)
|
|
fi
|
|
|
|
-if test "${enable_ospf_te}" = "yes"; then
|
|
+if test "${enable_ospf_te}" != "no"; then
|
|
AC_DEFINE(HAVE_OPAQUE_LSA,,OSPF Opaque LSA)
|
|
AC_DEFINE(HAVE_OSPF_TE,,OSPF TE)
|
|
fi
|