- bump to latest upstream
- fixed #527734 - posix compliant init scripts
This commit is contained in:
parent
11e48ac6d6
commit
aeff236b84
@ -1 +1 @@
|
||||
quagga-0.99.12.tar.gz
|
||||
quagga-0.99.15.tar.gz
|
||||
|
228
quagga-0.99.15-posix.patch
Normal file
228
quagga-0.99.15-posix.patch
Normal file
@ -0,0 +1,228 @@
|
||||
diff -up quagga-0.99.15/redhat/bgpd.init.posix quagga-0.99.15/redhat/bgpd.init
|
||||
--- quagga-0.99.15/redhat/bgpd.init.posix 2009-10-19 08:52:03.018303218 +0200
|
||||
+++ quagga-0.99.15/redhat/bgpd.init 2009-10-19 09:58:18.694292887 +0200
|
||||
@@ -30,6 +30,10 @@ case "$1" in
|
||||
|
||||
# The process must be configured first.
|
||||
[ -f $CONF_FILE ] || exit 6
|
||||
+ if [ `id -u` -ne 0 ]; then
|
||||
+ echo $"Insufficient privilege" 1>&2
|
||||
+ exit 4
|
||||
+ fi
|
||||
|
||||
echo -n $"Starting $PROG: "
|
||||
daemon $cmd -d $BGPD_OPTS
|
||||
@@ -44,12 +48,12 @@ case "$1" in
|
||||
[ $RETVAL -eq 0 ] && rm -f $LOCK_FILE
|
||||
echo
|
||||
;;
|
||||
- restart|reload)
|
||||
+ restart|reload|force-reload)
|
||||
$0 stop
|
||||
$0 start
|
||||
RETVAL=$?
|
||||
;;
|
||||
- condrestart)
|
||||
+ condrestart|try-restart)
|
||||
if [ -f $LOCK_FILE ]; then
|
||||
$0 stop
|
||||
$0 start
|
||||
@@ -61,7 +65,7 @@ case "$1" in
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
- echo $"Usage: $0 {start|stop|restart|reload|condrestart|status}"
|
||||
+ echo $"Usage: $0 {start|stop|restart|reload|force-reload|try-restart|status}"
|
||||
exit 2
|
||||
esac
|
||||
|
||||
diff -up quagga-0.99.15/redhat/ospf6d.init.posix quagga-0.99.15/redhat/ospf6d.init
|
||||
--- quagga-0.99.15/redhat/ospf6d.init.posix 2009-10-19 08:54:10.135543594 +0200
|
||||
+++ quagga-0.99.15/redhat/ospf6d.init 2009-10-19 09:53:29.288294085 +0200
|
||||
@@ -29,6 +29,10 @@ case "$1" in
|
||||
|
||||
# The process must be configured first.
|
||||
[ -f $CONF_FILE ] || exit 6
|
||||
+ if [ `id -u` -ne 0 ]; then
|
||||
+ echo $"Insufficient privilege" 1>&2
|
||||
+ exit 4
|
||||
+ fi
|
||||
|
||||
echo -n $"Starting $PROG: "
|
||||
daemon $cmd -d $OSPF6D_OPTS
|
||||
@@ -43,12 +47,12 @@ case "$1" in
|
||||
[ $RETVAL -eq 0 ] && rm -f $LOCK_FILE
|
||||
echo
|
||||
;;
|
||||
- restart|reload)
|
||||
+ restart|reload|force-reload)
|
||||
$0 stop
|
||||
$0 start
|
||||
RETVAL=$?
|
||||
;;
|
||||
- condrestart)
|
||||
+ condrestart|try-restart)
|
||||
if [ -f $LOCK_FILE ]; then
|
||||
$0 stop
|
||||
$0 start
|
||||
@@ -60,7 +64,7 @@ case "$1" in
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
- echo $"Usage: $PROG {start|stop|restart|reload|condrestart|status}"
|
||||
+ echo $"Usage: $PROG {start|stop|restart|reload|force-reload|try-restart|status}"
|
||||
exit 2
|
||||
esac
|
||||
|
||||
diff -up quagga-0.99.15/redhat/ospfd.init.posix quagga-0.99.15/redhat/ospfd.init
|
||||
--- quagga-0.99.15/redhat/ospfd.init.posix 2009-10-19 08:52:03.017303137 +0200
|
||||
+++ quagga-0.99.15/redhat/ospfd.init 2009-10-19 09:56:42.380294279 +0200
|
||||
@@ -29,6 +29,10 @@ case "$1" in
|
||||
|
||||
# The process must be configured first.
|
||||
[ -f $CONF_FILE ] || exit 6
|
||||
+ if [ `id -u` -ne 0 ]; then
|
||||
+ echo $"Insufficient privilege" 1>&2
|
||||
+ exit 4
|
||||
+ fi
|
||||
|
||||
echo -n $"Starting $PROG: "
|
||||
daemon $cmd -d $OSPFD_OPTS
|
||||
@@ -43,12 +47,12 @@ case "$1" in
|
||||
[ $RETVAL -eq 0 ] && rm -f $LOCK_FILE
|
||||
echo
|
||||
;;
|
||||
- restart|reload)
|
||||
+ restart|reload|force-reload)
|
||||
$0 stop
|
||||
$0 start
|
||||
RETVAL=$?
|
||||
;;
|
||||
- condrestart)
|
||||
+ condrestart|try-restart)
|
||||
if [ -f $LOCK_FILE ]; then
|
||||
$0 stop
|
||||
$0 start
|
||||
@@ -60,7 +64,7 @@ case "$1" in
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
- echo $"Usage: $PROG {start|stop|restart|reload|condrestart|status}"
|
||||
+ echo $"Usage: $PROG {start|stop|restart|reload|force-reload|try-restart|status}"
|
||||
exit 2
|
||||
esac
|
||||
|
||||
diff -up quagga-0.99.15/redhat/ripd.init.posix quagga-0.99.15/redhat/ripd.init
|
||||
--- quagga-0.99.15/redhat/ripd.init.posix 2009-10-19 09:57:08.605329988 +0200
|
||||
+++ quagga-0.99.15/redhat/ripd.init 2009-10-19 09:59:21.872294779 +0200
|
||||
@@ -29,6 +29,10 @@ case "$1" in
|
||||
|
||||
# The process must be configured first.
|
||||
[ -f $CONF_FILE ] || exit 6
|
||||
+ if [ `id -u` -ne 0 ]; then
|
||||
+ echo $"Insufficient privilege" 1>&2
|
||||
+ exit 4
|
||||
+ fi
|
||||
|
||||
echo -n $"Starting $PROG: "
|
||||
daemon $cmd -d $RIPD_OPTS
|
||||
@@ -43,12 +47,12 @@ case "$1" in
|
||||
[ $RETVAL -eq 0 ] && rm -f $LOCK_FILE
|
||||
echo
|
||||
;;
|
||||
- restart|reload)
|
||||
+ restart|reload|force-reload)
|
||||
$0 stop
|
||||
$0 start
|
||||
RETVAL=$?
|
||||
;;
|
||||
- condrestart)
|
||||
+ condrestart|try-restart)
|
||||
if [ -f $LOCK_FILE ]; then
|
||||
$0 stop
|
||||
$0 start
|
||||
@@ -60,7 +64,7 @@ case "$1" in
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
- echo $"Usage: $0 {start|stop|restart|reload|condrestart|status}"
|
||||
+ echo $"Usage: $0 {start|stop|restart|reload|force-reload|try-restart|status}"
|
||||
exit 2
|
||||
esac
|
||||
|
||||
diff -up quagga-0.99.15/redhat/ripngd.init.posix quagga-0.99.15/redhat/ripngd.init
|
||||
--- quagga-0.99.15/redhat/ripngd.init.posix 2009-10-19 09:59:42.545325446 +0200
|
||||
+++ quagga-0.99.15/redhat/ripngd.init 2009-10-19 10:04:01.286294713 +0200
|
||||
@@ -29,6 +29,10 @@ case "$1" in
|
||||
|
||||
# The process must be configured first.
|
||||
[ -f $CONF_FILE ] || exit 6
|
||||
+ if [ `id -u` -ne 0 ]; then
|
||||
+ echo $"Insufficient privilege" 1>&2
|
||||
+ exit 4
|
||||
+ fi
|
||||
|
||||
echo -n $"Starting $PROG: "
|
||||
daemon $cmd -d $RIPNGD_OPTS
|
||||
@@ -43,12 +47,12 @@ case "$1" in
|
||||
[ $RETVAL -eq 0 ] && rm -f $LOCK_FILE
|
||||
echo
|
||||
;;
|
||||
- restart|reload)
|
||||
+ restart|reload|force-reload)
|
||||
$0 stop
|
||||
$0 start
|
||||
RETVAL=$?
|
||||
;;
|
||||
- condrestart)
|
||||
+ condrestart|try-restart)
|
||||
if [ -f $LOCK_FILE ]; then
|
||||
$0 stop
|
||||
$0 start
|
||||
@@ -60,7 +64,7 @@ case "$1" in
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
- echo $"Usage: $0 {start|stop|restart|reload|condrestart|status}"
|
||||
+ echo $"Usage: $0 {start|stop|restart|reload|force-reload|try-restart|status}"
|
||||
exit 2
|
||||
esac
|
||||
|
||||
diff -up quagga-0.99.15/redhat/zebra.init.posix quagga-0.99.15/redhat/zebra.init
|
||||
--- quagga-0.99.15/redhat/zebra.init.posix 2009-10-19 10:00:32.754573536 +0200
|
||||
+++ quagga-0.99.15/redhat/zebra.init 2009-10-19 10:06:26.378294314 +0200
|
||||
@@ -26,6 +26,10 @@ case "$1" in
|
||||
|
||||
# The process must be configured first.
|
||||
[ -f $CONF_FILE ] || exit 6
|
||||
+ if [ `id -u` -ne 0 ]; then
|
||||
+ echo $"Insufficient privilege" 1>&2
|
||||
+ exit 4
|
||||
+ fi
|
||||
|
||||
echo -n $"Starting $PROG: "
|
||||
|
||||
@@ -43,12 +47,12 @@ case "$1" in
|
||||
[ $RETVAL -eq 0 ] && rm -f $LOCK_FILE
|
||||
echo
|
||||
;;
|
||||
- restart|reload)
|
||||
+ restart|reload|force-reload)
|
||||
$0 stop
|
||||
$0 start
|
||||
RETVAL=$?
|
||||
;;
|
||||
- condrestart)
|
||||
+ condrestart|try-restart)
|
||||
if [ -f $LOCK_FILE ]; then
|
||||
$0 stop
|
||||
$0 start
|
||||
@@ -60,7 +64,7 @@ case "$1" in
|
||||
RETVAL=$?
|
||||
;;
|
||||
*)
|
||||
- echo $"Usage: $0 {start|stop|restart|reload|condrestart|status}"
|
||||
+ echo $"Usage: $0 {start|stop|restart|reload|force-reload|try-restart|status}"
|
||||
exit 2
|
||||
esac
|
||||
|
10
quagga.spec
10
quagga.spec
@ -31,8 +31,8 @@
|
||||
|
||||
Summary: Routing daemon
|
||||
Name: quagga
|
||||
Version: 0.99.12
|
||||
Release: 4%{?dist}
|
||||
Version: 0.99.15
|
||||
Release: 1%{?dist}
|
||||
Epoch: 0
|
||||
License: GPLv2+
|
||||
Group: System Environment/Daemons
|
||||
@ -40,6 +40,7 @@ Source0: http://www.quagga.net/download/%{name}-%{version}.tar.gz
|
||||
Source1: quagga-filter-perl-requires.sh
|
||||
Patch2: quagga-0.96.5-nostart.patch
|
||||
Patch7: quagga-0.99.9-initscript.patch
|
||||
Patch8: quagga-0.99.15-posix.patch
|
||||
|
||||
URL: http://www.quagga.net
|
||||
%if %with_snmp
|
||||
@ -95,6 +96,7 @@ developing OSPF-API and quagga applications.
|
||||
%patch2 -p1 -b .nostart
|
||||
# This creates a .diff file that we apply after configuring
|
||||
%patch7 -p1 -b .initscript
|
||||
%patch8 -p1 -b .posix
|
||||
|
||||
%build
|
||||
# FC5+ automatic -fstack-protector-all switch
|
||||
@ -346,6 +348,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Oct 19 2009 Jiri Skala <jskala@redhat.com> - 0.99.15-1
|
||||
- bump to latest upstream
|
||||
- fixed #527734 - posix compliant init scripts
|
||||
|
||||
* Mon Sep 14 2009 Jiri Skala <jskala@redhat.com> - 0.99.12-3
|
||||
- fixed #516005 - Errors installing quagga-0.99.11-2.fc11.i586 with --excludedocs
|
||||
- fixed #522787 - quagga: build future versions without PAM
|
||||
|
Loading…
Reference in New Issue
Block a user