- fix vtysh.conf owner and group (#416121)
- fix bpgd IPv6 advertisements, patch from upstream (#429448)
This commit is contained in:
parent
613b0ea583
commit
a31d110238
12
quagga-0.99.9-ipv6_advert.patch
Normal file
12
quagga-0.99.9-ipv6_advert.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up quagga-0.99.9/bgpd/bgp_open.c.ipv6_advert quagga-0.99.9/bgpd/bgp_open.c
|
||||
--- quagga-0.99.9/bgpd/bgp_open.c.ipv6_advert 2008-03-05 20:44:20.000000000 +0100
|
||||
+++ quagga-0.99.9/bgpd/bgp_open.c 2008-03-05 20:44:59.000000000 +0100
|
||||
@@ -177,7 +177,7 @@ bgp_capability_mp (struct peer *peer, st
|
||||
peer->afc_recv[mpc.afi][mpc.safi] = 1;
|
||||
|
||||
if (peer->afc[mpc.afi][mpc.safi])
|
||||
- peer->afc_nego[mpc.safi][mpc.safi] = 1;
|
||||
+ peer->afc_nego[mpc.afi][mpc.safi] = 1;
|
||||
else
|
||||
return -1;
|
||||
|
11
quagga.spec
11
quagga.spec
@ -32,7 +32,7 @@
|
||||
Summary: Routing daemon
|
||||
Name: quagga
|
||||
Version: 0.99.9
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Epoch: 0
|
||||
License: GPL
|
||||
Group: System Environment/Daemons
|
||||
@ -42,6 +42,7 @@ Patch2: quagga-0.96.5-nostart.patch
|
||||
#Patch6: quagga-0.98.5-pie.patch
|
||||
Patch7: quagga-0.99.9-initscript.patch
|
||||
Patch8: quagga-0.99.9-port_overflow.patch
|
||||
Patch9: quagga-0.99.9-ipv6_advert.patch
|
||||
|
||||
URL: http://www.quagga.net
|
||||
%if %with_snmp
|
||||
@ -100,6 +101,7 @@ developing OSPF-API and quagga applications.
|
||||
#%patch6 -p1
|
||||
%patch7 -p1 -b .initscript
|
||||
%patch8 -p1 -b .port_overflow
|
||||
%patch9 -p1 -b .ipv6_advert
|
||||
|
||||
%build
|
||||
# FC5+ automatic -fstack-protector-all switch
|
||||
@ -258,6 +260,7 @@ fi
|
||||
if [ ! -e %{_sysconfdir}/vtysh.conf ]; then
|
||||
touch %{_sysconfdir}/vtysh.conf
|
||||
chmod 640 %{_sysconfdir}/vtysh.conf
|
||||
chown %{quagga_user}:%{vty_group} %{_sysconfdir}/vtysh.conf
|
||||
fi
|
||||
|
||||
%postun
|
||||
@ -313,7 +316,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %attr(750,root,root) /var/run/quagga
|
||||
%endif
|
||||
%if %vty_group
|
||||
%attr(750,%quagga_user,%vty_group) %{_sysconfdir}/vtysh.conf.sample
|
||||
%attr(644,%quagga_user,%vty_group) %{_sysconfdir}/vtysh.conf.sample
|
||||
%endif
|
||||
%{_infodir}/*info*
|
||||
%{_mandir}/man*/*
|
||||
@ -349,6 +352,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Mar 05 2008 Martin Nagy <mnagy@redhat.com> - 0.99.9-6
|
||||
- fix vtysh.conf owner and group (#416121)
|
||||
- fix bpgd IPv6 advertisements, patch from upstream (#429448)
|
||||
|
||||
* Mon Feb 11 2008 Martin Nagy <mnagy@redhat.com> - 0.99.9-5
|
||||
- rebuild for gcc-4.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user