- 2.3.0 (final)
- enable libwebp support
- .spec cleanup
This commit is contained in:
Rex Dieter 2013-03-15 11:50:14 -05:00
parent df5f3f64dc
commit 34761255a8
5 changed files with 22 additions and 120 deletions

2
.gitignore vendored
View File

@ -1,3 +1,3 @@
/qtwebkit-developers-qtwebkit-qtwebkit-2.1.1.tar.xz
/qtwebkit-2.2.2-source.tar.xz
/qtwebkit-2.3-rc1.tar.xz
/qtwebkit-2.3.0.tar.xz

View File

@ -1,62 +0,0 @@
From f4777381ce10a5db904d120f4e14993af3dec39d Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen <allan.jensen@digia.com>
Date: Mon, 4 Mar 2013 16:32:02 +0100
Subject: [PATCH 1/2] [Qt] Flash objects won't load until scrolling page
https://bugs.webkit.org/show_bug.cgi?id=110149
Reviewed by Simon Hausmann.
Revert r134222. The issue from bug 101836 is no longer reproducable,
and the fix was causing flash objects to not load properly.
* plugins/PluginPackage.cpp:
(WebCore::PluginPackage::determineQuirks):
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@144191 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
Source/WebCore/ChangeLog | 13 +++++++++++++
Source/WebCore/plugins/PluginPackage.cpp | 4 +---
2 files changed, 14 insertions(+), 3 deletions(-)
diff --git a/Source/WebCore/ChangeLog b/Source/WebCore/ChangeLog
index 833470c..a5acc4a 100644
--- a/Source/WebCore/ChangeLog
+++ b/Source/WebCore/ChangeLog
@@ -13,6 +13,19 @@
2013-02-27 Allan Sandfeld Jensen <allan.jensen@digia.com>
+ [Qt] Flash objects won't load until scrolling page
+ https://bugs.webkit.org/show_bug.cgi?id=110149
+
+ Reviewed by Simon Hausmann.
+
+ Revert r134222. The issue from bug 101836 is no longer reproducable,
+ and the fix was causing flash objects to not load properly.
+
+ * plugins/PluginPackage.cpp:
+ (WebCore::PluginPackage::determineQuirks):
+
+2013-02-27 Allan Sandfeld Jensen <allan.jensen@digia.com>
+
[TexMap] Flickering after transitions on Apple HTML5 demo
https://bugs.webkit.org/show_bug.cgi?id=102501
diff --git a/Source/WebCore/plugins/PluginPackage.cpp b/Source/WebCore/plugins/PluginPackage.cpp
index 05b3eb6..5927719 100644
--- a/Source/WebCore/plugins/PluginPackage.cpp
+++ b/Source/WebCore/plugins/PluginPackage.cpp
@@ -205,9 +205,7 @@ void PluginPackage::determineQuirks(const String& mimeType)
}
#if PLATFORM(QT)
- // Flash will crash on repeated calls to SetWindow in windowed mode.
- // Defer the setWindow, so we don't set it to the wrong size too early.
- m_quirks.add(PluginQuirkDeferFirstSetWindowCall);
+ // Flash will crash on repeated calls to SetWindow in windowed mode
m_quirks.add(PluginQuirkDontCallSetWindowMoreThanOnce);
#endif
--
1.8.1.4

View File

@ -1,29 +0,0 @@
From e28288309b95a1d4ea343c86d22f9b83983c7238 Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen <allan.jensen@digia.com>
Date: Fri, 8 Mar 2013 17:16:53 +0100
Subject: [PATCH 2/2] REGRESSION(r110272) qt_webkit.pri not installed
Readd modulefile to the INSTALLS.
---
Source/api.pri | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/Source/api.pri b/Source/api.pri
index 7b604d8..9da4b9f 100644
--- a/Source/api.pri
+++ b/Source/api.pri
@@ -105,6 +105,11 @@ haveQt(5) {
# Install rules handled by Qt's module system
} else {
# For Qt4 we have to set up install rules manually
+ modulefile.files = $${ROOT_WEBKIT_DIR}/Tools/qmake/qt_webkit.pri
+ mkspecs = $$[QMAKE_MKSPECS]
+ mkspecs = $$split(mkspecs, :)
+ modulefile.path = $$last(mkspecs)/modules
+ INSTALLS += modulefile
# Syncqt has already run at this point, so we can use headers.pri
# as a basis for our install-rules
--
1.8.1.4

View File

@ -1,11 +1,10 @@
%define pre rc1
Name: qtwebkit
Version: 2.3
Release: 0.6.%{pre}%{?dist}
Summary: Qt WebKit bindings
Group: System Environment/Libraries
Version: 2.3.0
Release: 1%{?dist}
License: LGPLv2 with exceptions or GPLv3 with exceptions
URL: http://trac.webkit.org/wiki/QtWebKit
## This was how qtwebkit-2.2 did it (no longer works for 2.3)
@ -23,10 +22,9 @@ URL: http://trac.webkit.org/wiki/QtWebKit
# $ tar cJf qtwebkit-2.2.2-source.tar.xz qtwebkit-2.2.2-source/
##
# download from
# https://gitorious.org/webkit/qtwebkit-23/archive-tarball/qtwebkit-2.3-rc1
# https://gitorious.org/webkit/qtwebkit-23/archive-tarball/qtwebkit-2.3.0
# repack as .xz
Source0: qtwebkit-%{version}-%{pre}.tar.xz
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
Source0: qtwebkit-%{version}.tar.xz
# search /usr/lib{,64}/mozilla/plugins-wrapped for browser plugins too
Patch1: webkit-qtwebkit-2.2-tp1-pluginpath.patch
@ -44,8 +42,6 @@ Patch10: qtwebkit-ppc.patch
Patch11: qtwebkit-23-LLInt-C-Loop-backend-ppc.patch
## upstream patches
Patch101: 0001-Qt-Flash-objects-won-t-load-until-scrolling-page.patch
Patch102: 0002-REGRESSION-r110272-qt_webkit.pri-not-installed.patch
BuildRequires: bison
BuildRequires: chrpath
@ -59,6 +55,7 @@ BuildRequires: pkgconfig(fontconfig)
BuildRequires: pkgconfig(gstreamer-0.10) pkgconfig(gstreamer-app-0.10)
BuildRequires: pkgconfig(libpcre)
BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(libwebp)
BuildRequires: pkgconfig(libxslt)
BuildRequires: pkgconfig(QtCore) pkgconfig(QtNetwork)
BuildRequires: pkgconfig(sqlite3)
@ -83,7 +80,6 @@ Provides: qt4-webkit%{?_isa} = 2:%{version}-%{release}
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: qt4-devel
Obsoletes: qt-webkit-devel < 1:4.9.0
@ -104,8 +100,6 @@ Provides: qt4-webkit-devel%{?_isa} = 2:%{version}-%{release}
%patch10 -p1 -b .system-malloc
%patch11 -p1 -b .Double2Ints
%endif
%patch101 -p1 -b .0001
%patch102 -p1 -b .0002
%build
@ -114,21 +108,21 @@ PATH=%{_qt4_bindir}:$PATH; export PATH
QMAKEPATH=`pwd`/Tools/qmake; export QMAKEPATH
QTDIR=%{_qt4_prefix}; export QTDIR
# production_build is *supposed* to be default, but apparently not?
# production_build drops -Werror compile flag
./Tools/Scripts/build-webkit \
--qt \
--qmakearg="CONFIG+=production_build" \
--makeargs=%{?_smp_mflags}
--no-webkit2 \
--release \
--qmakearg="CONFIG+=production_build DEFINES+=HAVE_LIBWEBP=1" \
--makeargs=%{?_smp_mflags} \
%ifarch %{ix86}
--no-force-sse2
%endif
%install
rm -rf %{buildroot}
make install INSTALL_ROOT=%{buildroot} -C WebKitBuild/Release
## HACK, there has to be a better way
## HACK alert
chrpath --list %{buildroot}%{_qt4_libdir}/libQtWebKit.so.4.10.?
chrpath --delete %{buildroot}%{_qt4_libdir}/libQtWebKit.so.4.10.? ||:
@ -141,22 +135,16 @@ mv QtWebKit.pc.new QtWebKit.pc
popd
%clean
rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%{_qt4_libdir}/libQtWebKit.so.4*
%if 0%{?_qt4_importdir:1}
%{_qt4_importdir}/QtWebKit/
%endif
%files devel
%defattr(-,root,root,-)
%{_qt4_datadir}/mkspecs/modules/qt_webkit.pri
%{_qt4_headerdir}/QtWebKit/
%{_qt4_libdir}/libQtWebKit.prl
@ -165,6 +153,11 @@ rm -rf %{buildroot}
%changelog
* Fri Mar 15 2013 Rex Dieter <rdieter@fedoraproject.org> 2.3.0-1
- 2.3.0 (final)
- enable libwebp support
- .spec cleanup
* Sat Mar 09 2013 Rex Dieter <rdieter@fedoraproject.org> 2.3-0.6.rc1
- should use libxml and libxslt (#919778)

View File

@ -1 +1 @@
a32ff002794ec5b9e40b6c5fe965ade5 qtwebkit-2.3-rc1.tar.xz
26f7ef9659aeb96ae0730014d9a86a16 qtwebkit-2.3.0.tar.xz