qt6-qtmultimedia/qtmultimedia-fix-build-on-x86-arch.patch
Jan Grulich 3b6ba5e7c5 6.8.0
2024-10-11 16:14:53 +02:00

29 lines
1.1 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From 610d7280ad1db68be49cb26b3d05b3a8059962cc Mon Sep 17 00:00:00 2001
From: Christophe Marin <christophe@krop.fr>
Date: Wed, 9 Oct 2024 12:27:14 +0200
Subject: [PATCH] Fix build on x86 arch
With GCC 14, build fails with:
/usr/lib/gcc/i586-suse-linux/14/include/xmmintrin.h:190:1: error: inlining failed in call to always_inline _mm_add_ps(float __vector(4), float __vector(4)): target specific option mismatch
---
src/resonance-audio/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/resonance-audio/CMakeLists.txt b/src/resonance-audio/CMakeLists.txt
index 0fa9dec..1eff0a3 100644
--- a/src/resonance-audio/CMakeLists.txt
+++ b/src/resonance-audio/CMakeLists.txt
@@ -233,7 +233,7 @@ qt_internal_extend_target(BundledResonanceAudio CONDITION (${CMAKE_SYSTEM_PROCES
# Use fallback mode if SSE is not available
qt_internal_extend_target(BundledResonanceAudio CONDITION (${CMAKE_SYSTEM_PROCESSOR} MATCHES "i[3-6]86$")
COMPILE_OPTIONS
- -DPFFFT_SIMD_DISABLE
+ -DPFFFT_SIMD_DISABLE -DDISABLE_SIMD
)
qt_disable_warnings(BundledResonanceAudio)
--
2.46.1