6.5.0
This commit is contained in:
parent
4dccb8dee5
commit
d932499e6c
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
||||
/qtbase-everywhere-src-6.4.1.tar.xz
|
||||
/qtbase-everywhere-src-6.4.2.tar.xz
|
||||
/qtbase-everywhere-src-6.4.3.tar.xz
|
||||
/qtbase-everywhere-src-6.5.0.tar.xz
|
||||
|
@ -38,8 +38,8 @@ BuildRequires: pkgconfig(libsystemd)
|
||||
|
||||
Name: qt6-qtbase
|
||||
Summary: Qt6 - QtBase components
|
||||
Version: 6.4.3
|
||||
Release: 2%{?dist}
|
||||
Version: 6.5.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: LGPL-3.0-only OR GPL-3.0-only WITH Qt-GPL-exception-1.0
|
||||
Url: http://qt-project.org/
|
||||
@ -66,11 +66,6 @@ Source6: 10-qt6-check-opengl2.sh
|
||||
# macros
|
||||
Source10: macros.qt6-qtbase
|
||||
|
||||
# borrowed from opensuse
|
||||
# track private api via properly versioned symbols
|
||||
# downside: binaries produced with these differently-versioned symbols are no longer
|
||||
# compatible with qt-project.org's Qt binary releases.
|
||||
Patch1: qtbase-tell-truth-about-private-api.patch
|
||||
Patch2: qtbase-use-qgnomeplatform-as-default-platform-theme-on-gnome.patch
|
||||
|
||||
# upstreamable patches
|
||||
@ -336,10 +331,6 @@ popd
|
||||
# check to ensure that can't happen -- rex
|
||||
test -x configure || chmod +x configure
|
||||
|
||||
# use proper perl interpretter so autodeps work as expected
|
||||
sed -i -e "s|^#!/usr/bin/env perl$|#!%{__perl}|" \
|
||||
mkspecs/features/data/unix/findclasslist.pl
|
||||
|
||||
|
||||
%build
|
||||
# QT is known not to work properly with LTO at this point. Some of the issues
|
||||
@ -433,7 +424,7 @@ translationdir=%{_qt6_translationdir}
|
||||
|
||||
Name: Qt6
|
||||
Description: Qt6 Configuration
|
||||
Version: 6.4.3
|
||||
Version: 6.5.0
|
||||
EOF
|
||||
|
||||
# rpm macros
|
||||
@ -491,7 +482,7 @@ install -p -m755 -D %{SOURCE6} %{buildroot}%{_sysconfdir}/X11/xinit/xinitrc.d/10
|
||||
mkdir -p %{buildroot}%{_qt6_headerdir}/QtXcb
|
||||
install -m 644 src/plugins/platforms/xcb/*.h %{buildroot}%{_qt6_headerdir}/QtXcb/
|
||||
|
||||
rm %{buildroot}/%{_bindir}/qt-cmake-private-install.cmake
|
||||
rm %{buildroot}/%{_qt6_libexecdir}/qt-cmake-private-install.cmake
|
||||
|
||||
# Use better location for some new scripts in qtbase-6.0.1
|
||||
mv %{buildroot}/%{_qt6_libexecdir}/ensure_pro_file.cmake %{buildroot}/%{_qt6_libdir}/cmake/Qt6/ensure_pro_file.cmake
|
||||
@ -563,8 +554,8 @@ make check -k ||:
|
||||
%{_rpmmacrodir}/macros.qt6-qtbase
|
||||
|
||||
%files devel
|
||||
%dir %{_qt6_datadir}/modules
|
||||
%dir %{_qt6_libdir}/metatypes
|
||||
%dir %{_qt6_libdir}/qt6/modules
|
||||
%dir %{_qt6_libdir}/qt6/metatypes
|
||||
%dir %{_qt6_libdir}/cmake/Qt6
|
||||
%dir %{_qt6_libdir}/cmake/Qt6/platforms
|
||||
%dir %{_qt6_libdir}/cmake/Qt6/platforms/Platform
|
||||
@ -593,7 +584,7 @@ make check -k ||:
|
||||
%dir %{_qt6_libdir}/cmake/Qt6OpenGLWidgets
|
||||
%dir %{_qt6_libdir}/cmake/Qt6PrintSupport
|
||||
%dir %{_qt6_libdir}/cmake/Qt6Sql
|
||||
%dir %{_qt6_libdir}/cmake/Qt6XcbQpaPrivate
|
||||
# dir {_qt6_libdir}/cmake/Qt6XcbQpaPrivate
|
||||
%dir %{_qt6_libdir}/cmake/Qt6Test
|
||||
%dir %{_qt6_libdir}/cmake/Qt6Widgets
|
||||
%dir %{_qt6_libdir}/cmake/Qt6WidgetsTools
|
||||
@ -602,40 +593,43 @@ make check -k ||:
|
||||
%dir %{_qt6_bindir}
|
||||
%endif
|
||||
%{_bindir}/androiddeployqt
|
||||
%{_bindir}/androiddeployqt6
|
||||
%{_bindir}/androidtestrunner
|
||||
%{_bindir}/qdbuscpp2xml*
|
||||
%{_bindir}/qdbusxml2cpp*
|
||||
%{_bindir}/qmake*
|
||||
%{_bindir}/qtpaths*
|
||||
%{_bindir}/qt-cmake
|
||||
%{_bindir}/qt-cmake-private
|
||||
%{_bindir}/qt-cmake-standalone-test
|
||||
# {_bindir}/qt-cmake-private
|
||||
# {_bindir}/qt-cmake-standalone-test
|
||||
%{_bindir}/qt-configure-module
|
||||
%{_libdir}/qt6/bin/qmake6
|
||||
%{_qt6_bindir}/androiddeployqt
|
||||
%{_qt6_bindir}/androiddeployqt6
|
||||
%{_qt6_bindir}/androidtestrunner
|
||||
%{_qt6_bindir}/qdbuscpp2xml
|
||||
%{_qt6_bindir}/qdbusxml2cpp
|
||||
%{_qt6_bindir}/qmake
|
||||
%{_qt6_bindir}/qtpaths*
|
||||
%{_qt6_bindir}/qt-cmake
|
||||
%{_qt6_bindir}/qt-cmake-private
|
||||
%{_qt6_bindir}/qt-cmake-private-install.cmake
|
||||
%{_qt6_bindir}/qt-cmake-standalone-test
|
||||
%{_qt6_bindir}/qt-configure-module
|
||||
%{_qt6_libexecdir}/qt-cmake-private
|
||||
%{_qt6_libexecdir}/qt-cmake-standalone-test
|
||||
%{_qt6_libexecdir}/cmake_automoc_parser
|
||||
%{_qt6_libexecdir}/qt-internal-configure-tests
|
||||
%{_qt6_libexecdir}/syncqt.pl
|
||||
%{_qt6_libexecdir}/sanitizer-testrunner.py
|
||||
%{_qt6_libexecdir}/syncqt
|
||||
%{_qt6_libexecdir}/android_emulator_launcher.sh
|
||||
%{_qt6_libexecdir}/moc
|
||||
%{_qt6_libexecdir}/tracegen
|
||||
%{_qt6_libexecdir}/tracepointgen
|
||||
%{_qt6_libexecdir}/qlalr
|
||||
%{_qt6_libexecdir}/qt-internal-configure-tests
|
||||
%{_qt6_libexecdir}/qvkgen
|
||||
%{_qt6_libexecdir}/rcc
|
||||
%{_qt6_libexecdir}/uic
|
||||
%{_qt6_libexecdir}/qt-testrunner.py
|
||||
%{_qt6_datadir}/modules/*.json
|
||||
%{_qt6_libdir}/qt6/modules/*.json
|
||||
%if "%{_qt6_headerdir}" != "%{_includedir}"
|
||||
%dir %{_qt6_headerdir}
|
||||
%endif
|
||||
@ -679,8 +673,8 @@ make check -k ||:
|
||||
%{_qt6_libdir}/libQt6Test.so
|
||||
%{_qt6_libdir}/libQt6Widgets.prl
|
||||
%{_qt6_libdir}/libQt6Widgets.so
|
||||
%{_qt6_libdir}/libQt6XcbQpa.prl
|
||||
%{_qt6_libdir}/libQt6XcbQpa.so
|
||||
# {_qt6_libdir}/libQt6XcbQpa.prl
|
||||
# {_qt6_libdir}/libQt6XcbQpa.so
|
||||
%{_qt6_libdir}/libQt6Xml.prl
|
||||
%{_qt6_libdir}/libQt6Xml.so
|
||||
%{_qt6_libdir}/libQt6EglFSDeviceIntegration.prl
|
||||
@ -695,8 +689,10 @@ make check -k ||:
|
||||
%{_qt6_libdir}/cmake/Qt6/libexec/*
|
||||
%{_qt6_libdir}/cmake/Qt6/platforms/*.cmake
|
||||
%{_qt6_libdir}/cmake/Qt6/platforms/Platform/*.cmake
|
||||
%{_qt6_libdir}/cmake/Qt6/qbatchedtestrunner.in.cpp
|
||||
%{_qt6_libdir}/cmake/Qt6/ModuleDescription.json.in
|
||||
%{_qt6_libdir}/cmake/Qt6/QtFileConfigure.txt.in
|
||||
%{_qt6_libdir}/cmake/Qt6/QtConfigureTimeExecutableCMakeLists.txt.in
|
||||
%{_qt6_libdir}/cmake/Qt6/QtSeparateDebugInfo.Info.plist.in
|
||||
%{_qt6_libdir}/cmake/Qt6/3rdparty/extra-cmake-modules/COPYING-CMAKE-SCRIPTS
|
||||
%{_qt6_libdir}/cmake/Qt6/3rdparty/extra-cmake-modules/find-modules/*.cmake
|
||||
@ -734,9 +730,9 @@ make check -k ||:
|
||||
%{_qt6_libdir}/cmake/Qt6Test/*.cmake
|
||||
%{_qt6_libdir}/cmake/Qt6Widgets/*.cmake
|
||||
%{_qt6_libdir}/cmake/Qt6WidgetsTools/*.cmake
|
||||
%{_qt6_libdir}/cmake/Qt6XcbQpaPrivate/*.cmake
|
||||
# {_qt6_libdir}/cmake/Qt6XcbQpaPrivate/*.cmake
|
||||
%{_qt6_libdir}/cmake/Qt6Xml/*.cmake
|
||||
%{_qt6_libdir}/metatypes/*.json
|
||||
%{_qt6_libdir}/qt6/metatypes/*.json
|
||||
%{_qt6_libdir}/pkgconfig/*.pc
|
||||
|
||||
%if 0%{?egl}
|
||||
@ -800,7 +796,7 @@ make check -k ||:
|
||||
%{_qt6_libdir}/libQt6OpenGLWidgets.so.6*
|
||||
%{_qt6_libdir}/libQt6PrintSupport.so.6*
|
||||
%{_qt6_libdir}/libQt6Widgets.so.6*
|
||||
%{_qt6_libdir}/libQt6XcbQpa.so.6*
|
||||
# {_qt6_libdir}/libQt6XcbQpa.so.6*
|
||||
# Generic
|
||||
%{_qt6_plugindir}/generic/libqevdevkeyboardplugin.so
|
||||
%{_qt6_plugindir}/generic/libqevdevmouseplugin.so
|
||||
@ -828,16 +824,16 @@ make check -k ||:
|
||||
%{_qt6_plugindir}/egldeviceintegrations/libqeglfs-x11-integration.so
|
||||
%{_qt6_plugindir}/egldeviceintegrations/libqeglfs-kms-egldevice-integration.so
|
||||
%{_qt6_plugindir}/egldeviceintegrations/libqeglfs-emu-integration.so
|
||||
%{_qt6_plugindir}/xcbglintegrations/libqxcb-egl-integration.so
|
||||
# {_qt6_plugindir}/xcbglintegrations/libqxcb-egl-integration.so
|
||||
%endif
|
||||
# Platforms
|
||||
%{_qt6_plugindir}/platforms/libqlinuxfb.so
|
||||
%{_qt6_plugindir}/platforms/libqminimal.so
|
||||
%{_qt6_plugindir}/platforms/libqoffscreen.so
|
||||
%{_qt6_plugindir}/platforms/libqxcb.so
|
||||
# {_qt6_plugindir}/platforms/libqxcb.so
|
||||
%{_qt6_plugindir}/platforms/libqvnc.so
|
||||
%{_qt6_plugindir}/platforms/libqvkkhrdisplay.so
|
||||
%{_qt6_plugindir}/xcbglintegrations/libqxcb-glx-integration.so
|
||||
# {_qt6_plugindir}/xcbglintegrations/libqxcb-glx-integration.so
|
||||
# Platformthemes
|
||||
%{_qt6_plugindir}/platformthemes/libqxdgdesktopportal.so
|
||||
%{_qt6_plugindir}/platformthemes/libqgtk3.so
|
||||
@ -845,6 +841,9 @@ make check -k ||:
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 03 2023 Jan Grulich <jgrulich@redhat.com> - 6.5.0-1
|
||||
- 6.5.0
|
||||
|
||||
* Mon Apr 03 2023 Jan Grulich <jgrulich@redhat.com> - 6.4.3-2
|
||||
- Enable zstd support
|
||||
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff --git a/mkspecs/features/qt_module.prf b/mkspecs/features/qt_module.prf
|
||||
index 3cacc8df..469e6f50 100644
|
||||
--- a/mkspecs/features/qt_module.prf
|
||||
+++ b/mkspecs/features/qt_module.prf
|
||||
@@ -218,9 +218,9 @@ android: CONFIG += qt_android_deps no_linker_version_script
|
||||
QMAKE_LFLAGS += $${QMAKE_LFLAGS_VERSION_SCRIPT}$$verscript
|
||||
|
||||
internal_module {
|
||||
- verscript_content = "Qt_$${QT_MAJOR_VERSION}_PRIVATE_API { *; };"
|
||||
+ verscript_content = "Qt_$${QT_MAJOR_VERSION}.$${QT_MINOR_VERSION}.$${QT_PATCH_VERSION}_PRIVATE_API { *; };"
|
||||
} else {
|
||||
- verscript_content = "Qt_$${QT_MAJOR_VERSION}_PRIVATE_API {" \
|
||||
+ verscript_content = "Qt_$${QT_MAJOR_VERSION}.$${QT_MINOR_VERSION}.$${QT_PATCH_VERSION}_PRIVATE_API {" \
|
||||
" qt_private_api_tag*;"
|
||||
|
||||
private_api_headers = $$SYNCQT.PRIVATE_HEADER_FILES $$SYNCQT.QPA_HEADER_FILES
|
@ -1,13 +1,13 @@
|
||||
diff --git a/src/corelib/global/qglobal.h b/src/corelib/global/qglobal.h
|
||||
index 6e83b78f..6a18cc19 100644
|
||||
--- a/src/corelib/global/qglobal.h
|
||||
+++ b/src/corelib/global/qglobal.h
|
||||
@@ -59,7 +59,7 @@
|
||||
diff --git a/src/corelib/global/qtversionchecks.h b/src/corelib/global/qtversionchecks.h
|
||||
index d3b7a7b0..a8b9c6f3 100644
|
||||
--- a/src/corelib/global/qtversionchecks.h
|
||||
+++ b/src/corelib/global/qtversionchecks.h
|
||||
@@ -26,7 +26,7 @@
|
||||
/*
|
||||
can be used like #if (QT_VERSION >= QT_VERSION_CHECK(6, 4, 0))
|
||||
*/
|
||||
-#define QT_VERSION_CHECK(major, minor, patch) ((major<<16)|(minor<<8)|(patch))
|
||||
+#define QT_VERSION_CHECK(qt_version_check_major, qt_version_check_minor, qt_version_check_patch) ((qt_version_check_major<<16)|(qt_version_check_minor<<8)|(qt_version_check_patch))
|
||||
|
||||
#ifdef QT_BOOTSTRAPPED
|
||||
#include <QtCore/qconfig-bootstrapped.h>
|
||||
/*
|
||||
Helper macros to make some simple code active in Qt 6 or Qt 7 only,
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (qtbase-everywhere-src-6.4.3.tar.xz) = a2d0779ba7ee8b8b78f5dc8db06177d04d50463fea7cad0b7785721acfc33dbbbaa1a7bfc052edb90ba1d11b488c30004daa43b6924a97126b9b8f82ad1a7f43
|
||||
SHA512 (qtbase-everywhere-src-6.5.0.tar.xz) = 29f70b9a9650afdd8e34703a7a8191feab4c3a25d0bc3a41010ea842389335b24e2685721fdb4a03653475ebd9bf8a8e4f4a77bf5d64b1289590b5ca0e4623f3
|
||||
|
Loading…
Reference in New Issue
Block a user