Merge branch 'f27' into f26

This commit is contained in:
Rex Dieter 2018-02-02 19:42:26 -06:00
commit df8b902bbd
3 changed files with 72 additions and 4 deletions

View File

@ -15,7 +15,7 @@
Name: qt5-%{qt_module}
Version: 5.212.0
Release: 0.12.%{?prerel}%{?dist}
Release: 0.15.%{?prerel}%{?dist}
Summary: Qt5 - QtWebKit components
License: LGPLv2 and BSD
@ -31,6 +31,12 @@ Patch0: qt5-qtwebkit-5.212.0-alpha2-fix-pagewidth.patch
# Patch from Kevin Kofler to fix https://github.com/annulen/webkit/issues/573
Patch1: qtwebkit-5.212.0-alpha2-fix-null-pointer-dereference.patch
# Patch for new CMake policy CMP0071 to explicitly use old behaviour.
Patch2: qtwebkit-5.212.0_cmake_cmp0071.patch
# Patch to fix for missing source file.
Patch3: qtwebkit-5.212.0_fix_missing_sources.patch
BuildRequires: bison
BuildRequires: cmake
BuildRequires: flex
@ -49,6 +55,8 @@ BuildRequires: pkgconfig(xcomposite)
BuildRequires: pkgconfig(xrender)
BuildRequires: pkgconfig(libxslt)
BuildRequires: pkgconfig(gl)
BuildRequires: pkgconfig(gstreamer-gl-1.0)
BuildRequires: pkgconfig(gstreamer-mpegts-1.0)
BuildRequires: perl-generators
BuildRequires: python2
BuildRequires: qt5-qtbase-devel
@ -60,9 +68,6 @@ BuildRequires: pkgconfig(Qt5WebChannel)
%endif
BuildRequires: pkgconfig(ruby)
BuildRequires: rubygems
%if 0%{?fedora}
BuildRequires: rubypick
%endif
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(zlib)
@ -224,6 +229,17 @@ sed -i "s,Libs: -L%{_qt5_libdir}/qt5/../ -lQt5WebKitWidgets,Libs: -L%{_qt5_libdi
%changelog
* Sun Nov 26 2017 Björn Esser <besser82@fedoraproject.org> - 5.212.0-0.15.alpha2
- Add patch2 to fix CMake warnings
- Add patch3 to fix build (missing src file caused by typo)
- Add missing BuildRequires
* Sun Nov 26 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.212.0-0.14.alpha2
- rebuild (qt5)
* Thu Oct 26 2017 Vít Ondruch <vondruch@redhat.com> - 5.212.0-0.13.alpha2
- Drop explicit dependency on rubypick.
* Tue Oct 24 2017 Christian Dersch <lupinix@mailbox.org> - 5.212.0-0.12.alpha2
- Added patch to fix null pointer dereference (#1470778)

View File

@ -0,0 +1,32 @@
Index: qtwebkit-5.212.0-alpha2/CMakeLists.txt
===================================================================
--- qtwebkit-5.212.0-alpha2.orig/CMakeLists.txt
+++ qtwebkit-5.212.0-alpha2/CMakeLists.txt
@@ -6,6 +6,11 @@ if (POLICY CMP0058)
cmake_policy(SET CMP0058 NEW)
endif ()
+# Explicitly process generated files with AUTOMOC.
+if (POLICY CMP0071)
+ cmake_policy(SET CMP0071 NEW)
+endif ()
+
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/Source/cmake")
if (NOT DEFINED ENABLE_WEBKIT)
Index: qtwebkit-5.212.0-alpha2/Source/WebKit/CMakeLists.txt
===================================================================
--- qtwebkit-5.212.0-alpha2.orig/Source/WebKit/CMakeLists.txt
+++ qtwebkit-5.212.0-alpha2/Source/WebKit/CMakeLists.txt
@@ -1,6 +1,11 @@
cmake_minimum_required(VERSION 2.8.12)
include(WebKitCommon)
+# Explicitly process generated files with AUTOMOC.
+if (POLICY CMP0071)
+ cmake_policy(SET CMP0071 NEW)
+endif ()
+
set(WebKit_SOURCES
Storage/StorageAreaImpl.cpp
Storage/StorageAreaSync.cpp

View File

@ -0,0 +1,20 @@
Index: qtwebkit-5.212.0-alpha2/Source/WebKit/PlatformQt.cmake
===================================================================
--- qtwebkit-5.212.0-alpha2.orig/Source/WebKit/PlatformQt.cmake
+++ qtwebkit-5.212.0-alpha2/Source/WebKit/PlatformQt.cmake
@@ -786,6 +786,7 @@ if (COMPILER_IS_GCC_OR_CLANG)
set_source_files_properties(
qt/Api/qwebdatabase.cpp
qt/Api/qwebelement.cpp
+ qt/Api/qwebfullscreenrequest.cpp
qt/Api/qwebhistory.cpp
qt/Api/qwebhistoryinterface.cpp
qt/Api/qwebpluginfactory.cpp
@@ -795,7 +796,6 @@ if (COMPILER_IS_GCC_OR_CLANG)
qt/WidgetApi/qgraphicswebview.cpp
qt/WidgetApi/qwebframe.cpp
- qt/WidgetApi/qwebfullscreenrequest.cpp
qt/WidgetApi/qwebinspector.cpp
qt/WidgetApi/qwebpage.cpp
qt/WidgetApi/qwebview.cpp