Update patch to incl. libatomic

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2022-10-20 18:46:14 +03:00
parent c17b17f340
commit 5584955288
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
1 changed files with 14 additions and 0 deletions

View File

@ -53,6 +53,20 @@ index 6b3d735..d1c8c14 100644
#define BROTLI_64_BITS 1
#else
#define BROTLI_64_BITS 0
diff --git a/Source/WTF/wtf/CMakeLists.txt b/Source/WTF/wtf/CMakeLists.txt
index 297589b..2c29fcb 100644
--- a/Source/WTF/wtf/CMakeLists.txt
+++ b/Source/WTF/wtf/CMakeLists.txt
@@ -251,6 +251,9 @@ list(APPEND WTF_SOURCES
set(WTF_SYSTEM_INCLUDE_DIRECTORIES
${ICU_INCLUDE_DIRS}
)
+
+list(APPEND WTF_LIBRARIES atomic)
+
list(APPEND WTF_LIBRARIES
${ICU_I18N_LIBRARIES}
${ICU_LIBRARIES}
diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
index 5717f3e..7aefa1b 100644
--- a/Source/WTF/wtf/Platform.h