diff --git a/chromium-hunspell-nullptr.patch b/chromium-hunspell-nullptr.patch
new file mode 100644
index 0000000..b215049
--- /dev/null
+++ b/chromium-hunspell-nullptr.patch
@@ -0,0 +1,12 @@
+diff -up qtwebengine-everywhere-src-5.15.8/src/3rdparty/chromium/third_party/hunspell/src/hunspell/hunspell.cxx.nullptr qtwebengine-everywhere-src-5.15.8/src/3rdparty/chromium/third_party/hunspell/src/hunspell/hunspell.cxx
+--- qtwebengine-everywhere-src-5.15.8/src/3rdparty/chromium/third_party/hunspell/src/hunspell/hunspell.cxx.nullptr	2021-12-15 10:09:27.000000000 -0600
++++ qtwebengine-everywhere-src-5.15.8/src/3rdparty/chromium/third_party/hunspell/src/hunspell/hunspell.cxx	2022-01-19 10:30:40.845051982 -0600
+@@ -1725,7 +1725,7 @@ std::string HunspellImpl::get_xml_par(co
+   if (end == '>')
+     end = '<';
+   else if (end != '\'' && end != '"')
+-    return 0;  // bad XML
++    return dest;  // bad XML
+   for (par++; *par != '\0' && *par != end; ++par) {
+     dest.push_back(*par);
+   }
diff --git a/qt5-qtwebengine.spec b/qt5-qtwebengine.spec
index bbbf040..16a7895 100644
--- a/qt5-qtwebengine.spec
+++ b/qt5-qtwebengine.spec
@@ -94,6 +94,7 @@ Patch4:  qtwebengine-SIOCGSTAMP.patch
 Patch5:  qtwebengine-5.15.0-QT_DEPRECATED_VERSION.patch
 # gcc-12 FTBFS "use of deleted function"
 Patch6:  chromium-angle-nullptr.patch
+Patch7:  chromium-hunspell-nullptr.patch
 # Fix/workaround FTBFS on aarch64 with newer glibc
 Patch24: qtwebengine-everywhere-src-5.11.3-aarch64-new-stat.patch
 # Use Python2
@@ -401,7 +402,8 @@ popd
 %endif
 %patch4 -p1 -b .SIOCGSTAMP
 %patch5 -p1 -b .QT_DEPRECATED_VERSION
-%patch6 -p1 -b .nullptr
+%patch6 -p1 -b .angle_nullptr
+%patch7 -p1 -b .hunspell_nullptr
 
 ## upstream patches
 %patch24 -p1 -b .aarch64-new-stat