import
This commit is contained in:
parent
fe3b76a2e3
commit
ea58782d0c
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
|||||||
|
/qttools-opensource-src-5.0.2.tar.xz
|
9
assistant.desktop
Normal file
9
assistant.desktop
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Name=Qt5 Assistant
|
||||||
|
GenericName=Documentation viewer
|
||||||
|
Comment=Shows Qt5 documentation and examples
|
||||||
|
Exec=assistant-qt5
|
||||||
|
Icon=assistant-qt5
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Categories=Qt;Development;Documentation;
|
10
designer.desktop
Normal file
10
designer.desktop
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Name=Qt5 Designer
|
||||||
|
GenericName=Interface Designer
|
||||||
|
Comment=Design GUIs for Qt5 applications
|
||||||
|
Exec=designer-qt5
|
||||||
|
Icon=designer-qt5
|
||||||
|
MimeType=application/x-designer;
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Categories=Qt;Development;
|
10
linguist.desktop
Normal file
10
linguist.desktop
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Name=Qt5 Linguist
|
||||||
|
GenericName=Translation tool
|
||||||
|
Comment=Add translations to Qt5 applications
|
||||||
|
Exec=linguist-qt5
|
||||||
|
Icon=linguist-qt5
|
||||||
|
MimeType=text/vnd.trolltech.linguist;application/x-linguist;
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Categories=Qt;Development;
|
10
qdbusviewer.desktop
Normal file
10
qdbusviewer.desktop
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Name=Qt5 QDbusViewer
|
||||||
|
GenericName=D-Bus Debugger
|
||||||
|
Comment=Debug D-Bus applications
|
||||||
|
Exec=qdbusviewer-qt5
|
||||||
|
Icon=qt5-qdbusviewer
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Categories=Qt;Development;Debugger;
|
||||||
|
|
225
qt5-qttools.spec
Normal file
225
qt5-qttools.spec
Normal file
@ -0,0 +1,225 @@
|
|||||||
|
|
||||||
|
%global qt_module qttools
|
||||||
|
%global system_clucene 1
|
||||||
|
|
||||||
|
Summary: Qt5 - QtTool components
|
||||||
|
Name: qt5-qttools
|
||||||
|
Version: 5.0.2
|
||||||
|
Release: 4%{?dist}
|
||||||
|
|
||||||
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
|
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
||||||
|
Url: http://qt-project.org/
|
||||||
|
Source0: http://download.qt-project.org/archive/qt/5.0/%{version}/submodules/%{qt_module}-opensource-src-%{version}.tar.xz
|
||||||
|
|
||||||
|
Patch1: qttools-system_clucene.patch
|
||||||
|
|
||||||
|
Source20: assistant.desktop
|
||||||
|
Source21: designer.desktop
|
||||||
|
Source22: linguist.desktop
|
||||||
|
Source23: qdbusviewer.desktop
|
||||||
|
|
||||||
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: qt5-qtbase-devel >= %{version}
|
||||||
|
BuildRequires: qt5-qtbase-static
|
||||||
|
%if 0%{?system_clucene}
|
||||||
|
BuildRequires: clucene09-core-devel
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
|
||||||
|
|
||||||
|
Provides: qt5-assistant = %{version}-%{release}
|
||||||
|
Provides: qt5-qdbusviewer = %{version}-%{release}
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: qt5-qtbase-devel%{?_isa}
|
||||||
|
Provides: qt5-designer = %{version}-%{release}
|
||||||
|
Provides: qt5-linguist = %{version}-%{release}
|
||||||
|
%description devel
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package static
|
||||||
|
Summary: Static library files for %{name}
|
||||||
|
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||||
|
%description static
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n qttools-opensource-src-%{version}%{?pre:-%{pre}}
|
||||||
|
|
||||||
|
%if 0%{?system_clucene}
|
||||||
|
%patch1 -p1 -b .system_clucene
|
||||||
|
# bundled libs
|
||||||
|
#mv src/assistant/3rdparty/clucene \
|
||||||
|
# src/assistant/3rdparty/clucene.BAK
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%{_qt5_qmake}
|
||||||
|
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
make install INSTALL_ROOT=%{buildroot}
|
||||||
|
|
||||||
|
# Add desktop files, --vendor=qt4 helps avoid possible conflicts with qt3/qt4
|
||||||
|
desktop-file-install \
|
||||||
|
--dir=%{buildroot}%{_datadir}/applications \
|
||||||
|
--vendor="qt5" \
|
||||||
|
%{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}
|
||||||
|
|
||||||
|
# icons
|
||||||
|
install -m644 -p -D src/assistant/assistant/images/assistant.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/assistant-qt5.png
|
||||||
|
install -m644 -p -D src/assistant/assistant/images/assistant-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/assistant-qt5.png
|
||||||
|
install -m644 -p -D src/designer/src/designer/images/designer.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/designer-qt5.png
|
||||||
|
install -m644 -p -D src/qdbus/qdbusviewer/images/qdbusviewer.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/qdbusviewer-qt5.png
|
||||||
|
install -m644 -p -D src/qdbus/qdbusviewer/images/qdbusviewer-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/qdbusviewer-qt5.png
|
||||||
|
# linguist icons
|
||||||
|
for icon in src/linguist/linguist/images/icons/linguist-*-32.png ; do
|
||||||
|
size=$(echo $(basename ${icon}) | cut -d- -f2)
|
||||||
|
install -p -m644 -D ${icon} %{buildroot}%{_datadir}/icons/hicolor/${size}x${size}/apps/linguist.png
|
||||||
|
done
|
||||||
|
|
||||||
|
# put non-conflicting binaries with -qt5 postfix in %%{_bindir}
|
||||||
|
mkdir %{buildroot}%{_bindir}
|
||||||
|
pushd %{buildroot}%{_qt5_bindir}
|
||||||
|
for i in * ; do
|
||||||
|
case "${i}" in
|
||||||
|
assistant|designer|lconvert|linguist|lrelease|lupdate|pixeltool|qcollectiongenerator|qdbus|qdbusviewer|qhelpconverter|qhelpgenerator)
|
||||||
|
mv $i ../../../bin/${i}-qt5
|
||||||
|
ln -s ../../../bin/${i}-qt5 .
|
||||||
|
ln -s ../../../bin/${i}-qt5 $i
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
mv $i ../../../bin/
|
||||||
|
ln -s ../../../bin/$i .
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
done
|
||||||
|
popd
|
||||||
|
|
||||||
|
## .prl/.la file love
|
||||||
|
# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
|
||||||
|
pushd %{buildroot}%{_qt5_libdir}
|
||||||
|
for prl_file in libQt5*.prl ; do
|
||||||
|
sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
|
||||||
|
if [ -f "$(basename ${prl_file} .prl).so" ]; then
|
||||||
|
rm -fv "$(basename ${prl_file} .prl).la"
|
||||||
|
sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
popd
|
||||||
|
|
||||||
|
|
||||||
|
%post
|
||||||
|
/sbin/ldconfig
|
||||||
|
touch --no-create %{_datadir}/icons/hicolor ||:
|
||||||
|
|
||||||
|
%posttrans
|
||||||
|
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
|
||||||
|
|
||||||
|
%postun
|
||||||
|
/sbin/ldconfig
|
||||||
|
if [ $1 -eq 0 ] ; then
|
||||||
|
touch --no-create %{_datadir}/icons/hicolor ||:
|
||||||
|
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
|
||||||
|
fi
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_bindir}/assistant*
|
||||||
|
%{_bindir}/qdbus*
|
||||||
|
%{_bindir}/qdbusviewer*
|
||||||
|
%{_qt5_bindir}/assistant*
|
||||||
|
%{_qt5_bindir}/qdbus*
|
||||||
|
%{_qt5_bindir}/qdbusviewer*
|
||||||
|
%{_qt5_libdir}/libQt5CLucene.so.5*
|
||||||
|
%{_qt5_libdir}/libQt5Designer.so.5*
|
||||||
|
%{_qt5_libdir}/libQt5DesignerComponents.so.5*
|
||||||
|
%{_qt5_libdir}/libQt5Help.so.5*
|
||||||
|
%{_qt5_datadir}/phrasebooks/
|
||||||
|
%{_datadir}/applications/*assistant.desktop
|
||||||
|
%{_datadir}/applications/*qdbusviewer.desktop
|
||||||
|
%{_datadir}/icons/hicolor/*/apps/assistant*.*
|
||||||
|
%{_datadir}/icons/hicolor/*/apps/qdbusviewer*.*
|
||||||
|
|
||||||
|
%post devel
|
||||||
|
touch --no-create %{_datadir}/icons/hicolor ||:
|
||||||
|
|
||||||
|
%posttrans devel
|
||||||
|
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
|
||||||
|
update-desktop-database -q &> /dev/null ||:
|
||||||
|
|
||||||
|
%postun devel
|
||||||
|
if [ $1 -eq 0 ] ; then
|
||||||
|
touch --no-create %{_datadir}/icons/hicolor ||:
|
||||||
|
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
|
||||||
|
fi
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_bindir}/designer*
|
||||||
|
%{_bindir}/lconvert*
|
||||||
|
%{_bindir}/linguist*
|
||||||
|
%{_bindir}/lrelease*
|
||||||
|
%{_bindir}/lupdate*
|
||||||
|
%{_bindir}/pixeltool*
|
||||||
|
%{_bindir}/qcollectiongenerator*
|
||||||
|
%{_bindir}/qhelpconverter*
|
||||||
|
%{_bindir}/qhelpgenerator*
|
||||||
|
%{_qt5_bindir}/designer*
|
||||||
|
%{_qt5_bindir}/lconvert*
|
||||||
|
%{_qt5_bindir}/linguist*
|
||||||
|
%{_qt5_bindir}/lrelease*
|
||||||
|
%{_qt5_bindir}/lupdate*
|
||||||
|
%{_qt5_bindir}/pixeltool*
|
||||||
|
%{_qt5_bindir}/qcollectiongenerator*
|
||||||
|
%{_qt5_bindir}/qhelpconverter*
|
||||||
|
%{_qt5_bindir}/qhelpgenerator*
|
||||||
|
%{_qt5_headerdir}/Qt*/
|
||||||
|
%{_qt5_libdir}/libQt5CLucene.prl
|
||||||
|
%{_qt5_libdir}/libQt5CLucene.so
|
||||||
|
%{_qt5_libdir}/libQt5Designer*.prl
|
||||||
|
%{_qt5_libdir}/libQt5Designer*.so
|
||||||
|
%{_qt5_libdir}/libQt5Help.prl
|
||||||
|
%{_qt5_libdir}/libQt5Help.so
|
||||||
|
%{_qt5_libdir}/cmake/Qt5*/
|
||||||
|
%{_qt5_libdir}/pkgconfig/Qt5*.pc
|
||||||
|
%{_qt5_archdatadir}/mkspecs/modules/*.pri
|
||||||
|
%{_datadir}/applications/*designer.desktop
|
||||||
|
%{_datadir}/applications/*linguist.desktop
|
||||||
|
%{_datadir}/icons/hicolor/*/apps/designer*.*
|
||||||
|
%{_datadir}/icons/hicolor/*/apps/linguist*.*
|
||||||
|
|
||||||
|
%files static
|
||||||
|
%{_qt5_libdir}/libQt5UiTools.*a
|
||||||
|
%{_qt5_libdir}/libQt5UiTools.prl
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Aug 19 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-4
|
||||||
|
- use system clucene09-core
|
||||||
|
|
||||||
|
* Mon Apr 29 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-3
|
||||||
|
- drop deprecated Encoding= key from .desktop files
|
||||||
|
- add justification for desktop vendor usage
|
||||||
|
|
||||||
|
* Fri Apr 19 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-2
|
||||||
|
- add .desktop/icons for assistant, designer, linguist, qdbusviewer
|
||||||
|
|
||||||
|
* Thu Apr 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-1
|
||||||
|
- 5.0.2
|
||||||
|
|
||||||
|
* Mon Feb 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-2
|
||||||
|
- BR: pkgconfig(zlib)
|
||||||
|
- -static subpkg
|
||||||
|
|
||||||
|
* Sat Feb 23 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-1
|
||||||
|
- first try
|
||||||
|
|
224
qttools-system_clucene.patch
Normal file
224
qttools-system_clucene.patch
Normal file
@ -0,0 +1,224 @@
|
|||||||
|
diff -up qttools-opensource-src-5.0.2/src/assistant/clucene/fulltextsearch.pri.system_clucene qttools-opensource-src-5.0.2/src/assistant/clucene/fulltextsearch.pri
|
||||||
|
--- qttools-opensource-src-5.0.2/src/assistant/clucene/fulltextsearch.pri.system_clucene 2013-04-08 19:11:56.000000000 -0500
|
||||||
|
+++ qttools-opensource-src-5.0.2/src/assistant/clucene/fulltextsearch.pri 2013-08-18 13:50:04.872174953 -0500
|
||||||
|
@@ -1,125 +1,8 @@
|
||||||
|
-DEFINES += _BUILD_FOR_QT_ LUCENE_DISABLE_MEMTRACKING
|
||||||
|
-win32:DEFINES += _CRT_SECURE_NO_DEPRECATE _MT
|
||||||
|
-
|
||||||
|
-CLUCENEDIR = ../3rdparty/clucene/src/CLucene
|
||||||
|
-
|
||||||
|
-INCLUDEPATH += . .. \
|
||||||
|
- $$CLUCENEDIR \
|
||||||
|
- $$CLUCENEDIR/../ \
|
||||||
|
- $$CLUCENEDIR/analysis \
|
||||||
|
- $$CLUCENEDIR/analysis/standard \
|
||||||
|
- $$CLUCENEDIR/config \
|
||||||
|
- $$CLUCENEDIR/debug \
|
||||||
|
- $$CLUCENEDIR/document \
|
||||||
|
- $$CLUCENEDIR/index \
|
||||||
|
- $$CLUCENEDIR/queryParser \
|
||||||
|
- $$CLUCENEDIR/search \
|
||||||
|
- $$CLUCENEDIR/store \
|
||||||
|
- $$CLUCENEDIR/util
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-SOURCES += $$CLUCENEDIR/StdHeader.cpp \
|
||||||
|
- $$CLUCENEDIR/analysis/AnalysisHeader.cpp \
|
||||||
|
- $$CLUCENEDIR/analysis/Analyzers.cpp \
|
||||||
|
- $$CLUCENEDIR/config/gunichartables.cpp \
|
||||||
|
- $$CLUCENEDIR/config/repl_lltot.cpp \
|
||||||
|
- $$CLUCENEDIR/config/repl_tcscasecmp.cpp \
|
||||||
|
- $$CLUCENEDIR/config/repl_tcslwr.cpp \
|
||||||
|
- $$CLUCENEDIR/config/repl_tcstod.cpp \
|
||||||
|
- $$CLUCENEDIR/config/repl_tcstoll.cpp \
|
||||||
|
- $$CLUCENEDIR/config/repl_tprintf.cpp \
|
||||||
|
- $$CLUCENEDIR/config/threads.cpp \
|
||||||
|
- $$CLUCENEDIR/config/utf8.cpp \
|
||||||
|
- $$CLUCENEDIR/debug/condition.cpp \
|
||||||
|
- $$CLUCENEDIR/debug/error.cpp \
|
||||||
|
- $$CLUCENEDIR/debug/memtracking.cpp \
|
||||||
|
- $$CLUCENEDIR/document/DateField.cpp \
|
||||||
|
- $$CLUCENEDIR/document/Document.cpp \
|
||||||
|
- $$CLUCENEDIR/document/Field.cpp \
|
||||||
|
- $$CLUCENEDIR/index/CompoundFile.cpp \
|
||||||
|
- $$CLUCENEDIR/index/DocumentWriter.cpp \
|
||||||
|
- $$CLUCENEDIR/index/FieldInfos.cpp \
|
||||||
|
- $$CLUCENEDIR/index/FieldsReader.cpp \
|
||||||
|
- $$CLUCENEDIR/index/FieldsWriter.cpp \
|
||||||
|
- $$CLUCENEDIR/index/IndexModifier.cpp \
|
||||||
|
- $$CLUCENEDIR/index/IndexReader.cpp \
|
||||||
|
- $$CLUCENEDIR/index/IndexWriter.cpp \
|
||||||
|
- $$CLUCENEDIR/index/MultiReader.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentInfos.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentMergeInfo.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentMergeQueue.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentMerger.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentReader.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentTermDocs.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentTermEnum.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentTermPositions.cpp \
|
||||||
|
- $$CLUCENEDIR/index/SegmentTermVector.cpp \
|
||||||
|
- $$CLUCENEDIR/index/Term.cpp \
|
||||||
|
- $$CLUCENEDIR/index/TermInfo.cpp \
|
||||||
|
- $$CLUCENEDIR/index/TermInfosReader.cpp \
|
||||||
|
- $$CLUCENEDIR/index/TermInfosWriter.cpp \
|
||||||
|
- $$CLUCENEDIR/index/TermVectorReader.cpp \
|
||||||
|
- $$CLUCENEDIR/index/TermVectorWriter.cpp \
|
||||||
|
- $$CLUCENEDIR/queryParser/Lexer.cpp \
|
||||||
|
- $$CLUCENEDIR/queryParser/MultiFieldQueryParser.cpp \
|
||||||
|
- $$CLUCENEDIR/queryParser/QueryParser.cpp \
|
||||||
|
- $$CLUCENEDIR/queryParser/QueryParserBase.cpp \
|
||||||
|
- $$CLUCENEDIR/queryParser/QueryToken.cpp \
|
||||||
|
- $$CLUCENEDIR/queryParser/TokenList.cpp \
|
||||||
|
- $$CLUCENEDIR/search/BooleanQuery.cpp \
|
||||||
|
- $$CLUCENEDIR/search/BooleanScorer.cpp \
|
||||||
|
- $$CLUCENEDIR/search/CachingWrapperFilter.cpp \
|
||||||
|
- $$CLUCENEDIR/search/ChainedFilter.cpp \
|
||||||
|
- $$CLUCENEDIR/search/ConjunctionScorer.cpp \
|
||||||
|
- $$CLUCENEDIR/search/DateFilter.cpp \
|
||||||
|
- $$CLUCENEDIR/search/ExactPhraseScorer.cpp \
|
||||||
|
- $$CLUCENEDIR/search/Explanation.cpp \
|
||||||
|
- $$CLUCENEDIR/search/FieldCache.cpp \
|
||||||
|
- $$CLUCENEDIR/search/FieldCacheImpl.cpp \
|
||||||
|
- $$CLUCENEDIR/search/FieldDocSortedHitQueue.cpp \
|
||||||
|
- $$CLUCENEDIR/search/FieldSortedHitQueue.cpp \
|
||||||
|
- $$CLUCENEDIR/search/FilteredTermEnum.cpp \
|
||||||
|
- $$CLUCENEDIR/search/FuzzyQuery.cpp \
|
||||||
|
- $$CLUCENEDIR/search/HitQueue.cpp \
|
||||||
|
- $$CLUCENEDIR/search/Hits.cpp \
|
||||||
|
- $$CLUCENEDIR/search/IndexSearcher.cpp \
|
||||||
|
- $$CLUCENEDIR/search/MultiSearcher.cpp \
|
||||||
|
- $$CLUCENEDIR/search/MultiTermQuery.cpp \
|
||||||
|
- $$CLUCENEDIR/search/PhrasePositions.cpp \
|
||||||
|
- $$CLUCENEDIR/search/PhraseQuery.cpp \
|
||||||
|
- $$CLUCENEDIR/search/PhraseScorer.cpp \
|
||||||
|
- $$CLUCENEDIR/search/PrefixQuery.cpp \
|
||||||
|
- $$CLUCENEDIR/search/QueryFilter.cpp \
|
||||||
|
- $$CLUCENEDIR/search/RangeFilter.cpp \
|
||||||
|
- $$CLUCENEDIR/search/RangeQuery.cpp \
|
||||||
|
- $$CLUCENEDIR/search/SearchHeader.cpp \
|
||||||
|
- $$CLUCENEDIR/search/Similarity.cpp \
|
||||||
|
- $$CLUCENEDIR/search/SloppyPhraseScorer.cpp \
|
||||||
|
- $$CLUCENEDIR/search/Sort.cpp \
|
||||||
|
- $$CLUCENEDIR/search/TermQuery.cpp \
|
||||||
|
- $$CLUCENEDIR/search/TermScorer.cpp \
|
||||||
|
- $$CLUCENEDIR/search/WildcardQuery.cpp \
|
||||||
|
- $$CLUCENEDIR/search/WildcardTermEnum.cpp \
|
||||||
|
- $$CLUCENEDIR/store/FSDirectory.cpp \
|
||||||
|
- $$CLUCENEDIR/store/IndexInput.cpp \
|
||||||
|
- $$CLUCENEDIR/store/IndexOutput.cpp \
|
||||||
|
- $$CLUCENEDIR/store/Lock.cpp \
|
||||||
|
- $$CLUCENEDIR/store/MMapInput.cpp \
|
||||||
|
- $$CLUCENEDIR/store/RAMDirectory.cpp \
|
||||||
|
- $$CLUCENEDIR/store/TransactionalRAMDirectory.cpp \
|
||||||
|
- $$CLUCENEDIR/util/BitSet.cpp \
|
||||||
|
- $$CLUCENEDIR/util/Equators.cpp \
|
||||||
|
- $$CLUCENEDIR/util/FastCharStream.cpp \
|
||||||
|
- $$CLUCENEDIR/util/fileinputstream.cpp \
|
||||||
|
- $$CLUCENEDIR/util/Misc.cpp \
|
||||||
|
- $$CLUCENEDIR/util/Reader.cpp \
|
||||||
|
- $$CLUCENEDIR/util/StringBuffer.cpp \
|
||||||
|
- $$CLUCENEDIR/util/StringIntern.cpp \
|
||||||
|
- $$CLUCENEDIR/util/ThreadLocal.cpp \
|
||||||
|
- $$CLUCENEDIR/analysis/standard/StandardAnalyzer.cpp \
|
||||||
|
- $$CLUCENEDIR/analysis/standard/StandardFilter.cpp \
|
||||||
|
- $$CLUCENEDIR/analysis/standard/StandardTokenizer.cpp
|
||||||
|
|
||||||
|
+INCLUDEPATH += /usr/include/clucene09 $$[QT_INSTALL_LIBS]/clucene09
|
||||||
|
+LIBS += -L$$[QT_INSTALL_LIBS]/clucene09 -lclucene
|
||||||
|
+DEFINES += LUCENE_ENABLE_REFCOUNT
|
||||||
|
+QMAKE_CXXFLAGS += -fpermissive
|
||||||
|
|
||||||
|
#Header files
|
||||||
|
HEADERS += qclucene_global_p.h \
|
||||||
|
diff -up qttools-opensource-src-5.0.2/src/assistant/clucene/qindexreader.cpp.system_clucene qttools-opensource-src-5.0.2/src/assistant/clucene/qindexreader.cpp
|
||||||
|
--- qttools-opensource-src-5.0.2/src/assistant/clucene/qindexreader.cpp.system_clucene 2013-04-08 19:11:56.000000000 -0500
|
||||||
|
+++ qttools-opensource-src-5.0.2/src/assistant/clucene/qindexreader.cpp 2013-08-18 12:59:34.992893144 -0500
|
||||||
|
@@ -59,13 +59,13 @@ bool QCLuceneIndexReader::isLuceneFile(c
|
||||||
|
{
|
||||||
|
using namespace lucene::index;
|
||||||
|
|
||||||
|
- return IndexReader::isLuceneFile(filename);
|
||||||
|
+ return IndexReader::isLuceneFile(filename.toStdString().c_str());
|
||||||
|
}
|
||||||
|
|
||||||
|
bool QCLuceneIndexReader::indexExists(const QString &directory)
|
||||||
|
{
|
||||||
|
using namespace lucene::index;
|
||||||
|
- return IndexReader::indexExists(directory);
|
||||||
|
+ return IndexReader::indexExists(directory.toStdString().c_str());
|
||||||
|
}
|
||||||
|
|
||||||
|
QCLuceneIndexReader QCLuceneIndexReader::open(const QString &path)
|
||||||
|
@@ -73,7 +73,7 @@ QCLuceneIndexReader QCLuceneIndexReader:
|
||||||
|
using namespace lucene::index;
|
||||||
|
|
||||||
|
QCLuceneIndexReader indexReader;
|
||||||
|
- indexReader.d->reader = IndexReader::open(path);
|
||||||
|
+ indexReader.d->reader = IndexReader::open(path.toStdString().c_str());
|
||||||
|
|
||||||
|
return indexReader;
|
||||||
|
}
|
||||||
|
@@ -81,25 +81,25 @@ QCLuceneIndexReader QCLuceneIndexReader:
|
||||||
|
void QCLuceneIndexReader::unlock(const QString &path)
|
||||||
|
{
|
||||||
|
using namespace lucene::index;
|
||||||
|
- IndexReader::unlock(path);
|
||||||
|
+ IndexReader::unlock(path.toStdString().c_str());
|
||||||
|
}
|
||||||
|
|
||||||
|
bool QCLuceneIndexReader::isLocked(const QString &directory)
|
||||||
|
{
|
||||||
|
using namespace lucene::index;
|
||||||
|
- return IndexReader::isLocked(directory);
|
||||||
|
+ return IndexReader::isLocked(directory.toStdString().c_str());
|
||||||
|
}
|
||||||
|
|
||||||
|
quint64 QCLuceneIndexReader::lastModified(const QString &directory)
|
||||||
|
{
|
||||||
|
using namespace lucene::index;
|
||||||
|
- return quint64(IndexReader::lastModified(directory));
|
||||||
|
+ return quint64(IndexReader::lastModified(directory.toStdString().c_str()));
|
||||||
|
}
|
||||||
|
|
||||||
|
qint64 QCLuceneIndexReader::getCurrentVersion(const QString &directory)
|
||||||
|
{
|
||||||
|
using namespace lucene::index;
|
||||||
|
- return qint64(IndexReader::getCurrentVersion(directory));
|
||||||
|
+ return qint64(IndexReader::getCurrentVersion(directory.toStdString().c_str()));
|
||||||
|
}
|
||||||
|
|
||||||
|
void QCLuceneIndexReader::close()
|
||||||
|
@@ -155,7 +155,7 @@ bool QCLuceneIndexReader::document(qint3
|
||||||
|
void QCLuceneIndexReader::setNorm(qint32 doc, const QString &field, qreal value)
|
||||||
|
{
|
||||||
|
TCHAR *fieldName = QStringToTChar(field);
|
||||||
|
- d->reader->setNorm(int32_t(doc), fieldName, qreal(value));
|
||||||
|
+ d->reader->setNorm(int32_t(doc), fieldName, float(value));
|
||||||
|
delete [] fieldName;
|
||||||
|
}
|
||||||
|
|
||||||
|
diff -up qttools-opensource-src-5.0.2/src/assistant/clucene/qindexwriter.cpp.system_clucene qttools-opensource-src-5.0.2/src/assistant/clucene/qindexwriter.cpp
|
||||||
|
--- qttools-opensource-src-5.0.2/src/assistant/clucene/qindexwriter.cpp.system_clucene 2013-04-08 19:11:56.000000000 -0500
|
||||||
|
+++ qttools-opensource-src-5.0.2/src/assistant/clucene/qindexwriter.cpp 2013-08-18 12:59:34.992893144 -0500
|
||||||
|
@@ -50,7 +50,7 @@ QCLuceneIndexWriter::QCLuceneIndexWriter
|
||||||
|
: d(new QCLuceneIndexWriterPrivate())
|
||||||
|
, analyzer(analyzer)
|
||||||
|
{
|
||||||
|
- d->writer = new lucene::index::IndexWriter(path,
|
||||||
|
+ d->writer = new lucene::index::IndexWriter(path.toStdString().c_str(),
|
||||||
|
analyzer.d->analyzer, create, closeDir);
|
||||||
|
}
|
||||||
|
|
||||||
|
diff -up qttools-opensource-src-5.0.2/src/assistant/clucene/qsearchable.cpp.system_clucene qttools-opensource-src-5.0.2/src/assistant/clucene/qsearchable.cpp
|
||||||
|
--- qttools-opensource-src-5.0.2/src/assistant/clucene/qsearchable.cpp.system_clucene 2013-04-08 19:11:56.000000000 -0500
|
||||||
|
+++ qttools-opensource-src-5.0.2/src/assistant/clucene/qsearchable.cpp 2013-08-18 12:59:34.992893144 -0500
|
||||||
|
@@ -95,7 +95,7 @@ QCLuceneIndexSearcher::QCLuceneIndexSear
|
||||||
|
: QCLuceneSearcher()
|
||||||
|
{
|
||||||
|
lucene::search::IndexSearcher *searcher =
|
||||||
|
- new lucene::search::IndexSearcher(path);
|
||||||
|
+ new lucene::search::IndexSearcher(path.toStdString().c_str());
|
||||||
|
|
||||||
|
reader.d->reader = searcher->getReader();
|
||||||
|
reader.d->deleteCLuceneIndexReader = false;
|
Loading…
Reference in New Issue
Block a user