- apply patch to fix the color issue in 24bit mode (cirrus driver)
This commit is contained in:
parent
2547722966
commit
fdfba67b94
15
qt-everywhere-opensource-src-4.7.0-bpp24.patch
Normal file
15
qt-everywhere-opensource-src-4.7.0-bpp24.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -up qt-everywhere-opensource-src-4.7.0/src/gui/image/qpixmap_x11.cpp.me qt-everywhere-opensource-src-4.7.0/src/gui/image/qpixmap_x11.cpp
|
||||
--- qt-everywhere-opensource-src-4.7.0/src/gui/image/qpixmap_x11.cpp.me 2010-10-15 22:04:09.000000000 +0200
|
||||
+++ qt-everywhere-opensource-src-4.7.0/src/gui/image/qpixmap_x11.cpp 2010-10-15 22:04:18.000000000 +0200
|
||||
@@ -900,9 +900,9 @@ void QX11PixmapData::fromImage(const QIm
|
||||
case BPP24_888: // 24 bit MSB
|
||||
CYCLE(
|
||||
for (int x=0; x<w; x++) {
|
||||
- *dst++ = qRed (*p);
|
||||
+ *dst++ = qBlue (*p);
|
||||
*dst++ = qGreen(*p);
|
||||
- *dst++ = qBlue (*p++);
|
||||
+ *dst++ = qRed (*p++);
|
||||
}
|
||||
)
|
||||
break;
|
9
qt.spec
9
qt.spec
@ -18,7 +18,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.7.0
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||
@ -79,6 +79,9 @@ Patch60: qt-4.6.3-bn-rendering-bz562058.patch
|
||||
Patch61: qt-4.6.3-indic-rendering-bz631732.patch
|
||||
Patch62: qt-4.6.3-indic-rendering-bz636399.patch
|
||||
|
||||
# fix 24bit color issue
|
||||
Patch63: qt-everywhere-opensource-src-4.7.0-bpp24.patch
|
||||
|
||||
# security patches
|
||||
|
||||
## upstream patches
|
||||
@ -435,6 +438,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
%patch60 -p1 -b .bn-rendering-bz562058
|
||||
%patch61 -p1 -b .indic-rendering-bz631732
|
||||
%patch62 -p1 -b .indic-rendering-bz636399
|
||||
%patch63 -p1 -b .bpp24
|
||||
|
||||
# security fixes
|
||||
|
||||
@ -1101,6 +1105,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Oct 15 2010 Than Ngo <than@redhat.com> - 4.7.0-6
|
||||
- apply patch to fix the color issue in 24bit mode (cirrus driver)
|
||||
|
||||
* Thu Sep 30 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-5
|
||||
- Wrong Cursor when widget become native on X11 (QTBUG-6185)
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user