- Crash in drawPixmap in Qt 4.7rc1 (#631845, QTBUG-12826)
This commit is contained in:
parent
3e6009be04
commit
f8f69bf18e
13
qt-everywhere-opensource-src-4.7.0-rc1-QTBUG-12826.patch
Normal file
13
qt-everywhere-opensource-src-4.7.0-rc1-QTBUG-12826.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/src/gui/painting/qpaintengine_x11.cpp b/src/gui/painting/qpaintengine_x11.cpp
|
||||
index e521e01..d430f77 100644
|
||||
--- a/src/gui/painting/qpaintengine_x11.cpp
|
||||
+++ b/src/gui/painting/qpaintengine_x11.cpp
|
||||
@@ -1914,6 +1914,8 @@ void QX11PaintEngine::drawPixmap(const QRectF &r, const QPixmap &px, const QRect
|
||||
int sh = qRound(sr.height());
|
||||
|
||||
QPixmap pixmap = qt_toX11Pixmap(px);
|
||||
+ if (pixmap.isNull())
|
||||
+ return;
|
||||
|
||||
if ((d->xinfo && d->xinfo->screen() != pixmap.x11Info().screen())
|
||||
|| (pixmap.x11Info().screen() != DefaultScreen(X11->display))) {
|
8
qt.spec
8
qt.spec
@ -17,7 +17,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.7.0
|
||||
Release: 0.29.%{pre}%{?dist}
|
||||
Release: 0.30.%{pre}%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
||||
@ -65,6 +65,8 @@ Patch58: qt-everywhere-opensource-src-4.7.0-beta1-qtwebkit_pluginpath.patch
|
||||
# security patches
|
||||
|
||||
# upstream patches
|
||||
# http://bugreports.qt.nokia.com/browse/QTBUG-12826
|
||||
Patch100: qt-everywhere-opensource-src-4.7.0-rc1-QTBUG-12826.patch
|
||||
|
||||
# kde-qt git patches
|
||||
Patch201: 0001-This-patch-uses-object-name-as-a-fallback-for-window.patch
|
||||
@ -421,6 +423,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
# security fixes
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .QTBUG-12826
|
||||
|
||||
# kde-qt branch
|
||||
%if 0%{?kde_qt}
|
||||
@ -1086,6 +1089,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Sep 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-0.30.rc1
|
||||
- Crash in drawPixmap in Qt 4.7rc1 (#631845, QTBUG-12826)
|
||||
|
||||
* Mon Aug 30 2010 Than Ngo <than@redhat.com> - 4.7.0-0.29.rc1
|
||||
- drop the patch, it's already fixed in upstream
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user