fix #189012, qt settings should be readable for other
This commit is contained in:
parent
b67df495dd
commit
eb4c326d6a
14
qt-x11-free-3.3.7-umask.patch
Normal file
14
qt-x11-free-3.3.7-umask.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- qt-x11-free-3.3.7/src/tools/qsettings.cpp.tn 2006-11-09 20:53:25.000000000 +0100
|
||||
+++ qt-x11-free-3.3.7/src/tools/qsettings.cpp 2006-11-09 20:59:53.000000000 +0100
|
||||
@@ -994,7 +994,10 @@
|
||||
#endif
|
||||
|
||||
QFile file( filename + ".tmp" );
|
||||
- if (! file.open(IO_WriteOnly)) {
|
||||
+ mode_t old_umask = umask(0022);
|
||||
+ bool f = file.open(IO_WriteOnly);
|
||||
+ umask(old_umask);
|
||||
+ if (! f) {
|
||||
|
||||
#ifdef QT_CHECK_STATE
|
||||
qWarning("QSettings::sync: failed to open '%s' for writing",
|
3
qt.spec
3
qt.spec
@ -18,6 +18,7 @@ Source7: qtconfig3.desktop
|
||||
Patch1: qt-3.3.4-print-CJK.patch
|
||||
Patch2: qt-3.0.5-nodebug.patch
|
||||
Patch3: qt-3.1.0-makefile.patch
|
||||
Patch4: qt-x11-free-3.3.7-umask.patch
|
||||
Patch5: qt-x11-free-3.3.6-strip.patch
|
||||
Patch7: qt-x11-free-3.3.2-quiet.patch
|
||||
Patch8: qt-x11-free-3.3.3-qembed.patch
|
||||
@ -247,6 +248,7 @@ for the Qt toolkit.
|
||||
%patch1 -p1 -b .cjk
|
||||
%patch2 -p1 -b .ndebug
|
||||
%patch3 -p1 -b .makefile
|
||||
%patch4 -p1 -b .umask
|
||||
%patch5 -p1
|
||||
%patch7 -p1 -b .quiet
|
||||
%patch8 -p1 -b .qembed
|
||||
@ -563,6 +565,7 @@ rm -rf %{buildroot}
|
||||
thanks Sachin Tawniya, LingNing Zhang for the fixes
|
||||
- move html files to devel
|
||||
- add sqlite plugin
|
||||
- fix #189012, qt settings should be readable for other
|
||||
|
||||
* Thu Aug 31 2006 Than Ngo <than@redhat.com> 1:3.3.6-13
|
||||
- add missing desktop files
|
||||
|
Loading…
x
Reference in New Issue
Block a user