This commit is contained in:
Than Ngo 2012-05-22 14:26:22 +02:00
parent 4656da0cd4
commit e9629e4208
4 changed files with 9 additions and 23 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@
/qt-everywhere-opensource-src-4.7.4.tar.gz
/qt-everywhere-opensource-src-4.8.0.tar.gz
/qt-everywhere-opensource-src-4.8.1.tar.gz
/qt-everywhere-opensource-src-4.8.2.tar.gz

View File

@ -1,14 +0,0 @@
diff -up qt-everywhere-opensource-src-4.8.1/src/gui/text/qtextlayout.cpp.QTBUG-24718 qt-everywhere-opensource-src-4.8.1/src/gui/text/qtextlayout.cpp
--- qt-everywhere-opensource-src-4.8.1/src/gui/text/qtextlayout.cpp.QTBUG-24718 2012-03-14 15:01:14.000000000 +0100
+++ qt-everywhere-opensource-src-4.8.1/src/gui/text/qtextlayout.cpp 2012-04-03 10:53:12.973058622 +0200
@@ -2508,6 +2508,10 @@ qreal QTextLine::cursorToX(int *cursorPo
int pos = *cursorPos;
int itm;
const HB_CharAttributes *attributes = eng->attributes();
+ if (!attributes) {
+ *cursorPos = 0;
+ return x.toReal();
+ }
while (pos < line.from + line.length && !attributes[pos].charStop)
pos++;
if (pos == line.from + (int)line.length) {

15
qt.spec
View File

@ -7,7 +7,7 @@
# See http://bugzilla.redhat.com/223663
%define multilib_archs x86_64 %{ix86} ppc64 ppc s390x s390 sparc64 sparcv9
%if 0%{?fedora} > 16
%if 0%{?fedora} > 16 || 0%{?rhel} > 6
# use external qt_settings pkg
%define qt_settings 1
%endif
@ -15,14 +15,14 @@
Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.8.1
Release: 15%{?dist}
Version: 4.8.2
Release: 1%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
Group: System Environment/Libraries
Url: http://qt.nokia.com/
Source0: http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-%{version}.tar.gz
Source0: http://releases.qt-project.org/qt4/source/qt-everywhere-opensource-src-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Obsoletes: qt4 < %{version}-%{release}
@ -120,9 +120,6 @@ Patch81: qt-everywhere-opensource-src-4.8.0-gcc-4.7.patch
# upstream patches
# http://codereview.qt-project.org/#change,22006
Patch100: qt-everywhere-opensource-src-4.8.1-qtgahandle.patch
# Fix a crash in cursorToX() when new block is added
# http://codereview.qt-project.org/22142
Patch101: qt-everywhere-opensource-src-4.8.1-QTBUG-24718.patch
# fix crash on big endian machines
# https://bugreports.qt-project.org/browse/QTBUG-22960
Patch102: qt-everywhere-opensource-src-4.8.1-type.patch
@ -468,7 +465,6 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
# upstream patches
%patch100 -p1 -b .QTgaHandler
%patch101 -p1 -b .QTBUG-24718
%patch102 -p1 -b .bigendian
# security fixes
@ -1101,6 +1097,9 @@ fi
%changelog
* Tue May 22 2012 Than Ngo <than@redhat.com> - 4.8.2-1
- 4.8.2
* Fri May 18 2012 Than Ngo <than@redhat.com> - 4.8.1-15
- add rhel/fedora condition

View File

@ -1,3 +1,3 @@
d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
6dcc0672ff9e60a6b83f95c5f42bec5b hi48-app-qt4-logo.png
7960ba8e18ca31f0c6e4895a312f92ff qt-everywhere-opensource-src-4.8.1.tar.gz
3c1146ddf56247e16782f96910a8423b qt-everywhere-opensource-src-4.8.2.tar.gz