- adjust qt-3.3.8-fontrendering-as_IN-209972.patch and

qt-3.3.8-fontrendering-#214570.patch for qt-3.3.8
This commit is contained in:
Than Ngo 2007-04-11 13:28:18 +00:00
parent e84ad30a9d
commit e6ea0aa6ef
3 changed files with 41 additions and 3 deletions

View File

@ -0,0 +1,23 @@
--- qt-x11-free-3.3.8/src/kernel/qscriptengine_x11.cpp.orig 2007-04-11 15:05:34.000000000 +0200
+++ qt-x11-free-3.3.8/src/kernel/qscriptengine_x11.cpp 2007-04-11 15:22:19.000000000 +0200
@@ -1240,7 +1240,7 @@
int script = item->script;
Q_ASSERT(script >= QFont::Devanagari && script <= QFont::Sinhala);
const unsigned short script_base = 0x0900 + 0x80*(script-QFont::Devanagari);
- const unsigned short ra = script_base + 0x30;
+ unsigned short ra = script_base + 0x30; //it was const unsigned short ra before modification
const unsigned short halant = script_base + 0x4d;
const unsigned short nukta = script_base + 0x3c;
@@ -1278,6 +1278,11 @@
}
#endif
+ unsigned short *chkAssamese=reordered.data();
+ if((script == QFont::Bengali) && (*chkAssamese==0x09F0)) //if it is assamese ra
+ {
+ ra = script_base + 0x70;
+ }
if (len != 1) {
unsigned short *uc = reordered.data();
bool beginsWithRa = FALSE;

View File

@ -0,0 +1,11 @@
--- qt-x11-free-3.3.8/src/kernel/qscriptengine_x11.cpp.orig 2007-04-11 15:05:34.000000000 +0200
+++ qt-x11-free-3.3.8/src/kernel/qscriptengine_x11.cpp 2007-04-11 15:22:19.000000000 +0200
@@ -601,7 +601,7 @@
None, None, None, None,
None, None, None, None,
- None, None, None, None,
+ Below, None, None, None,
None, None, None, None,
None, None, None, None,
None, None, None, None,

10
qt.spec
View File

@ -1,7 +1,7 @@
Summary: The shared library for the Qt GUI toolkit.
Name: qt
Version: 3.3.8
Release: 3%{?dist}
Release: 4%{?dist}
Epoch: 1
License: GPL/QPL
Group: System Environment/Libraries
@ -32,10 +32,10 @@ Patch25: qt-x11-free-3.3.8-uic-multilib.patch
Patch26: qt-3.3.6-fontrendering-punjabi-209970.patch
Patch27: qt-3.3.6-fontrendering-ml_IN-209097.patch
Patch28: qt-3.3.6-fontrendering-or_IN-209098.patch
Patch29: qt-3.3.6-fontrendering-as_IN-209972.patch
Patch29: qt-3.3.8-fontrendering-as_IN-209972.patch
Patch31: qt-3.3.6-fontrendering-te_IN-211259.patch
Patch32: qt-3.3.6-fontrendering-214371.patch
Patch33: qt-3.3.6-fontrendering-#214570.patch
Patch33: qt-3.3.8-fontrendering-#214570.patch
Patch34: qt-3.3.6-fontrendering-ml_IN-209974.patch
Patch35: qt-3.3.6-fontrendering-ml_IN-217657.patch
@ -564,6 +564,10 @@ rm -rf %{buildroot}
%changelog
* Wed Apr 11 2007 Than Ngo <than@redhat.com> - 1:3.3.8-4.fc7
- adjust qt-3.3.8-fontrendering-as_IN-209972.patch and
qt-3.3.8-fontrendering-#214570.patch for qt-3.3.8
* Mon Apr 02 2007 Than Ngo <than@redhat.com> - 1:3.3.8-3.fc7
- apply patches to fix
Qt UTF-8 overlong sequence decoding vulnerability