Stop using the NameOwnerChanged signal without arg0 in QtDBus itself
This commit is contained in:
parent
6234a6f70e
commit
df6016dd04
30
qt-everywhere-opensource-src-4.6.0-QTBUG-5972.patch
Normal file
30
qt-everywhere-opensource-src-4.6.0-QTBUG-5972.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From a06da644f9293424f0f537c1d9288796403cd979 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Thiago Macieira <thiago.macieira@nokia.com>
|
||||||
|
Date: Thu, 19 Nov 2009 10:01:47 +0100
|
||||||
|
Subject: [PATCH] Revert "Stop using the NameOwnerChanged signal without arg0 in QtDBus itself"
|
||||||
|
|
||||||
|
This partially reverts commit 1176ecf0b533279e5a1c97f183e5c5f1c57fb188.
|
||||||
|
|
||||||
|
Task-number: QTBUG-5972
|
||||||
|
(cherry picked from commit db1cff73726ff12d50139769dc8071f9e9173261)
|
||||||
|
---
|
||||||
|
src/dbus/qdbusconnection.cpp | 3 +++
|
||||||
|
1 files changed, 3 insertions(+), 0 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/dbus/qdbusconnection.cpp b/src/dbus/qdbusconnection.cpp
|
||||||
|
index b2a88ef..79ac8de 100644
|
||||||
|
--- a/src/dbus/qdbusconnection.cpp
|
||||||
|
+++ b/src/dbus/qdbusconnection.cpp
|
||||||
|
@@ -1005,6 +1005,9 @@ void QDBusConnectionPrivate::setBusService(const QDBusConnection &connection)
|
||||||
|
busService = new QDBusConnectionInterface(connection, this);
|
||||||
|
ref.deref(); // busService has increased the refcounting to us
|
||||||
|
// avoid cyclic refcounting
|
||||||
|
+// if (mode != PeerMode)
|
||||||
|
+ QObject::connect(busService, SIGNAL(serviceOwnerChanged(QString,QString,QString)),
|
||||||
|
+ this, SIGNAL(serviceOwnerChanged(QString,QString,QString)));
|
||||||
|
|
||||||
|
QObject::connect(this, SIGNAL(callWithCallbackFailed(QDBusError,QDBusMessage)),
|
||||||
|
busService, SIGNAL(callWithCallbackFailed(QDBusError,QDBusMessage)),
|
||||||
|
--
|
||||||
|
1.6.1
|
||||||
|
|
7
qt.spec
7
qt.spec
@ -13,7 +13,7 @@ Summary: Qt toolkit
|
|||||||
Name: qt
|
Name: qt
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.6.0
|
Version: 4.6.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
|
|
||||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
||||||
@ -79,6 +79,7 @@ Patch210: 0010-Fix-error-line-not-to-have-a-as-it-s-not-correct.patch
|
|||||||
Patch211: 0011-Fill-gap-of-X.org-XFree-multimedia-special-launcher-.patch
|
Patch211: 0011-Fill-gap-of-X.org-XFree-multimedia-special-launcher-.patch
|
||||||
Patch212: 0012-Add-context-to-tr-calls-in-QShortcut.patch
|
Patch212: 0012-Add-context-to-tr-calls-in-QShortcut.patch
|
||||||
Patch213: 0013-Fix-QNativeImage-constructor.patch
|
Patch213: 0013-Fix-QNativeImage-constructor.patch
|
||||||
|
Patch214: qt-everywhere-opensource-src-4.6.0-QTBUG-5972.patch
|
||||||
|
|
||||||
Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
|
Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
|
||||||
Source11: hi16-phonon-gstreamer.png
|
Source11: hi16-phonon-gstreamer.png
|
||||||
@ -433,6 +434,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
|||||||
#patch211 -p1 -b .kde-qt-0011
|
#patch211 -p1 -b .kde-qt-0011
|
||||||
%patch212 -p1 -b .kde-qt-0012
|
%patch212 -p1 -b .kde-qt-0012
|
||||||
#patch213 -p1 -b .kde-qt-0013
|
#patch213 -p1 -b .kde-qt-0013
|
||||||
|
%patch214 -p1 -b .QTBUG-5972
|
||||||
|
|
||||||
# drop -fexceptions from $RPM_OPT_FLAGS
|
# drop -fexceptions from $RPM_OPT_FLAGS
|
||||||
RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's|-fexceptions||g'`
|
RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's|-fexceptions||g'`
|
||||||
@ -1017,6 +1019,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 04 2009 Than Ngo <than@redhat.com> - 4.6.0-2
|
||||||
|
- Stop using the NameOwnerChanged signal without arg0 in QtDBus itself
|
||||||
|
|
||||||
* Tue Dec 01 2009 Than Ngo <than@redhat.com> - 4.6.0-1
|
* Tue Dec 01 2009 Than Ngo <than@redhat.com> - 4.6.0-1
|
||||||
- 4.6.0
|
- 4.6.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user