- add s390 and s390x to 3rdparty/webkit/JavaScriptCore/wtf/Platform.h and
3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
This commit is contained in:
parent
3d02d73f3c
commit
cf17e68ecc
61
qt-everywhere-opensource-src-4.7.0-beta1-s390x.patch
Normal file
61
qt-everywhere-opensource-src-4.7.0-beta1-s390x.patch
Normal file
@ -0,0 +1,61 @@
|
||||
diff -up qt-everywhere-opensource-src-4.7.0-beta1/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h.s390x qt-everywhere-opensource-src-4.7.0-beta1/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
|
||||
--- qt-everywhere-opensource-src-4.7.0-beta1/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h.s390x 2010-06-16 13:54:50.000000000 +0200
|
||||
+++ qt-everywhere-opensource-src-4.7.0-beta1/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h 2010-06-16 13:53:43.000000000 +0200
|
||||
@@ -179,6 +179,18 @@
|
||||
#define WTF_CPU_SPARC 1
|
||||
#endif
|
||||
|
||||
+/* CPU(S390X) - S390 64-bit */
|
||||
+#if defined(__s390x__)
|
||||
+#define WTF_CPU_S390X 1
|
||||
+#define WTF_CPU_BIG_ENDIAN 1
|
||||
+#endif
|
||||
+
|
||||
+/* CPU(S390) - S390 32-bit */
|
||||
+#if defined(__s390__)
|
||||
+#define WTF_CPU_S390 1
|
||||
+#define WTF_CPU_BIG_ENDIAN 1
|
||||
+#endif
|
||||
+
|
||||
/* CPU(X86) - i386 / x86 32-bit */
|
||||
#if defined(__i386__) \
|
||||
|| defined(i386) \
|
||||
@@ -860,7 +872,7 @@
|
||||
#endif
|
||||
|
||||
#if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
|
||||
-#if (CPU(X86_64) && (OS(UNIX) || OS(WINDOWS) || OS(SOLARIS) || OS(HPUX))) || (CPU(IA64) && !CPU(IA64_32)) || CPU(ALPHA) || CPU(AIX64) || CPU(SPARC64)
|
||||
+#if (CPU(X86_64) && (OS(UNIX) || OS(WINDOWS) || OS(SOLARIS) || OS(HPUX))) || (CPU(IA64) && !CPU(IA64_32)) || CPU(ALPHA) || CPU(AIX64) || CPU(SPARC64) || CPU(S390X)
|
||||
#define WTF_USE_JSVALUE64 1
|
||||
#elif CPU(ARM) || CPU(PPC64)
|
||||
#define WTF_USE_JSVALUE32 1
|
||||
diff -up qt-everywhere-opensource-src-4.7.0-beta1/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h.s390x qt-everywhere-opensource-src-4.7.0-beta1/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
|
||||
--- qt-everywhere-opensource-src-4.7.0-beta1/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h.s390x 2010-06-16 13:49:00.000000000 +0200
|
||||
+++ qt-everywhere-opensource-src-4.7.0-beta1/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h 2010-06-16 13:50:01.000000000 +0200
|
||||
@@ -169,6 +169,18 @@
|
||||
#define WTF_CPU_SPARC 1
|
||||
#endif
|
||||
|
||||
+/* CPU(S390X) - S390 64-bit */
|
||||
+#if defined(__s390x__)
|
||||
+#define WTF_CPU_S390X 1
|
||||
+#define WTF_CPU_BIG_ENDIAN 1
|
||||
+#endif
|
||||
+
|
||||
+/* CPU(S390) - S390 32-bit */
|
||||
+#if defined(__s390__)
|
||||
+#define WTF_CPU_S390 1
|
||||
+#define WTF_CPU_BIG_ENDIAN 1
|
||||
+#endif
|
||||
+
|
||||
/* CPU(X86) - i386 / x86 32-bit */
|
||||
#if defined(__i386__) \
|
||||
|| defined(i386) \
|
||||
@@ -874,6 +886,7 @@
|
||||
#if (CPU(X86_64) && (OS(UNIX) || OS(WINDOWS))) \
|
||||
|| (CPU(IA64) && !CPU(IA64_32)) \
|
||||
|| CPU(ALPHA) \
|
||||
+ || CPU(S390X) \
|
||||
|| CPU(SPARC64)
|
||||
#define WTF_USE_JSVALUE64 1
|
||||
#elif CPU(ARM) || CPU(PPC64) || CPU(MIPS)
|
9
qt.spec
9
qt.spec
@ -19,7 +19,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.7.0
|
||||
Release: 0.16.%{pre}%{?dist}
|
||||
Release: 0.17.%{pre}%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
||||
@ -59,6 +59,8 @@ Patch53: qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
|
||||
Patch54: qt-x11-opensource-src-4.5.1-mysql_config.patch
|
||||
# http://bugs.kde.org/show_bug.cgi?id=180051#c22
|
||||
Patch55: qt-everywhere-opensource-src-4.6.2-cups.patch
|
||||
# Add s390x as 64bit and s390 as 31bit bigendian platform
|
||||
Patch56: qt-everywhere-opensource-src-4.7.0-beta1-s390x.patch
|
||||
|
||||
# security patches
|
||||
|
||||
@ -419,6 +421,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
## TODO: upstream me
|
||||
%patch54 -p1 -b .mysql_config
|
||||
%patch55 -p1 -b .cups-1
|
||||
%patch56 -p1 -b .s390x
|
||||
|
||||
# security fixes
|
||||
|
||||
@ -1076,6 +1079,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 16 2010 Karsten Hopp <karsten@redhat.com> 4.7.0-0.17.beta1
|
||||
- add s390 and s390x to 3rdparty/webkit/JavaScriptCore/wtf/Platform.h and
|
||||
3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
|
||||
|
||||
* Fri Jun 11 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-0.16.beta1
|
||||
- scrub -lpulse-mainloop-glib from .prl files (#599844)
|
||||
- scrub references to %%buildroot in .pc, .prl files
|
||||
|
Loading…
Reference in New Issue
Block a user