- Resolves: bz#214371, bn_IN font rendering

- Resolves: bz#217657, ml_IN issue with cursor position
- Resolves: bz#217638, regression bug in qt
- Resolves: bz#209974, Vowel position set properly
- Resolves: bz#214570, Rendering is not fine for 'RA' 09B0
This commit is contained in:
Than Ngo 2006-12-06 13:50:23 +00:00
parent eb4c326d6a
commit c565afb96f
4 changed files with 54 additions and 3 deletions

View File

@ -0,0 +1,15 @@
diff -pruN qt-x11-free-3.3.6.org/src/kernel/qscriptengine_x11.cpp qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp
--- qt-x11-free-3.3.6.org/src/kernel/qscriptengine_x11.cpp 2006-12-04 18:47:11.000000000 +0530
+++ qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp 2006-12-05 12:05:10.000000000 +0530
@@ -1412,7 +1412,10 @@ static bool indic_shape_syllable(QOpenTy
toPos += 2;
if (script == QFont::Devanagari || script == QFont::Gujarati || script == QFont::Bengali) {
if (matra_position == Post || matra_position == Split) {
- toPos = matra+1;
+ if (matra_position == Post )
+ toPos = matra;
+ else
+ toPos = matra+1;
matra -= 2;
}
} else if (script == QFont::Kannada) {

View File

@ -0,0 +1,11 @@
--- qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp.orig 2006-11-29 17:17:26.000000000 +0100
+++ qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp 2006-11-29 17:22:34.000000000 +0100
@@ -864,7 +864,7 @@
None, None, None, Post,
None, None, None, None,
- None, Post, None, None,
+ None, None, None, None,
None, None, None, None,
None, None, Post, Post,

View File

@ -0,0 +1,12 @@
diff -pruN qt-x11-free-3.3.6.org/src/kernel/qfont_x11.cpp qt-x11-free-3.3.6/src/kernel/qfont_x11.cpp
--- qt-x11-free-3.3.6.org/src/kernel/qfont_x11.cpp 2006-03-08 00:00:00.000000000 +0530
+++ qt-x11-free-3.3.6/src/kernel/qfont_x11.cpp 2006-12-04 18:49:09.000000000 +0530
@@ -709,7 +709,7 @@ int QFontMetrics::charWidth( const QStri
if ( script >= QFont::Arabic && script <= QFont::Khmer ) {
// complex script shaping. Have to do some hard work
int from = QMAX( 0, pos - 8 );
- int to = QMIN( (int)str.length(), pos + 8 );
+ int to = str.length();
QConstString cstr( str.unicode()+from, to-from);
QTextEngine layout( cstr.string(), d );
layout.itemize( QTextEngine::WidthOnly );

19
qt.spec
View File

@ -1,7 +1,7 @@
Summary: The shared library for the Qt GUI toolkit.
Name: qt
Version: 3.3.7
Release: 1%{?dist}
Release: 2%{?dist}
Epoch: 1
License: GPL/QPL
Group: System Environment/Libraries
@ -35,7 +35,10 @@ Patch28: qt-3.3.6-fontrendering-or_IN-209098.patch
Patch29: qt-3.3.6-fontrendering-as_IN-209972.patch
Patch30: qt-3.3.6-fontrendering-bn_IN-209975.patch
Patch31: qt-3.3.6-fontrendering-te_IN-211259.patch
Patch32: qt-3.3.6-fontrendering-as_IN-211436.patch
Patch32: qt-3.3.6-fontrendering-214371.patch
Patch33: qt-3.3.6-fontrendering-#214570.patch
Patch34: qt-3.3.6-fontrendering-ml_IN-209974.patch
Patch35: qt-3.3.6-fontrendering-ml_IN-217657.patch
# immodule patches
Patch50: qt-x11-free-3.3.6-qt-x11-immodule-unified-qt3.3.5-20060318-pre.patch
@ -265,7 +268,10 @@ for the Qt toolkit.
%patch29 -p1 -b .fontrendering-as_IN-bz#209972
%patch30 -p1 -b .fontrendering-bn_IN-bz#209975
%patch31 -p1 -b .fontrendering-te_IN-bz#211259
%patch32 -p1 -b .fontrendering-as_IN-bz211436
%patch32 -p1 -b .fontrendering-bz#214371
%patch33 -p1 -b .fontrendering-#214570
%patch34 -p1 -b .fontrendering-#209974
%patch35 -p1 -b .fontrendering-ml_IN-217657
%if %{immodule}
%patch50 -p1 -b .pre
@ -553,6 +559,13 @@ rm -rf %{buildroot}
%changelog
* Wed Dec 06 2006 Than Ngo <than@redhat.com> - 1:3.3.7-2.fc7
- Resolves: bz#214371, bn_IN font rendering
- Resolves: bz#217657, ml_IN issue with cursor position
- Resolves: bz#217638, regression bug in qt
- Resolves: bz#209974, Vowel position set properly
- Resolves: bz#214570, Rendering is not fine for 'RA' 09B0
* Thu Nov 09 2006 Than Ngo <than@redhat.com> 1:3.3.7-1.fc6
- update to 3.3.7
- fix #209097, ml_IN font rendering