Merge branch 'master' into f16
This commit is contained in:
commit
c2e696277e
13
qt-everywhere-opensource-src-4.8.2--assistant-crash.patch
Normal file
13
qt-everywhere-opensource-src-4.8.2--assistant-crash.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up qt-everywhere-opensource-src-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp.me qt-everywhere-opensource-src-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp
|
||||
--- qt-everywhere-opensource-src-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp.me 2012-06-19 12:52:22.740180410 +0200
|
||||
+++ qt-everywhere-opensource-src-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp 2012-06-19 12:52:51.953194103 +0200
|
||||
@@ -944,8 +944,7 @@ void MainWindow::updateApplicationFont()
|
||||
if (helpEngine.usesAppFont())
|
||||
font = helpEngine.appFont();
|
||||
|
||||
- const QWidgetList &widgets = qApp->allWidgets();
|
||||
- foreach (QWidget* widget, widgets)
|
||||
+ foreach (QWidget* widget, QApplication::allWidgets())
|
||||
widget->setFont(font);
|
||||
}
|
||||
|
9
qt.spec
9
qt.spec
@ -16,7 +16,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.8.2
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||
@ -111,6 +111,9 @@ Patch77: qt-everywhere-opensource-src-4.8.1-icu_no_debug.patch
|
||||
# gcc doesn't support flag -fuse-ld=gold
|
||||
Patch80: qt-everywhere-opensource-src-4.8.0-ld-gold.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=810500
|
||||
Patch81: ./qt-everywhere-opensource-src-4.8.2--assistant-crash.patch
|
||||
|
||||
# upstream patches
|
||||
# http://codereview.qt-project.org/#change,22006
|
||||
Patch100: qt-everywhere-opensource-src-4.8.1-qtgahandle.patch
|
||||
@ -454,6 +457,7 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
||||
%patch76 -p1 -b .s390-atomic
|
||||
%patch77 -p1 -b .icu_no_debug
|
||||
%patch80 -p1 -b .ld.gold
|
||||
%patch81 -p1 -b .assistant-crash
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .QTgaHandler
|
||||
@ -1089,6 +1093,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 19 2012 Than Ngo <than@redhat.com> - 4.8.2-3
|
||||
- fix bz#810500, fix crash in assistant
|
||||
|
||||
* Tue May 29 2012 Than Ngo <than@redhat.com> - 4.8.2-2
|
||||
- fix bz#820767, lrelease-qt4 tries to run qmake not qmake-qt4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user