- disable JavaScriptCore JIT, SE Linux crashes (#527079)
This commit is contained in:
parent
45c933c0f3
commit
c2aca32302
24
qt-x11-opensource-src-4.5.3-javascript-disable-jit.patch
Normal file
24
qt-x11-opensource-src-4.5.3-javascript-disable-jit.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up qt-x11-opensource-src-4.5.3/src/3rdparty/webkit/JavaScriptCore/JavaScriptCore.pri.javascriptcore-disable-jit qt-x11-opensource-src-4.5.3/src/3rdparty/webkit/JavaScriptCore/JavaScriptCore.pri
|
||||
--- qt-x11-opensource-src-4.5.3/src/3rdparty/webkit/JavaScriptCore/JavaScriptCore.pri.javascriptcore-disable-jit 2009-09-29 13:01:35.000000000 +0200
|
||||
+++ qt-x11-opensource-src-4.5.3/src/3rdparty/webkit/JavaScriptCore/JavaScriptCore.pri 2009-10-06 10:39:55.976466622 +0200
|
||||
@@ -13,20 +13,6 @@ win32-* {
|
||||
LIBS += -lwinmm
|
||||
}
|
||||
|
||||
-# Disable the JIT due to numerous observed miscompilations :(
|
||||
-CONFIG(release):isEqual(QT_ARCH,i386) {
|
||||
- JIT_DEFINES = ENABLE_JIT ENABLE_WREC ENABLE_JIT_OPTIMIZE_CALL ENABLE_JIT_OPTIMIZE_PROPERTY_ACCESS ENABLE_JIT_OPTIMIZE_ARITHMETIC
|
||||
- # Require gcc >= 4.1
|
||||
- linux-g++*:greaterThan(QT_GCC_MAJOR_VERSION,3):greaterThan(QT_GCC_MINOR_VERSION,0) {
|
||||
- DEFINES += $$JIT_DEFINES WTF_USE_JIT_STUB_ARGUMENT_VA_LIST
|
||||
- QMAKE_CXXFLAGS += -fno-stack-protector
|
||||
- QMAKE_CFLAGS += -fno-stack-protector
|
||||
- }
|
||||
- win32-msvc* {
|
||||
- DEFINES += $$JIT_DEFINES WTF_USE_JIT_STUB_ARGUMENT_REGISTER
|
||||
- }
|
||||
-}
|
||||
-
|
||||
win32-msvc*: INCLUDEPATH += $$PWD/os-win32
|
||||
wince* {
|
||||
INCLUDEPATH += $$PWD/os-wince
|
9
qt.spec
9
qt.spec
@ -10,7 +10,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.5.3
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
||||
@ -44,6 +44,9 @@ Patch21: qt-x11-opensource-src-4.5.2-gst-pulsaudio.patch
|
||||
# use system ca-bundle certs, http://bugzilla.redhat.com/521911
|
||||
Patch22: qt-x11-opensource-src-4.5.3-system_ca_certificates.patch
|
||||
Requires: ca-certificates
|
||||
# disable JavaScriptCore JIT as it crashes with SE Linux
|
||||
# http://bugzilla.redhat.com/527079
|
||||
Patch23: qt-x11-opensource-src-4.5.3-javascript-disable-jit.patch
|
||||
|
||||
## upstreamable bits
|
||||
# http://bugzilla.redhat.com/485677
|
||||
@ -371,6 +374,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
%patch19 -p1 -b .servicesfile
|
||||
%patch21 -p1 -b .gst-pulsaudio
|
||||
%patch22 -p1 -b .system_ca_certificates
|
||||
%patch23 -p1 -b .javascriptcore-disable-jit
|
||||
%patch51 -p1 -b .qdoc3
|
||||
%patch52 -p1 -b .sparc64
|
||||
%patch53 -p1 -b .qatomic-inline-asm
|
||||
@ -962,6 +966,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 06 2009 Jaroslav Reznik <jreznik@redhat.com> - 4.5.3-3
|
||||
- disable JavaScriptCore JIT, SE Linux crashes (#527079)
|
||||
|
||||
* Fri Oct 02 2009 Than Ngo <than@redhat.com> - 4.5.3-2
|
||||
- cleanup patches
|
||||
- if ! phonon_internal, exclude more/all phonon headers
|
||||
|
Loading…
Reference in New Issue
Block a user