Hardcode the compiler version in the build key once and for all

* Wed Aug 19 2020 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.8.7-57
- Hardcode the compiler version in the build key once and for all

It does not make sense to have to mess with the build key again and
again at each GCC major version. GCC major versions no longer carry any
ABI meaning as in the days of GCC 2.95 vs. 3.0. And nobody really uses a
GCC older than 4.0 anymore. So we just hardcode the compiler version in
the build key to "4". See also my corresponding Qt 3 patch from January
2019.
This commit is contained in:
Kevin Kofler 2020-08-19 23:51:51 +02:00
parent 110ec9baed
commit c0e685509d
4 changed files with 55 additions and 26 deletions

View File

@ -1,24 +1,3 @@
diff -up qt-everywhere-opensource-src-4.8.7/configure.gcc6 qt-everywhere-opensource-src-4.8.7/configure
--- qt-everywhere-opensource-src-4.8.7/configure.gcc6 2016-04-15 07:04:19.430268222 -0500
+++ qt-everywhere-opensource-src-4.8.7/configure 2016-04-15 07:05:22.157568689 -0500
@@ -7744,7 +7744,7 @@ case "$XPLATFORM" in
*-g++*)
# Check gcc's version
case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
- 5*|4*|3.4*)
+ 11*|10*|9*|8*|7*|6*|5*|4*|3.4*)
;;
3.3*)
canBuildWebKit="no"
@@ -8060,7 +8060,7 @@ g++*)
3.*)
COMPILER_VERSION="3.*"
;;
- 5*|4.*)
+ 11*|10*|9*|8*|7*|6*|5*|4.*)
COMPILER_VERSION="4"
;;
*)
diff -up qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h
--- qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 2015-05-07 09:14:48.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h 2016-04-15 07:04:19.431268227 -0500

View File

@ -0,0 +1,43 @@
diff -ur qt-everywhere-opensource-src-4.8.7/configure qt-everywhere-opensource-src-4.8.7-hardcode-buildkey/configure
--- qt-everywhere-opensource-src-4.8.7/configure 2015-05-07 16:14:56.000000000 +0200
+++ qt-everywhere-opensource-src-4.8.7-hardcode-buildkey/configure 2020-08-19 23:43:10.792653485 +0200
@@ -7732,18 +7732,6 @@
canBuildQtXmlPatterns="no"
;;
*-g++*)
- # Check gcc's version
- case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
- 5*|4*|3.4*)
- ;;
- 3.3*)
- canBuildWebKit="no"
- ;;
- *)
- canBuildWebKit="no"
- canBuildQtXmlPatterns="no"
- ;;
- esac
;;
solaris-cc*)
# Check the compiler version
@@ -8043,19 +8031,7 @@
;;
esac
- case "$COMPILER_VERSION" in
- 2.95.*)
- COMPILER_VERSION="2.95.*"
- ;;
- 3.*)
- COMPILER_VERSION="3.*"
- ;;
- 5*|4.*)
- COMPILER_VERSION="4"
- ;;
- *)
- ;;
- esac
+ COMPILER_VERSION="4"
[ '!' -z "$COMPILER_VERSION" ] && COMPILER="g++-${COMPILER_VERSION}"
;;
icc*)

17
qt.spec
View File

@ -43,7 +43,7 @@ Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.8.7
Release: 56%{?dist}
Release: 57%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
@ -203,6 +203,12 @@ Patch95: qt-everywhere-opensource-src-4.8.7-icu59.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1580047
Patch96: qt-everywhere-opensource-src-4.8.7-gcc8_qtscript.patch
# Fix ordered pointer comparison against zero problem reported by gcc-11
Patch97: qt-everywhere-opensource-src-4.8.7-gcc11.patch
# hardcode the compiler version in the build key once and for all
Patch98: qt-everywhere-opensource-src-4.8.7-hardcode-buildkey.patch
# upstream patches
# backported from Qt5 (essentially)
# http://bugzilla.redhat.com/702493
@ -219,9 +225,6 @@ Patch180: qt-aarch64.patch
# https://github.com/qt/qtbase/commit/c35a3f519007af44c3b364b9af86f6a336f6411b.patch
Patch181: qt-everywhere-opensource-src-4.8.7-qforeach.patch
# Fix ordered pointer comparison against zero problem reported by gcc-11
Patch200: qt-gcc11.patch
## upstream git
## security patches
@ -650,6 +653,8 @@ rm -rf src/3rdparty/clucene
%if 0%{?fedora} > 27
%patch96 -p1 -b .gcc8_qtscript
%endif
%patch97 -p1 -b .gcc11
%patch98 -p1 -b .hardcode-buildkey
# upstream patches
%patch102 -p1 -b .qgtkstyle_disable_gtk_theme_check
@ -657,7 +662,6 @@ rm -rf src/3rdparty/clucene
%patch180 -p1 -b .aarch64
%patch181 -p1 -b .qforeach
%patch200 -p1 -b .gcc11
# upstream git
@ -1386,6 +1390,9 @@ fi
%changelog
* Wed Aug 19 2020 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.8.7-57
- Hardcode the compiler version in the build key once and for all
* Wed Aug 19 2020 Jeff Law <law@redhat.com> - 4.8.7-56
- Add support for gcc-11
- Fix ordered pointer comparison against zero problems