multilib QT_PLUGIN_PATH (#704840)
This commit is contained in:
parent
1f58c3a6d8
commit
bb9ed3a702
@ -1,19 +0,0 @@
|
||||
diff -up qt-everywhere-opensource-src-4.7.0-beta2/src/corelib/kernel/qcoreapplication.cpp.kde4_plugins qt-everywhere-opensource-src-4.7.0-beta2/src/corelib/kernel/qcoreapplication.cpp
|
||||
--- qt-everywhere-opensource-src-4.7.0-beta2/src/corelib/kernel/qcoreapplication.cpp.kde4_plugins 2010-06-29 20:53:15.000000000 -0500
|
||||
+++ qt-everywhere-opensource-src-4.7.0-beta2/src/corelib/kernel/qcoreapplication.cpp 2010-07-08 08:24:12.714604479 -0500
|
||||
@@ -2262,6 +2262,15 @@ QStringList QCoreApplication::libraryPat
|
||||
if (!app_libpaths->contains(installPathPlugins))
|
||||
app_libpaths->append(installPathPlugins);
|
||||
}
|
||||
+
|
||||
+ // hack in support for kde4 plugin paths -- Rex
|
||||
+ QString kde4PathPlugins = QLibraryInfo::location(QLibraryInfo::LibrariesPath) + QLatin1String("/kde4/plugins");
|
||||
+ if (QFile::exists(kde4PathPlugins)) {
|
||||
+ // Make sure we convert from backslashes to slashes.
|
||||
+ // kde4PathPlugins = QDir(kde4PathPlugins).canonicalPath();
|
||||
+ if (!app_libpaths->contains(kde4PathPlugins))
|
||||
+ app_libpaths->append(kde4PathPlugins);
|
||||
+ }
|
||||
#endif
|
||||
|
||||
// If QCoreApplication is not yet instantiated,
|
@ -0,0 +1,19 @@
|
||||
diff -up qt-everywhere-opensource-src-4.7.3/src/corelib/kernel/qcoreapplication.cpp.qt_plugin_path qt-everywhere-opensource-src-4.7.3/src/corelib/kernel/qcoreapplication.cpp
|
||||
--- qt-everywhere-opensource-src-4.7.3/src/corelib/kernel/qcoreapplication.cpp.qt_plugin_path 2011-03-30 00:19:08.000000000 -0500
|
||||
+++ qt-everywhere-opensource-src-4.7.3/src/corelib/kernel/qcoreapplication.cpp 2011-05-21 20:22:45.537241160 -0500
|
||||
@@ -2262,6 +2262,15 @@ QStringList QCoreApplication::libraryPat
|
||||
if (!app_libpaths->contains(installPathPlugins))
|
||||
app_libpaths->append(installPathPlugins);
|
||||
}
|
||||
+
|
||||
+ // hack in support for multilib qt4 plugin path -- Rex
|
||||
+ QString qt4_multilibPathPlugins = QLatin1String("/usr/lib/qt4/plugins");
|
||||
+ if (QFile::exists(qt4_multilibPathPlugins)) {
|
||||
+ // Make sure we convert from backslashes to slashes.
|
||||
+ // qt4_multilibPathPlugins = QDir(qt4_multilibPathPlugins).canonicalPath();
|
||||
+ if (!app_libpaths->contains(qt4_multilibPathPlugins))
|
||||
+ app_libpaths->append(qt4_multilibPathPlugins);
|
||||
+ }
|
||||
#endif
|
||||
|
||||
// If QCoreApplication is not yet instantiated,
|
12
qt.spec
12
qt.spec
@ -18,7 +18,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.7.3
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||
@ -45,9 +45,8 @@ Patch4: qt-everywhere-opensource-src-4.7.0-beta1-uic_multilib.patch
|
||||
# enable ft lcdfilter
|
||||
Patch15: qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
|
||||
|
||||
# include kde4 plugin path, http://bugzilla.redhat.com/498809
|
||||
# omit for now, (seems?) causes unwelcome side-effects -- Rex
|
||||
Patch16: qt-everywhere-opensource-src-4.7.0-beta2-kde4_plugins.patch
|
||||
# include multilib plugin paths, http://bugzilla.redhat.com/704840
|
||||
Patch16: qt-everywhere-opensource-src-4.7.3-multilib_qt_plugin_path.patch
|
||||
|
||||
# phonon gstreamer services
|
||||
Patch19: qt-everywhere-opensource-src-4.7.0-beta2-phonon_servicesfile.patch
|
||||
@ -491,7 +490,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
%setup -q -n qt-everywhere-opensource-src-%{version}
|
||||
|
||||
%patch15 -p1 -b .enable_ft_lcdfilter
|
||||
#patch16 -p1 -b .kde4_plugins
|
||||
%patch16 -p1 -b .multilib_qt_plugin_path
|
||||
%patch19 -p1 -b .phonon_servicesfile
|
||||
%patch23 -p1 -b .glib_eventloop_nullcheck
|
||||
## make -assistant subpkg instead (#660287#9)
|
||||
@ -1242,6 +1241,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat May 21 2011 Rex Dieter <rdieter@fedoraproject.org> 1:4.7.3-4
|
||||
- multilib QT_PLUGIN_PATH (#704840)
|
||||
|
||||
* Thu May 19 2011 Rex Dieter <rdieter@fedoraproject.org> 1:4.7.3-3
|
||||
- omit %%{_qt4_plugindir}/designer/libqwebview.so too
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user