- enable FT_LCD_FILTER

This commit is contained in:
Rex Dieter 2009-04-24 17:16:23 +00:00
parent 6cf04333d3
commit bb2ec7f619
5 changed files with 33 additions and 29 deletions

View File

@ -1,6 +1,4 @@
hi128-app-qt4-logo.png
hi48-app-qt4-logo.png
qt-x11-opensource-src-4.5.0.tar.bz2
qt-copy-patches-20090325svn.tar.bz2
qt-copy-patches-20090423svn.tar.bz2
qt-x11-opensource-src-4.5.1.tar.bz2
qt-copy-patches-20090424svn.tar.bz2

View File

@ -1,16 +0,0 @@
diff -up qt-x11-opensource-src-4.5.0/src/gui/text/qfontengine_ft.cpp.disable_ft_lcdfilter qt-x11-opensource-src-4.5.0/src/gui/text/qfontengine_ft.cpp
--- qt-x11-opensource-src-4.5.0/src/gui/text/qfontengine_ft.cpp.disable_ft_lcdfilter 2009-04-14 13:56:07.000000000 -0500
+++ qt-x11-opensource-src-4.5.0/src/gui/text/qfontengine_ft.cpp 2009-04-14 13:59:00.000000000 -0500
@@ -72,9 +72,9 @@
#include FT_CONFIG_OPTIONS_H
#endif
-#if defined(FT_LCD_FILTER_H) && defined(FT_CONFIG_OPTION_SUBPIXEL_RENDERING)
-#define QT_USE_FREETYPE_LCDFILTER
-#endif
+//#if defined(FT_LCD_FILTER_H) && defined(FT_CONFIG_OPTION_SUBPIXEL_RENDERING)
+//#define QT_USE_FREETYPE_LCDFILTER
+//#endif
#ifdef QT_LINUXBASE
#include FT_ERRORS_H

View File

@ -0,0 +1,21 @@
diff -up qt-x11-opensource-src-4.5.1/src/gui/text/qfontengine_ft.cpp.enable_ft_lcdfilter qt-x11-opensource-src-4.5.1/src/gui/text/qfontengine_ft.cpp
--- qt-x11-opensource-src-4.5.1/src/gui/text/qfontengine_ft.cpp.enable_ft_lcdfilter 2009-04-21 18:57:41.000000000 -0500
+++ qt-x11-opensource-src-4.5.1/src/gui/text/qfontengine_ft.cpp 2009-04-24 11:17:49.562695405 -0500
@@ -72,7 +72,7 @@
#include FT_CONFIG_OPTIONS_H
#endif
-#if defined(FT_LCD_FILTER_H) && defined(FT_CONFIG_OPTION_SUBPIXEL_RENDERING)
+#if defined(FT_LCD_FILTER_H) // && defined(FT_CONFIG_OPTION_SUBPIXEL_RENDERING)
#define QT_USE_FREETYPE_LCDFILTER
#endif
@@ -1051,7 +1051,7 @@ QFontEngineFT::Glyph *QFontEngineFT::loa
Q_ASSERT(antialias);
uchar *convoluted = new uchar[bitmap.rows*bitmap.pitch];
bool useLegacyLcdFilter = false;
-#if defined(FC_LCD_FILTER) && defined(FT_LCD_FILTER_H)
+#if defined(FT_LCD_FILTER_H) // && defined(FC_LCD_FILTER)
useLegacyLcdFilter = (lcdFilterType == FT_LCD_FILTER_LEGACY);
#endif
uchar *buffer = bitmap.buffer;

19
qt.spec
View File

@ -12,7 +12,7 @@ Epoch: 1
Name: qt4
%endif
Version: 4.5.1
Release: 1%{?dist}
Release: 3%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: LGPLv2 with exceptions or GPLv3 with exceptions
@ -41,8 +41,7 @@ Patch5: qt-all-opensource-src-4.4.0-rc1-as_IN-437440.patch
Patch13: qt-x11-opensource-src-4.5.0-gcc_hack.patch
# qt fails to build on ia64: http://bugzilla.redhat.com/492174
Patch14: qt-x11-opensource-src-4.5.0-ia64_boilerplate.patch
# http://bugzilla.redhat.com/490377
Patch15: qt-x11-opensource-src-4.5.0-disable_ft_lcdfilter.patch
Patch15: qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
## upstreamable bits
# http://bugzilla.redhat.com/485677
@ -54,7 +53,7 @@ Patch52: qt-4.5-sparc64.patch
Patch53: qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
## qt-copy patches
%define qt_copy 20090423
%define qt_copy 20090424
Source1: qt-copy-patches-svn_checkout.sh
%{?qt_copy:Source2: qt-copy-patches-%{qt_copy}svn.tar.bz2}
%{?qt_copy:Provides: qt-copy = %{qt_copy}}
@ -308,10 +307,6 @@ Qt libraries which are used for drawing widgets and OpenGL items.
%if 0%{?qt_copy}
echo "0250" >> patches/DISABLED
echo "0245" >> patches/DISABLED
echo "0275" >> patches/DISABLED
echo "0276" >> patches/DISABLED
echo "0278" >> patches/DISABLED
test -x apply_patches && ./apply_patches
%endif
@ -324,7 +319,7 @@ test -x apply_patches && ./apply_patches
%patch5 -p1 -b .bz#437440-as_IN-437440
%patch13 -p1 -b .gcc_hack
%patch14 -p1 -b .ia64_boilerplate
%patch15 -p1 -b .disable_ft_lcdfilter
%patch15 -p1 -b .enable_ft_lcdfilter
%patch51 -p1 -b .qdoc3
%patch52 -p1 -b .sparc64
%patch53 -p1 -b .qatomic-inline-asm
@ -809,6 +804,12 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%changelog
* Fri Apr 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-3
- enable FT_LCD_FILTER
* Fri Apr 24 2009 Than Ngo <than@redhat.com> - 4.5.1-2
- apply upstream patch to fix the svg rendering regression
* Thu Apr 23 2009 Than Ngo <than@redhat.com> - 4.5.1-1
- 4.5.1

View File

@ -1,4 +1,4 @@
d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
6dcc0672ff9e60a6b83f95c5f42bec5b hi48-app-qt4-logo.png
e658d26376d678bd45a877ca47e42b7a qt-copy-patches-20090423svn.tar.bz2
afc43e566341cf3e5ed0bcb974f0c3b2 qt-x11-opensource-src-4.5.1.tar.bz2
8718da189e55c91a749ec9d142aea784 qt-copy-patches-20090424svn.tar.bz2