Port the as_IN patch to Qt 4.4 (the code moved to harfbuzz).
This commit is contained in:
parent
d5666b9b35
commit
b3ca8bd302
@ -1,6 +1,7 @@
|
|||||||
--- qt-x11-opensource-src-4.3.4/src/gui/text/qscriptengine.cpp 2008-02-19 23:17:19.000000000 +0530
|
diff -ur qt-all-opensource-src-4.4.0-rc1/src/3rdparty/harfbuzz/src/harfbuzz-indic.cpp qt-all-opensource-src-4.4.0-rc1-as_IN-437440/src/3rdparty/harfbuzz/src/harfbuzz-indic.cpp
|
||||||
+++ qscriptengine.cpp_mod 2008-04-01 17:39:48.000000000 +0530
|
--- qt-all-opensource-src-4.4.0-rc1/src/3rdparty/harfbuzz/src/harfbuzz-indic.cpp 2008-04-02 18:33:48.000000000 +0200
|
||||||
@@ -2174,7 +2174,7 @@ static const unsigned char indicPosition
|
+++ qt-all-opensource-src-4.4.0-rc1-as_IN-437440/src/3rdparty/harfbuzz/src/harfbuzz-indic.cpp 2008-04-08 04:37:45.000000000 +0200
|
||||||
|
@@ -552,7 +552,7 @@
|
||||||
None, None, None, None,
|
None, None, None, None,
|
||||||
None, None, None, None,
|
None, None, None, None,
|
||||||
|
|
||||||
@ -9,17 +10,17 @@
|
|||||||
None, None, None, None,
|
None, None, None, None,
|
||||||
None, None, None, None,
|
None, None, None, None,
|
||||||
None, None, None, None,
|
None, None, None, None,
|
||||||
@@ -2814,7 +2814,7 @@ static bool indic_shape_syllable(QOpenTy
|
@@ -1169,7 +1169,7 @@
|
||||||
int script = item->script;
|
HB_Script script = item->item.script;
|
||||||
Q_ASSERT(script >= QUnicodeTables::Devanagari && script <= QUnicodeTables::Sinhala);
|
assert(script >= HB_Script_Devanagari && script <= HB_Script_Sinhala);
|
||||||
const unsigned short script_base = 0x0900 + 0x80*(script-QUnicodeTables::Devanagari);
|
const unsigned short script_base = 0x0900 + 0x80*(script-HB_Script_Devanagari);
|
||||||
- const unsigned short ra = script_base + 0x30;
|
- const unsigned short ra = script_base + 0x30;
|
||||||
+ unsigned short ra = script_base + 0x30;
|
+ unsigned short ra = script_base + 0x30;
|
||||||
const unsigned short halant = script_base + 0x4d;
|
const unsigned short halant = script_base + 0x4d;
|
||||||
const unsigned short nukta = script_base + 0x3c;
|
const unsigned short nukta = script_base + 0x3c;
|
||||||
|
bool control = false;
|
||||||
@@ -2856,6 +2856,19 @@ static bool indic_shape_syllable(QOpenTy
|
@@ -1212,6 +1212,19 @@
|
||||||
unsigned short *uc = reordered.data();
|
HB_UChar16 *uc = reordered;
|
||||||
bool beginsWithRa = false;
|
bool beginsWithRa = false;
|
||||||
|
|
||||||
+ // Exception in Bengali Script
|
+ // Exception in Bengali Script
|
||||||
@ -31,7 +32,7 @@
|
|||||||
+ // To handle this exception we need to change ra to from const to normal variable
|
+ // To handle this exception we need to change ra to from const to normal variable
|
||||||
+ // and aslo need to change ra to 'Base+0x70' whenever we will get assamese language
|
+ // and aslo need to change ra to 'Base+0x70' whenever we will get assamese language
|
||||||
+ //character in data
|
+ //character in data
|
||||||
+ if((script == QUnicodeTables::Bengali) && (*uc==0x09F0)){
|
+ if((script == HB_Script_Bengali) && (*uc==0x09F0)){
|
||||||
+ ra = script_base + 0x70;
|
+ ra = script_base + 0x70;
|
||||||
+ }
|
+ }
|
||||||
+
|
+
|
4
qt.spec
4
qt.spec
@ -34,7 +34,7 @@ Source5: qconfig-multilib.h
|
|||||||
|
|
||||||
# multilib hacks
|
# multilib hacks
|
||||||
Patch2: qt-x11-opensource-src-4.2.2-multilib.patch
|
Patch2: qt-x11-opensource-src-4.2.2-multilib.patch
|
||||||
Patch5: qt-x11-opensource-src-4.3.4-as_IN-437440.patch
|
Patch5: qt-all-opensource-src-4.4.0-rc1-as_IN-437440.patch
|
||||||
|
|
||||||
## qt-copy patches
|
## qt-copy patches
|
||||||
#define qt_copy 20080404
|
#define qt_copy 20080404
|
||||||
@ -787,7 +787,7 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
|
|||||||
%changelog
|
%changelog
|
||||||
* Tue Apr 08 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.4.0-0.4.rc1
|
* Tue Apr 08 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.4.0-0.4.rc1
|
||||||
- updated patch for #437440 ([as-IN] Consonant combination issue) by Pravin Satpute
|
- updated patch for #437440 ([as-IN] Consonant combination issue) by Pravin Satpute
|
||||||
- actually enable the patch
|
- port the patch to Qt 4.4 (the code moved to harfbuzz) and reenable it
|
||||||
|
|
||||||
* Fri Apr 04 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.0-0.3.rc1
|
* Fri Apr 04 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.0-0.3.rc1
|
||||||
- qt-4.4.0-rc1
|
- qt-4.4.0-rc1
|
||||||
|
Loading…
Reference in New Issue
Block a user