This commit is contained in:
Rex Dieter 2011-09-02 08:30:58 -05:00
parent 979fb02c8a
commit b38ecb620b
4 changed files with 21 additions and 31 deletions

20
.gitignore vendored
View File

@ -1,10 +1,12 @@
hi128-app-qt4-logo.png
hi48-app-qt4-logo.png
gstreamer-logo.svg
hi128-phonon-gstreamer.png
hi16-phonon-gstreamer.png
hi22-phonon-gstreamer.png
hi32-phonon-gstreamer.png
hi48-phonon-gstreamer.png
hi64-phonon-gstreamer.png
/hi128-app-qt4-logo.png
/hi48-app-qt4-logo.png
/gstreamer-logo.svg
/hi128-phonon-gstreamer.png
/hi16-phonon-gstreamer.png
/hi22-phonon-gstreamer.png
/hi32-phonon-gstreamer.png
/hi48-phonon-gstreamer.png
/hi64-phonon-gstreamer.png
/qt-everywhere-opensource-src-4.7.3.tar.gz
/qt-everywhere-opensource-src-4.7.4.tar.gz
/qt-everywhere-opensource-src-4.8.0-beta1.tar.gz

View File

@ -1,13 +0,0 @@
diff --git a/src/gui/itemviews/qtreeview.cpp b/src/gui/itemviews/qtreeview.cpp
index 406e1f6..4691b17 100644
--- a/src/gui/itemviews/qtreeview.cpp
+++ b/src/gui/itemviews/qtreeview.cpp
@@ -3223,7 +3223,7 @@ int QTreeViewPrivate::itemHeight(int item) const
return defaultItemHeight;
if (viewItems.isEmpty())
return 0;
- const QModelIndex &index = viewItems.at(item).index;
+ QModelIndex index = viewItems.at(item).index;
int height = viewItems.at(item).height;
if (height <= 0 && index.isValid()) {
height = q_func()->indexRowSizeHint(index);

17
qt.spec
View File

@ -17,8 +17,8 @@
Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.7.3
Release: 9%{?dist}
Version: 4.7.4
Release: 1%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
@ -88,9 +88,6 @@ Patch63: qt-everywhere-opensource-src-4.7.0-bpp24.patch
# Fails to create debug build of Qt projects on mingw (rhbz#653674)
Patch64: qt-everywhere-opensource-src-4.7.1-QTBUG-14467.patch
# fix QTreeView crash triggered by KPackageKit (patch by David Faure)
Patch65: qt-everywhere-opensource-src-4.7.1-qtreeview-kpackagekit-crash.patch
# upstream patches
# adds debug support to webkit/JavaScriptCore
# UPSTREAM ME
@ -530,11 +527,12 @@ Qt libraries used for drawing widgets and OpenGL items.
%patch62 -p1 -b .indic-rendering-bz636399
%patch63 -p1 -b .bpp24
%patch64 -p1 -b .QTBUG-14467
%patch65 -p1 -b .qtreeview-kpackagekit-crash
# upstream patches
## upstream patches
%patch105 -p1 -b .webkit_debug_javascriptcore
%patch106 -p1 -b .QNetworkConfigurationManager-null-pointer
# no longer applies, I *think* it's no longer needed, though
# should be reviewed by another set of eyes -- rex
#patch106 -p1 -b .QNetworkConfigurationManager-null-pointer
%patch107 -p1 -b .QTBUG-19947-fontconfig-2
@ -1276,6 +1274,9 @@ fi
%changelog
* Thu Sep 01 2011 Rex Dieter <rdieter@fedoraproject.org> 1:4.7.4-1
- 4.7.4
* Sat Aug 27 2011 Than Ngo <than@redhat.com> - 1:4.7.3-9
- drop unused rhel conditional

View File

@ -7,4 +7,4 @@ d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
12db12c009b722a6dc141f78feb7e330 hi32-phonon-gstreamer.png
86c34a1b81d44980b1381f94ed6b7a23 hi48-phonon-gstreamer.png
153505c71ec021b0a3bd4b74f2492e93 hi64-phonon-gstreamer.png
49b96eefb1224cc529af6fe5608654fe qt-everywhere-opensource-src-4.7.3.tar.gz
ddf7d83f912cf1283aa066368464fa22 qt-everywhere-opensource-src-4.7.4.tar.gz