switch to upstream moc/boost patch
This commit is contained in:
parent
809cb90014
commit
b21e1f5472
33
0013-Fix-moc-from-choking-on-boost-headers.patch
Normal file
33
0013-Fix-moc-from-choking-on-boost-headers.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
From a6305580b27f0bf1d268b5a3531c8332a57c3864 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Kofler <Kevin@tigcc.ticalc.org>
|
||||||
|
Date: Sun, 25 Nov 2012 16:20:00 +0000
|
||||||
|
Subject: [PATCH 13/90] Fix moc from choking on boost headers.
|
||||||
|
|
||||||
|
Fixes several build failures with boost >= 1.48, for example
|
||||||
|
the kdepim build: https://bugs.kde.org/show_bug.cgi?id=304111
|
||||||
|
|
||||||
|
Task-number: QTBUG-22829
|
||||||
|
Change-Id: Ic37a5290955fbfd18894a228cc9d57615edddea6
|
||||||
|
Reviewed-by: Olivier Goffart <ogoffart@woboq.com>
|
||||||
|
---
|
||||||
|
src/tools/moc/main.cpp | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp
|
||||||
|
index 33344fc..f558a5e 100644
|
||||||
|
--- a/src/tools/moc/main.cpp
|
||||||
|
+++ b/src/tools/moc/main.cpp
|
||||||
|
@@ -187,6 +187,10 @@ int runMoc(int _argc, char **_argv)
|
||||||
|
Moc moc;
|
||||||
|
pp.macros["Q_MOC_RUN"];
|
||||||
|
pp.macros["__cplusplus"];
|
||||||
|
+
|
||||||
|
+ // Workaround a bug while parsing the boost/type_traits/has_operator.hpp header. See QTBUG-22829
|
||||||
|
+ pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"];
|
||||||
|
+
|
||||||
|
QByteArray filename;
|
||||||
|
QByteArray output;
|
||||||
|
FILE *in = 0;
|
||||||
|
--
|
||||||
|
1.8.1
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -ur qt-everywhere-opensource-src-4.8.0/src/tools/moc/main.cpp qt-everywhere-opensource-src-4.8.0-moc-boost148/src/tools/moc/main.cpp
|
|
||||||
--- qt-everywhere-opensource-src-4.8.0/src/tools/moc/main.cpp 2011-10-04 05:44:32.000000000 +0200
|
|
||||||
+++ qt-everywhere-opensource-src-4.8.0-moc-boost148/src/tools/moc/main.cpp 2011-12-04 00:11:25.000000000 +0100
|
|
||||||
@@ -187,6 +187,7 @@
|
|
||||||
Moc moc;
|
|
||||||
pp.macros["Q_MOC_RUN"];
|
|
||||||
pp.macros["__cplusplus"];
|
|
||||||
+ pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"]; // rh#756395
|
|
||||||
QByteArray filename;
|
|
||||||
QByteArray output;
|
|
||||||
FILE *in = 0;
|
|
8
qt.spec
8
qt.spec
@ -48,9 +48,6 @@ Patch15: qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
|
|||||||
# workaround for gdal/grass crashers wrt glib_eventloop null deref's
|
# workaround for gdal/grass crashers wrt glib_eventloop null deref's
|
||||||
Patch23: qt-everywhere-opensource-src-4.6.3-glib_eventloop_nullcheck.patch
|
Patch23: qt-everywhere-opensource-src-4.6.3-glib_eventloop_nullcheck.patch
|
||||||
|
|
||||||
# workaround for a MOC issue with Boost 1.48 headers (#756395)
|
|
||||||
Patch24: qt-everywhere-opensource-src-4.8.0-rc1-moc-boost148.patch
|
|
||||||
|
|
||||||
# hack out largely useless (to users) warnings about qdbusconnection
|
# hack out largely useless (to users) warnings about qdbusconnection
|
||||||
# (often in kde apps), keep an eye on https://git.reviewboard.kde.org/r/103699/
|
# (often in kde apps), keep an eye on https://git.reviewboard.kde.org/r/103699/
|
||||||
Patch25: qt-everywhere-opensource-src-4.8.3-qdbusconnection_no_debug.patch
|
Patch25: qt-everywhere-opensource-src-4.8.3-qdbusconnection_no_debug.patch
|
||||||
@ -126,6 +123,8 @@ Patch101: 0054-Fix-binary-incompatibility-between-openssl-versions.patch
|
|||||||
# http://bugzilla.redhat.com/702493
|
# http://bugzilla.redhat.com/702493
|
||||||
# https://bugreports.qt-project.org/browse/QTBUG-5545
|
# https://bugreports.qt-project.org/browse/QTBUG-5545
|
||||||
Patch102: qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
|
Patch102: qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
|
||||||
|
# workaround for a MOC issue with Boost 1.48 headers (#756395)
|
||||||
|
Patch103: 0013-Fix-moc-from-choking-on-boost-headers.patch
|
||||||
|
|
||||||
# security patches
|
# security patches
|
||||||
# CVE-2011-3922 qt: Stack-based buffer overflow in embedded harfbuzz code
|
# CVE-2011-3922 qt: Stack-based buffer overflow in embedded harfbuzz code
|
||||||
@ -445,7 +444,6 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
|||||||
%patch4 -p1 -b .uic_multilib
|
%patch4 -p1 -b .uic_multilib
|
||||||
%patch15 -p1 -b .enable_ft_lcdfilter
|
%patch15 -p1 -b .enable_ft_lcdfilter
|
||||||
%patch23 -p1 -b .glib_eventloop_nullcheck
|
%patch23 -p1 -b .glib_eventloop_nullcheck
|
||||||
%patch24 -p1 -b .moc-boost148
|
|
||||||
%patch25 -p1 -b .qdbusconnection_no_debug
|
%patch25 -p1 -b .qdbusconnection_no_debug
|
||||||
%patch26 -p1 -b .linguist_qtmake-qt4
|
%patch26 -p1 -b .linguist_qtmake-qt4
|
||||||
%patch27 -p1 -b .qt3support_debuginfo
|
%patch27 -p1 -b .qt3support_debuginfo
|
||||||
@ -472,6 +470,8 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
|||||||
%patch100 -p1 -b .QTgaHandler
|
%patch100 -p1 -b .QTgaHandler
|
||||||
%patch101 -p1 -b .0054
|
%patch101 -p1 -b .0054
|
||||||
%patch102 -p1 -b .qgtkstyle_disable_gtk_theme_check
|
%patch102 -p1 -b .qgtkstyle_disable_gtk_theme_check
|
||||||
|
%patch103 -p1 -b .moc-boost148
|
||||||
|
|
||||||
|
|
||||||
# security fixes
|
# security fixes
|
||||||
%patch200 -p1 -b .CVE-2011-3922
|
%patch200 -p1 -b .CVE-2011-3922
|
||||||
|
Loading…
Reference in New Issue
Block a user