- backport fix for QTBUG-9354 which breaks kdeutils build

This commit is contained in:
Kevin Kofler 2010-04-03 22:31:36 +00:00
parent ff1e9122ca
commit a6338f25bd
2 changed files with 37 additions and 1 deletions

View File

@ -0,0 +1,13 @@
diff -ur qt-everywhere-opensource-src-4.7.0-tp/src/corelib/kernel/qmetaobject_p.h qt-everywhere-opensource-src-4.7.0-tp-QTBUG-9354/src/corelib/kernel/qmetaobject_p.h
--- qt-everywhere-opensource-src-4.7.0-tp/src/corelib/kernel/qmetaobject_p.h 2010-03-10 14:56:51.000000000 +0100
+++ qt-everywhere-opensource-src-4.7.0-tp-QTBUG-9354/src/corelib/kernel/qmetaobject_p.h 2010-04-04 00:14:37.000000000 +0200
@@ -287,7 +287,8 @@
}
// cv qualifers can appear after the type as well
- if (t != e && (e - t >= 5 && strncmp("const", t, 5) == 0)) {
+ if (!is_ident_char(c) && t != e && (e - t >= 5 && strncmp("const", t, 5) == 0)
+ && (e - t == 5 || !is_ident_char(t[5]))) {
t += 5;
while (t != e && is_space(*t))
++t;

25
qt.spec
View File

@ -15,7 +15,7 @@ Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.7.0
Release: 0.5.%{pre}%{?dist}
Release: 0.6.%{pre}%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: LGPLv2 with exceptions or GPLv3 with exceptions
@ -65,6 +65,23 @@ Patch56: qt-everywhere-opensource-src-4.6.2-sparc64-webkit-fix.patch
# security patches
# upstream patches
# http://qt.gitorious.org/qt/qt/commit/ff870dbf9106f2bbb2cf64f5aa35fc5917e5f4f2
# http://bugreports.qt.nokia.com/browse/QTBUG-9354
#
# From ff870dbf9106f2bbb2cf64f5aa35fc5917e5f4f2 Mon Sep 17 00:00:00 2001
# From: Olivier Goffart <ogoffart@trolltech.com>
# Date: Fri, 26 Mar 2010 11:26:42 +0100
# Subject: [PATCH] QMetaObject::normalizeType: Fix parsing of type which contains "const" in names
#
# Regression since b881d8fb99972f1bd04ab4c84843cc8d43ddbeed
#
# Task-number: QTBUG-9354
# Reviewed-by: Kent Hansen
Patch100: qt-everywhere-opensource-src-4.7.0-tp-QTBUG-9354.patch
# kde-qt git patches
Patch201: 0001-This-patch-uses-object-name-as-a-fallback-for-window.patch
Patch202: 0002-This-patch-makes-override-redirect-windows-popup-men.patch
@ -402,6 +419,9 @@ Qt libraries used for drawing widgets and OpenGL items.
# security fixes
# upstream patches
%patch100 -p1 -b .QTBUG-9354
# kde-qt branch
%if 0%{?kde_qt}
%patch201 -p1 -b .kde-qt-0001
@ -1018,6 +1038,9 @@ fi
%changelog
* Sat Apr 03 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.7.0-0.6.tp
- backport fix for QTBUG-9354 which breaks kdeutils build
* Fri Apr 02 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-0.5.tp
- Associate text/vnd.trolltech.linguist with linguist (#579082)