parent
7f8efd552b
commit
a5dac8ed81
18
qt-x11-free-3.3.5-uic.patch
Normal file
18
qt-x11-free-3.3.5-uic.patch
Normal file
@ -0,0 +1,18 @@
|
||||
Index: tools/designer/uic/form.cpp
|
||||
===================================================================
|
||||
--- qt/tools/designer/uic/form.cpp (revision 460038)
|
||||
+++ qt/tools/designer/uic/form.cpp (working copy)
|
||||
@@ -731,6 +731,13 @@
|
||||
while ( !n2.isNull() ) {
|
||||
if ( n2.tagName() == "includehint" ) {
|
||||
QString file = n2.firstChild().toText().data();
|
||||
+ int colons = file.find("::");
|
||||
+
|
||||
+ if (colons != -1)
|
||||
+ {
|
||||
+ file = file.right(file.length() - colons - 2);
|
||||
+ }
|
||||
+
|
||||
localIncludes += file;
|
||||
}
|
||||
n2 = n2.nextSibling().toElement();
|
6
qt.spec
6
qt.spec
@ -85,7 +85,7 @@
|
||||
Summary: The shared library for the Qt GUI toolkit.
|
||||
Name: qt
|
||||
Version: %{ver}
|
||||
Release: 1
|
||||
Release: 2
|
||||
Epoch: 1
|
||||
License: GPL/QPL
|
||||
Group: System Environment/Libraries
|
||||
@ -107,6 +107,7 @@ Patch14: qt-x11-free-3.3.3-gl.patch
|
||||
Patch19: qt-3.3.3-gtkstyle.patch
|
||||
Patch20: qt-x11-free-3.3.5-gcc4-buildkey.patch
|
||||
Patch23: qt-visibility.patch
|
||||
Patch24: qt-x11-free-3.3.5-uic.patch
|
||||
|
||||
# immodule patches
|
||||
Patch50: qt-x11-immodule-unified-qt3.3.4-20041203-pre.patch
|
||||
@ -322,6 +323,8 @@ for the Qt toolkit.
|
||||
%patch23 -p1 -b .hidden_visibility
|
||||
%endif
|
||||
|
||||
%patch24 -p1 -b .uic
|
||||
|
||||
%if %{immodule}
|
||||
bunzip2 -c %{_sourcedir}/qt-x11-immodule-unified-qt3.3.4-20041203.diff.bz2 > qt-x11-immodule-unified-qt3.3.4-20041203.diff
|
||||
patch -p0 < %{_sourcedir}/qt-x11-immodule-unified-qt3.3.4-20041203-pre.patch
|
||||
@ -715,6 +718,7 @@ rm -rf %{buildroot}
|
||||
%changelog
|
||||
* Tue Sep 20 2005 Than Ngo <than@redhat.com> 1:3.3.5-2
|
||||
- German translation of the Qt Assistent #161558
|
||||
- add uic workaround
|
||||
|
||||
* Sun Sep 11 2005 Than Ngo <than@redhat.com> 1:3.3.5-1
|
||||
- update to 3.3.5
|
||||
|
Loading…
x
Reference in New Issue
Block a user