drop patches which are already included in 4.7.1
This commit is contained in:
parent
6111d96eb2
commit
9d66e67ec2
@ -1,31 +0,0 @@
|
||||
From 6da6b7099d4e0b49329793e4b90703ec3d868048 Mon Sep 17 00:00:00 2001
|
||||
From: Frank Reininghaus <frank78ac@googlemail.com>
|
||||
Date: Wed, 22 Sep 2010 10:19:59 +0200
|
||||
Subject: [PATCH] QTreeView: do not scroll to top if last item is removed
|
||||
|
||||
When the last item is the current item and is removed,
|
||||
QTreeViewPrivate::updateScrollBars() is called after QTreeViewPrivate's
|
||||
viewItems member is cleared. This commit makes sure that viewItems is
|
||||
restored by calling QTreeView::doItemsLayout() in this case, preventing
|
||||
that the scroll bar range is set to zero temporarily and the view is
|
||||
scrolled to the top unexpectedly (this was a regression in 4.7.0:
|
||||
QTBUG-13567).
|
||||
|
||||
Merge-request: 2481
|
||||
Reviewed-by: Olivier Goffart <olivier.goffart@nokia.com>
|
||||
|
||||
diff --git a/src/gui/itemviews/qtreeview.cpp b/src/gui/itemviews/qtreeview.cpp
|
||||
index b797776..40b51fe 100644
|
||||
--- a/src/gui/itemviews/qtreeview.cpp
|
||||
+++ b/src/gui/itemviews/qtreeview.cpp
|
||||
@@ -3435,6 +3435,10 @@ void QTreeViewPrivate::updateScrollBars()
|
||||
if (!viewportSize.isValid())
|
||||
viewportSize = QSize(0, 0);
|
||||
|
||||
+ if (viewItems.isEmpty()) {
|
||||
+ q->doItemsLayout();
|
||||
+ }
|
||||
+
|
||||
int itemsInViewport = 0;
|
||||
if (uniformRowHeights) {
|
||||
if (defaultItemHeight <= 0)
|
@ -1,34 +0,0 @@
|
||||
From 9e9a7bc29319d52c3e563bc2c5282cb7e6890eba Mon Sep 17 00:00:00 2001
|
||||
From: Denis Dzyubenko <denis.dzyubenko@nokia.com>
|
||||
Date: Wed, 29 Sep 2010 14:02:10 +0200
|
||||
Subject: [PATCH] Fixes cursor shape when widget becomes native on X11.
|
||||
|
||||
When a native window handle is created for a widget that has override
|
||||
cursor set, we should reset the cursor on the parent and set the cursor
|
||||
on the new window handle.
|
||||
|
||||
Task-number: QTBUG-6185
|
||||
Reviewed-by: Olivier Goffart
|
||||
---
|
||||
src/gui/kernel/qwidget_x11.cpp | 4 +++-
|
||||
1 files changed, 3 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/gui/kernel/qwidget_x11.cpp b/src/gui/kernel/qwidget_x11.cpp
|
||||
index e01489f..8d80e10 100644
|
||||
--- a/src/gui/kernel/qwidget_x11.cpp
|
||||
+++ b/src/gui/kernel/qwidget_x11.cpp
|
||||
@@ -889,8 +889,10 @@ void QWidgetPrivate::create_sys(WId window, bool initializeWindow, bool destroyO
|
||||
q->setWindowOpacity(maybeTopData()->opacity/255.);
|
||||
|
||||
}
|
||||
- } else if (q->testAttribute(Qt::WA_SetCursor) && q->internalWinId()) {
|
||||
+ } else if (q->internalWinId()) {
|
||||
qt_x11_enforce_cursor(q);
|
||||
+ if (QWidget *p = q->parentWidget()) // reset the cursor on the native parent
|
||||
+ qt_x11_enforce_cursor(p);
|
||||
}
|
||||
|
||||
if (extra && !extra->mask.isEmpty() && q->internalWinId())
|
||||
--
|
||||
1.6.1
|
||||
|
6
qt.spec
6
qt.spec
@ -83,10 +83,6 @@ Patch62: qt-4.6.3-indic-rendering-bz636399.patch
|
||||
Patch63: qt-everywhere-opensource-src-4.7.0-bpp24.patch
|
||||
|
||||
## upstream patches
|
||||
Patch100: qt-everywhere-opensource-src-4.7.0-QTBUG-13567-QTreeView.patch
|
||||
# http://bugreports.qt.nokia.com/browse/QTBUG-6185
|
||||
# http://qt.gitorious.org/qt/staging/commit/9e9a7bc29319d52c3e563bc2c5282cb7e6890eba
|
||||
Patch101: qt-everywhere-opensource-src-4.7.0-QTBUG-6185.patch
|
||||
|
||||
# kde-qt git patches
|
||||
Patch202: 0002-This-patch-makes-override-redirect-windows-popup-men.patch
|
||||
@ -442,8 +438,6 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
%patch63 -p1 -b .bpp24
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .QTBUG-13567-QTreeView
|
||||
%patch101 -p1 -b .QTBUG-6185
|
||||
|
||||
# kde-qt branch
|
||||
%if 0%{?kde_qt}
|
||||
|
Loading…
Reference in New Issue
Block a user