4.7.0
This commit is contained in:
parent
af20ebbd40
commit
9978f4fd3f
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@ hi48-phonon-gstreamer.png
|
|||||||
hi64-phonon-gstreamer.png
|
hi64-phonon-gstreamer.png
|
||||||
qt-everywhere-opensource-src-4.7.0-beta2.tar.gz
|
qt-everywhere-opensource-src-4.7.0-beta2.tar.gz
|
||||||
/qt-everywhere-opensource-src-4.7.0-rc1.tar.gz
|
/qt-everywhere-opensource-src-4.7.0-rc1.tar.gz
|
||||||
|
/qt-everywhere-opensource-src-4.7.0.tar.gz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/gui/painting/qpaintengine_x11.cpp b/src/gui/painting/qpaintengine_x11.cpp
|
|
||||||
index e521e01..d430f77 100644
|
|
||||||
--- a/src/gui/painting/qpaintengine_x11.cpp
|
|
||||||
+++ b/src/gui/painting/qpaintengine_x11.cpp
|
|
||||||
@@ -1914,6 +1914,8 @@ void QX11PaintEngine::drawPixmap(const QRectF &r, const QPixmap &px, const QRect
|
|
||||||
int sh = qRound(sr.height());
|
|
||||||
|
|
||||||
QPixmap pixmap = qt_toX11Pixmap(px);
|
|
||||||
+ if (pixmap.isNull())
|
|
||||||
+ return;
|
|
||||||
|
|
||||||
if ((d->xinfo && d->xinfo->screen() != pixmap.x11Info().screen())
|
|
||||||
|| (pixmap.x11Info().screen() != DefaultScreen(X11->display))) {
|
|
14
qt.spec
14
qt.spec
@ -11,19 +11,17 @@
|
|||||||
# enable kde-qt integration/patches
|
# enable kde-qt integration/patches
|
||||||
#define kde_qt 1
|
#define kde_qt 1
|
||||||
|
|
||||||
%define pre rc1
|
|
||||||
|
|
||||||
Summary: Qt toolkit
|
Summary: Qt toolkit
|
||||||
Name: qt
|
Name: qt
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.7.0
|
Version: 4.7.0
|
||||||
Release: 0.31.%{pre}%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Url: http://www.qtsoftware.com/
|
Url: http://www.qtsoftware.com/
|
||||||
Source0: http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-%{version}%{?pre:-%{pre}}.tar.gz
|
Source0: http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-%{version}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: qt4 < %{version}-%{release}
|
Obsoletes: qt4 < %{version}-%{release}
|
||||||
Provides: qt4 = %{version}-%{release}
|
Provides: qt4 = %{version}-%{release}
|
||||||
@ -65,8 +63,6 @@ Patch58: qt-everywhere-opensource-src-4.7.0-beta1-qtwebkit_pluginpath.patch
|
|||||||
# security patches
|
# security patches
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
# http://bugreports.qt.nokia.com/browse/QTBUG-12826
|
|
||||||
Patch100: qt-everywhere-opensource-src-4.7.0-rc1-QTBUG-12826.patch
|
|
||||||
|
|
||||||
# kde-qt git patches
|
# kde-qt git patches
|
||||||
Patch201: 0001-This-patch-uses-object-name-as-a-fallback-for-window.patch
|
Patch201: 0001-This-patch-uses-object-name-as-a-fallback-for-window.patch
|
||||||
@ -406,7 +402,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n qt-everywhere-opensource-src-%{version}%{?pre:-%{pre}}
|
%setup -q -n qt-everywhere-opensource-src-%{version}
|
||||||
|
|
||||||
%patch15 -p1 -b .enable_ft_lcdfilter
|
%patch15 -p1 -b .enable_ft_lcdfilter
|
||||||
#patch16 -p1 -b .kde4_plugins
|
#patch16 -p1 -b .kde4_plugins
|
||||||
@ -423,7 +419,6 @@ Qt libraries used for drawing widgets and OpenGL items.
|
|||||||
# security fixes
|
# security fixes
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch100 -p1 -b .QTBUG-12826
|
|
||||||
|
|
||||||
# kde-qt branch
|
# kde-qt branch
|
||||||
%if 0%{?kde_qt}
|
%if 0%{?kde_qt}
|
||||||
@ -1092,6 +1087,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 21 2010 Than Ngo <than@redhat.com> - 4.7.0-1
|
||||||
|
- 4.7.0
|
||||||
|
|
||||||
* Thu Sep 09 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-0.31.rc1
|
* Thu Sep 09 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-0.31.rc1
|
||||||
- -webkit-devel: add missing %%defattr
|
- -webkit-devel: add missing %%defattr
|
||||||
- -webkit: move qml/webkit bits here
|
- -webkit: move qml/webkit bits here
|
||||||
|
2
sources
2
sources
@ -7,4 +7,4 @@ d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
|
|||||||
12db12c009b722a6dc141f78feb7e330 hi32-phonon-gstreamer.png
|
12db12c009b722a6dc141f78feb7e330 hi32-phonon-gstreamer.png
|
||||||
86c34a1b81d44980b1381f94ed6b7a23 hi48-phonon-gstreamer.png
|
86c34a1b81d44980b1381f94ed6b7a23 hi48-phonon-gstreamer.png
|
||||||
153505c71ec021b0a3bd4b74f2492e93 hi64-phonon-gstreamer.png
|
153505c71ec021b0a3bd4b74f2492e93 hi64-phonon-gstreamer.png
|
||||||
6ba503cea2f91c38b34594ed68c15d9a qt-everywhere-opensource-src-4.7.0-rc1.tar.gz
|
3a2f25b9b115037277f4fb759194a7a5 qt-everywhere-opensource-src-4.7.0.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user