fix build with ICU >= 59, from OpenSUSE (Fabian Vogt)
This commit is contained in:
parent
16cf98a681
commit
973f90b5f8
28
qt-everywhere-opensource-src-4.8.7-icu59.patch
Normal file
28
qt-everywhere-opensource-src-4.8.7-icu59.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From: Fabian Vogt <fabian@ritter-vogt.de>
|
||||||
|
Subject: Fix build with ICU >= 59
|
||||||
|
|
||||||
|
ICU >= 59 requires C++11 for its header files.
|
||||||
|
Qt can't be compiled with -std=c++11 as a whole, so only enable
|
||||||
|
it for qlocale_icu.cpp.
|
||||||
|
|
||||||
|
Index: qt-everywhere-opensource-src-4.8.7/src/corelib/tools/tools.pri
|
||||||
|
===================================================================
|
||||||
|
--- qt-everywhere-opensource-src-4.8.7.orig/src/corelib/tools/tools.pri
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.7/src/corelib/tools/tools.pri
|
||||||
|
@@ -102,7 +102,15 @@ contains(QT_CONFIG, zlib):include($$PWD/
|
||||||
|
else:include($$PWD/../../3rdparty/zlib_dependency.pri)
|
||||||
|
|
||||||
|
contains(QT_CONFIG,icu) {
|
||||||
|
- SOURCES += tools/qlocale_icu.cpp
|
||||||
|
+ cpp11.name = cpp11
|
||||||
|
+ cpp11.input = SOURCES_CPP11
|
||||||
|
+ cpp11.dependency_type = TYPE_C
|
||||||
|
+ cpp11.variable_out = OBJECTS
|
||||||
|
+ cpp11.output = ${QMAKE_VAR_OBJECTS_DIR}${QMAKE_FILE_IN_BASE}$${first(QMAKE_EXT_OBJ)}
|
||||||
|
+ cpp11.commands = $${QMAKE_CXX} $(CXXFLAGS) -std=c++11 $(INCPATH) -c ${QMAKE_FILE_IN} -o ${QMAKE_FILE_OUT}
|
||||||
|
+ QMAKE_EXTRA_COMPILERS += cpp11
|
||||||
|
+
|
||||||
|
+ SOURCES_CPP11 += tools/qlocale_icu.cpp
|
||||||
|
DEFINES += QT_USE_ICU
|
||||||
|
}
|
||||||
|
|
6
qt.spec
6
qt.spec
@ -190,6 +190,10 @@ Patch93: qt-everywhere-opensource-src-4.8.7-alsa-1.1.patch
|
|||||||
# https://anonscm.debian.org/cgit/pkg-kde/qt/qt4-x11.git/tree/debian/patches/openssl_1.1.patch?h=experimental
|
# https://anonscm.debian.org/cgit/pkg-kde/qt/qt4-x11.git/tree/debian/patches/openssl_1.1.patch?h=experimental
|
||||||
Patch94: qt-everywhere-opensource-src-4.8.7-openssl-1.1.patch
|
Patch94: qt-everywhere-opensource-src-4.8.7-openssl-1.1.patch
|
||||||
|
|
||||||
|
# fix build with ICU >= 59, from OpenSUSE (Fabian Vogt)
|
||||||
|
# https://build.opensuse.org/package/view_file/KDE:Qt/libqt4/fix-build-icu59.patch?expand=1
|
||||||
|
Patch95: qt-everywhere-opensource-src-4.8.7-icu59.patch
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
# backported from Qt5 (essentially)
|
# backported from Qt5 (essentially)
|
||||||
# http://bugzilla.redhat.com/702493
|
# http://bugzilla.redhat.com/702493
|
||||||
@ -614,6 +618,7 @@ rm -rf src/3rdparty/clucene
|
|||||||
%patch92 -p1 -b .gcc6
|
%patch92 -p1 -b .gcc6
|
||||||
%patch93 -p1 -b .alsa1.1
|
%patch93 -p1 -b .alsa1.1
|
||||||
%patch94 -p1 -b .openssl1.1
|
%patch94 -p1 -b .openssl1.1
|
||||||
|
%patch95 -p1 -b .icu59
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch102 -p1 -b .qgtkstyle_disable_gtk_theme_check
|
%patch102 -p1 -b .qgtkstyle_disable_gtk_theme_check
|
||||||
@ -1400,6 +1405,7 @@ fi
|
|||||||
%changelog
|
%changelog
|
||||||
* Fri Jan 05 2018 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:4.8.7-34
|
* Fri Jan 05 2018 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:4.8.7-34
|
||||||
- build with OpenSSL 1.1.x, from Debian (Gert Wollny, Dmitry Eremin-Solenikov)
|
- build with OpenSSL 1.1.x, from Debian (Gert Wollny, Dmitry Eremin-Solenikov)
|
||||||
|
- fix build with ICU >= 59, from OpenSUSE (Fabian Vogt)
|
||||||
- update URL to use HTTPS
|
- update URL to use HTTPS
|
||||||
|
|
||||||
* Wed Oct 25 2017 Troy Dawson <tdawson@redhat.com> - 1:4.8.7-33
|
* Wed Oct 25 2017 Troy Dawson <tdawson@redhat.com> - 1:4.8.7-33
|
||||||
|
Loading…
Reference in New Issue
Block a user