workaround for keyboard input action in KHotKeys
This commit is contained in:
parent
5b4bb508f0
commit
96d70d775c
21
0056-khotkeys_input_84434.patch
Normal file
21
0056-khotkeys_input_84434.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
qt-bugs@ issue : 58251
|
||||||
|
bugs.kde.org number : 84434
|
||||||
|
applied: no
|
||||||
|
author: Lubos Lunak <l.lunak@kde.org>
|
||||||
|
|
||||||
|
Fixes keyboard input action in KHotKeys (see bug #84434).
|
||||||
|
|
||||||
|
--- src/kernel/qapplication_x11.cpp.sav 2004-10-07 15:38:05.000000000 +0200
|
||||||
|
+++ src/kernel/qapplication_x11.cpp 2004-10-12 11:46:32.513137808 +0200
|
||||||
|
@@ -5294,8 +5294,10 @@ static Bool qt_keypress_scanner(Display
|
||||||
|
qt_auto_repeat_data *d = (qt_auto_repeat_data *) arg;
|
||||||
|
if (d->error ||
|
||||||
|
event->xkey.window != d->window ||
|
||||||
|
- event->xkey.keycode != d->keycode)
|
||||||
|
+ event->xkey.keycode != d->keycode) {
|
||||||
|
+ d->error = TRUE;
|
||||||
|
return FALSE;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
if (event->type == XKeyPress) {
|
||||||
|
d->error = (! d->release || event->xkey.time - d->timestamp > 10);
|
7
qt.spec
7
qt.spec
@ -85,7 +85,7 @@
|
|||||||
Summary: The shared library for the Qt GUI toolkit.
|
Summary: The shared library for the Qt GUI toolkit.
|
||||||
Name: qt
|
Name: qt
|
||||||
Version: %{ver}
|
Version: %{ver}
|
||||||
Release: 9
|
Release: 10
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL/QPL
|
License: GPL/QPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -119,6 +119,7 @@ Patch100: 0038-dragobject-dont-prefer-unknown.patch
|
|||||||
Patch101: 0047-fix-kmenu-width.diff
|
Patch101: 0047-fix-kmenu-width.diff
|
||||||
Patch102: 0048-qclipboard_hack_80072.patch
|
Patch102: 0048-qclipboard_hack_80072.patch
|
||||||
Patch103: 0051-qtoolbar_77047.patch
|
Patch103: 0051-qtoolbar_77047.patch
|
||||||
|
Patch104: 0056-khotkeys_input_84434.patch
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
Patch200: qt-x11-free-3.3.4-assistant_de.patch
|
Patch200: qt-x11-free-3.3.4-assistant_de.patch
|
||||||
@ -351,6 +352,7 @@ for the Qt toolkit.
|
|||||||
%patch101 -p0 -b .0047-fix-kmenu-width
|
%patch101 -p0 -b .0047-fix-kmenu-width
|
||||||
%patch102 -p0 -b .0048-qclipboard_hack_80072
|
%patch102 -p0 -b .0048-qclipboard_hack_80072
|
||||||
%patch103 -p0 -b .0051-qtoolbar_77047
|
%patch103 -p0 -b .0051-qtoolbar_77047
|
||||||
|
%patch104 -p0 -b .0056-khotkeys_input_84434
|
||||||
|
|
||||||
%patch200 -p1 -b .assistant-translation
|
%patch200 -p1 -b .assistant-translation
|
||||||
%patch201 -p1 -b .fullscreen
|
%patch201 -p1 -b .fullscreen
|
||||||
@ -732,6 +734,9 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Nov 13 2005 Than Ngo <than@redhat.com> 1:3.3.5-10
|
||||||
|
- workaround for keyboard input action in KHotKeys
|
||||||
|
|
||||||
* Tue Nov 08 2005 Than Ngo <than@redhat.com> 1:3.3.5-9
|
* Tue Nov 08 2005 Than Ngo <than@redhat.com> 1:3.3.5-9
|
||||||
- fix for modular X
|
- fix for modular X
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user