bz#660287, using QTextBrowser in assistant to drop qtwebkit dependency

This commit is contained in:
Than Ngo 2010-12-07 13:22:43 +01:00
parent 8244061b3d
commit 8be6ad84de
2 changed files with 56 additions and 1 deletions

View File

@ -0,0 +1,43 @@
diff -up qt-everywhere-opensource-src-4.7.1/tools/assistant/tools/assistant/assistant.pro.webkit qt-everywhere-opensource-src-4.7.1/tools/assistant/tools/assistant/assistant.pro
--- qt-everywhere-opensource-src-4.7.1/tools/assistant/tools/assistant/assistant.pro.webkit 2010-11-06 02:55:11.000000000 +0100
+++ qt-everywhere-opensource-src-4.7.1/tools/assistant/tools/assistant/assistant.pro 2010-12-06 18:39:53.667993686 +0100
@@ -2,7 +2,7 @@ include(../../../shared/fontpanel/fontpa
TEMPLATE = app
LANGUAGE = C++
TARGET = assistant
-contains(QT_CONFIG, webkit):QT += webkit
+DEFINES += QT_NO_WEBKIT
CONFIG += qt \
warn_on \
help
@@ -40,12 +40,9 @@ HEADERS += aboutdialog.h \
topicchooser.h \
tracer.h \
xbelsupport.h \
- ../shared/collectionconfiguration.h
-contains(QT_CONFIG, webkit) {
- HEADERS += helpviewer_qwv.h
-} else {
- HEADERS += helpviewer_qtb.h
- }
+ ../shared/collectionconfiguration.h \
+ helpviewer_qtb.h
+
win32:HEADERS += remotecontrol_win.h
SOURCES += aboutdialog.cpp \
@@ -72,12 +69,8 @@ SOURCES += aboutdialog.cpp \
searchwidget.cpp \
topicchooser.cpp \
xbelsupport.cpp \
- ../shared/collectionconfiguration.cpp
- contains(QT_CONFIG, webkit) {
- SOURCES += helpviewer_qwv.cpp
-} else {
- SOURCES += helpviewer_qtb.cpp
-}
+ ../shared/collectionconfiguration.cpp \
+ helpviewer_qtb.cpp
FORMS += bookmarkdialog.ui \
bookmarkmanagerwidget.ui \

14
qt.spec
View File

@ -18,7 +18,7 @@ Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.7.1
Release: 3%{?dist}
Release: 4%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
@ -56,6 +56,9 @@ Patch19: qt-everywhere-opensource-src-4.7.0-beta2-phonon_servicesfile.patch
# workaround for gdal/grass crashers wrt glib_eventloop null deref's
Patch23: qt-everywhere-opensource-src-4.6.3-glib_eventloop_nullcheck.patch
# remove depenency of webkit in assistant
Patch24: qt-everywhere-opensource-src-4.7.1-webkit.patch
## upstreamable bits
# fix invalid inline assembly in qatomic_{i386,x86_64}.h (de)ref implementations
Patch53: qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
@ -429,6 +432,7 @@ Qt libraries used for drawing widgets and OpenGL items.
#patch16 -p1 -b .kde4_plugins
%patch19 -p1 -b .phonon_servicesfile
%patch23 -p1 -b .glib_eventloop_nullcheck
%patch24 -p1 -b .webkit
## TODO: still worth carrying? if so, upstream it.
%patch53 -p1 -b .qatomic-inline-asm
## TODO: upstream me
@ -1053,6 +1057,7 @@ fi
%defattr(-,root,root,-)
%{_qt4_libdir}/libQtWebKit.so.4*
%{_qt4_importdir}/QtWebKit/
%{_qt4_plugindir}/designer/libqwebview.so
%files webkit-devel
%defattr(-,root,root,-)
@ -1090,6 +1095,9 @@ fi
%{_qt4_plugindir}/*
%exclude %{_qt4_plugindir}/crypto
%exclude %{_qt4_plugindir}/sqldrivers
%if 0%{?webkit:1}
%exclude %{_qt4_plugindir}/designer/libqwebview.so
%endif
#if "%{?phonon_backend}" == "-phonon-backend"
%if 0%{?phonon_backend_packaged}
%exclude %{_qt4_plugindir}/phonon_backend/*_gstreamer.so
@ -1109,6 +1117,10 @@ fi
%changelog
* Mon Dec 06 2010 Than Ngo <than@redhat.com> 4.7.1-4
- bz#660287, using QTextBrowser in assistant to drop
qtwebkit dependency
* Tue Nov 23 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.1-3
- Fails to create debug build of Qt projects on mingw (#653674, QTBUG-14467)