%build: -buildkey g++-4 (#1327360)
This commit is contained in:
parent
593e8b6cfd
commit
87bb4a5751
@ -1,6 +1,27 @@
|
|||||||
diff -up qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.than qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h
|
diff -up qt-everywhere-opensource-src-4.8.7/configure.gcc6 qt-everywhere-opensource-src-4.8.7/configure
|
||||||
--- qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.than 2016-02-03 11:43:04.567757448 +0100
|
--- qt-everywhere-opensource-src-4.8.7/configure.gcc6 2016-04-15 07:04:19.430268222 -0500
|
||||||
+++ qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h 2016-02-04 13:12:26.394350271 +0100
|
+++ qt-everywhere-opensource-src-4.8.7/configure 2016-04-15 07:05:22.157568689 -0500
|
||||||
|
@@ -7744,7 +7744,7 @@ case "$XPLATFORM" in
|
||||||
|
*-g++*)
|
||||||
|
# Check gcc's version
|
||||||
|
case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
|
||||||
|
- 5*|4*|3.4*)
|
||||||
|
+ 8*|7*|6*|5*|4*|3.4*)
|
||||||
|
;;
|
||||||
|
3.3*)
|
||||||
|
canBuildWebKit="no"
|
||||||
|
@@ -8060,7 +8060,7 @@ g++*)
|
||||||
|
3.*)
|
||||||
|
COMPILER_VERSION="3.*"
|
||||||
|
;;
|
||||||
|
- 5*|4.*)
|
||||||
|
+ 8*|7*|6*|5*|4.*)
|
||||||
|
COMPILER_VERSION="4"
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
diff -up qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h
|
||||||
|
--- qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 2015-05-07 09:14:48.000000000 -0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h 2016-04-15 07:04:19.431268227 -0500
|
||||||
@@ -70,8 +70,8 @@ namespace QPatternist
|
@@ -70,8 +70,8 @@ namespace QPatternist
|
||||||
ForegroundShift = 10,
|
ForegroundShift = 10,
|
||||||
BackgroundShift = 20,
|
BackgroundShift = 20,
|
||||||
@ -12,15 +33,3 @@ diff -up qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h
|
|||||||
};
|
};
|
||||||
|
|
||||||
public:
|
public:
|
||||||
diff -up qt-everywhere-opensource-src-4.8.7/configure.than qt-everywhere-opensource-src-4.8.7/configure
|
|
||||||
--- qt-everywhere-opensource-src-4.8.7/configure.than 2016-02-10 16:19:31.763130618 +0100
|
|
||||||
+++ qt-everywhere-opensource-src-4.8.7/configure 2016-02-10 16:19:48.508500789 +0100
|
|
||||||
@@ -7741,7 +7741,7 @@ case "$XPLATFORM" in
|
|
||||||
*-g++*)
|
|
||||||
# Check gcc's version
|
|
||||||
case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
|
|
||||||
- 5*|4*|3.4*)
|
|
||||||
+ 6*|5*|4*|3.4*)
|
|
||||||
;;
|
|
||||||
3.3*)
|
|
||||||
canBuildWebKit="no"
|
|
||||||
|
12
qt.spec
12
qt.spec
@ -44,7 +44,7 @@ Summary: Qt toolkit
|
|||||||
Name: qt
|
Name: qt
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.8.7
|
Version: 4.8.7
|
||||||
Release: 14%{?dist}
|
Release: 15%{?dist}
|
||||||
|
|
||||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||||
@ -175,7 +175,11 @@ Patch90: qt-everywhere-opensource-src-4.8.6-system-clucene.patch
|
|||||||
# fix arch autodetection for 64-bit MIPS
|
# fix arch autodetection for 64-bit MIPS
|
||||||
Patch91: qt-everywhere-opensource-src-4.8.7-mips64.patch
|
Patch91: qt-everywhere-opensource-src-4.8.7-mips64.patch
|
||||||
|
|
||||||
# fix build issue with gcc6
|
# fix build issue(s) with gcc6
|
||||||
|
%if 0%{?fedora}
|
||||||
|
%global buildkey -buildkey g++-4
|
||||||
|
#BuildRequires: gcc-c++ >= 4
|
||||||
|
%endif
|
||||||
Patch100: qt-everywhere-opensource-src-4.8.7-gcc6.patch
|
Patch100: qt-everywhere-opensource-src-4.8.7-gcc6.patch
|
||||||
|
|
||||||
# support alsa-1.1.x
|
# support alsa-1.1.x
|
||||||
@ -673,6 +677,7 @@ export LDFLAGS="$LDFLAGS $RPM_LD_FLAGS"
|
|||||||
export MAKEFLAGS="%{?_smp_mflags}"
|
export MAKEFLAGS="%{?_smp_mflags}"
|
||||||
|
|
||||||
./configure -v \
|
./configure -v \
|
||||||
|
%{?buildkey} \
|
||||||
-confirm-license \
|
-confirm-license \
|
||||||
-opensource \
|
-opensource \
|
||||||
-optimized-qmake \
|
-optimized-qmake \
|
||||||
@ -1362,6 +1367,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:4.8.7-15
|
||||||
|
- %%build: -buildkey g++-4 (#1327360)
|
||||||
|
|
||||||
* Sun Apr 03 2016 Michal Toman <mtoman@fedoraproject.org> - 1:4.8.7-14
|
* Sun Apr 03 2016 Michal Toman <mtoman@fedoraproject.org> - 1:4.8.7-14
|
||||||
- Fix build on MIPS (#1322524)
|
- Fix build on MIPS (#1322524)
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user