- Fails to create debug build of Qt projects on mingw (#653674, QTBUG-14467)
This commit is contained in:
parent
137cfcb128
commit
8244061b3d
27
qt-everywhere-opensource-src-4.7.1-QTBUG-14467.patch
Normal file
27
qt-everywhere-opensource-src-4.7.1-QTBUG-14467.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
|
||||||
|
Fails to create debug build of Qt projects on mingw
|
||||||
|
http://bugzilla.redhat.com/653674
|
||||||
|
http://bugreports.qt.nokia.com/browse/QTBUG-14467
|
||||||
|
|
||||||
|
--- qt-everywhere-opensource-src-4.7.1/mkspecs/features/qt_functions.prf.orig 2010-11-16 03:12:17.000000000 +0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.7.1/mkspecs/features/qt_functions.prf 2010-11-16 03:12:50.000000000 +0500
|
||||||
|
@@ -62,7 +62,7 @@ defineTest(qtAddLibrary) {
|
||||||
|
}
|
||||||
|
isEmpty(LINKAGE) {
|
||||||
|
if(!debug_and_release|build_pass):CONFIG(debug, debug|release) {
|
||||||
|
- win32:LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}d
|
||||||
|
+ win32:LINKAGE = -l$${LIB_NAME}d$${QT_LIBINFIX}
|
||||||
|
mac:LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}_debug
|
||||||
|
}
|
||||||
|
isEmpty(LINKAGE):LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}
|
||||||
|
--- qt-everywhere-opensource-src-4.7.1/mkspecs/features/win32/windows.prf.orig 2010-11-16 03:11:34.000000000 +0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.7.1/mkspecs/features/win32/windows.prf 2010-11-16 03:11:51.000000000 +0500
|
||||||
|
@@ -6,7 +6,7 @@ contains(TEMPLATE, ".*app"){
|
||||||
|
|
||||||
|
qt:for(entryLib, $$list($$unique(QMAKE_LIBS_QT_ENTRY))) {
|
||||||
|
isEqual(entryLib, -lqtmain): {
|
||||||
|
- CONFIG(debug, debug|release): QMAKE_LIBS += $${entryLib}$${QT_LIBINFIX}d
|
||||||
|
+ CONFIG(debug, debug|release): QMAKE_LIBS += $${entryLib}d$${QT_LIBINFIX}
|
||||||
|
else: QMAKE_LIBS += $${entryLib}$${QT_LIBINFIX}
|
||||||
|
} else {
|
||||||
|
QMAKE_LIBS += $${entryLib}
|
9
qt.spec
9
qt.spec
@ -18,7 +18,7 @@ Summary: Qt toolkit
|
|||||||
Name: qt
|
Name: qt
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.7.1
|
Version: 4.7.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
|
|
||||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||||
@ -82,6 +82,9 @@ Patch62: qt-4.6.3-indic-rendering-bz636399.patch
|
|||||||
# fix 24bit color issue
|
# fix 24bit color issue
|
||||||
Patch63: qt-everywhere-opensource-src-4.7.0-bpp24.patch
|
Patch63: qt-everywhere-opensource-src-4.7.0-bpp24.patch
|
||||||
|
|
||||||
|
# Fails to create debug build of Qt projects on mingw (rhbz#653674)
|
||||||
|
Patch64: qt-everywhere-opensource-src-4.7.1-QTBUG-14467.patch
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
# Reordering of Malayalam Rakar not working properly
|
# Reordering of Malayalam Rakar not working properly
|
||||||
Patch100: qt-everywhere-opensource-src-4.7.1-ml_IN-bz528303
|
Patch100: qt-everywhere-opensource-src-4.7.1-ml_IN-bz528303
|
||||||
@ -438,6 +441,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
|||||||
%patch61 -p1 -b .indic-rendering-bz631732
|
%patch61 -p1 -b .indic-rendering-bz631732
|
||||||
%patch62 -p1 -b .indic-rendering-bz636399
|
%patch62 -p1 -b .indic-rendering-bz636399
|
||||||
%patch63 -p1 -b .bpp24
|
%patch63 -p1 -b .bpp24
|
||||||
|
%patch64 -p1 -b .QTBUG-14467
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch100 -p1 -b .ml_IN-redering
|
%patch100 -p1 -b .ml_IN-redering
|
||||||
@ -1105,6 +1109,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 23 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.1-3
|
||||||
|
- Fails to create debug build of Qt projects on mingw (#653674, QTBUG-14467)
|
||||||
|
|
||||||
* Mon Nov 22 2010 Than Ngo <than@redhat.com> - 4.7.1-2
|
* Mon Nov 22 2010 Than Ngo <than@redhat.com> - 4.7.1-2
|
||||||
- bz#528303, Reordering of Malayalam Rakar not working properly
|
- bz#528303, Reordering of Malayalam Rakar not working properly
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user