reduce debuginfo in qtwebkit(webcore) and qtscript(javascriptcore)

This commit is contained in:
Rex Dieter 2013-07-11 15:10:47 -05:00
parent c1a09759e2
commit 7ff9f93fee
3 changed files with 44 additions and 1 deletions

View File

@ -0,0 +1,16 @@
diff -up qt-everywhere-opensource-src-4.8.5/src/3rdparty/javascriptcore/JavaScriptCore/JavaScriptCore.pri.jscore_debuginfo qt-everywhere-opensource-src-4.8.5/src/3rdparty/javascriptcore/JavaScriptCore/JavaScriptCore.pri
--- qt-everywhere-opensource-src-4.8.5/src/3rdparty/javascriptcore/JavaScriptCore/JavaScriptCore.pri.jscore_debuginfo 2013-06-07 00:16:58.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.5/src/3rdparty/javascriptcore/JavaScriptCore/JavaScriptCore.pri 2013-07-11 15:02:37.097084409 -0500
@@ -13,6 +13,12 @@ CONFIG(debug, debug|release) {
OBJECTS_DIR = obj/release
}
+equals(QT_ARCH, s390)|equals(QT_ARCH, arm)|equals(QT_ARCH, mips)|equals(QT_ARCH, i386)|equals(QT_ARCH, i686)|equals(QT_ARCH, x86_64)|equals(QT_ARCH, powerpc64)|equals(QT_ARCH, powerpc) {
+ message("JavaScriptCore workaround for QtWebkit: do not build with -g, but with -g1")
+ QMAKE_CXXFLAGS_RELEASE -= -g
+ QMAKE_CXXFLAGS_RELEASE += -g1
+}
+
symbian: {
# Need to guarantee this comes before system includes of /epoc32/include
MMP_RULES += "USERINCLUDE ../JavaScriptCore/profiler"

View File

@ -0,0 +1,16 @@
diff -up qt-everywhere-opensource-src-4.8.5/src/3rdparty/webkit/Source/WebCore/WebCore.pri.webkit_debuginfo qt-everywhere-opensource-src-4.8.5/src/3rdparty/webkit/Source/WebCore/WebCore.pri
--- qt-everywhere-opensource-src-4.8.5/src/3rdparty/webkit/Source/WebCore/WebCore.pri.webkit_debuginfo 2013-06-07 00:16:55.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.5/src/3rdparty/webkit/Source/WebCore/WebCore.pri 2013-07-11 14:04:19.937056249 -0500
@@ -5,6 +5,12 @@ include(features.pri)
# Uncomment this to enable Texture Mapper.
# CONFIG += texmap
+#
+equals(QT_ARCH, s390)|equals(QT_ARCH, arm)|equals(QT_ARCH, mips)|equals(QT_ARCH, i386)|equals(QT_ARCH, i686)|equals(QT_ARCH, x86_64)|equals(QT_ARCH, powerpc64)|equals(QT_ARCH, powerpc) {
+ message("WebCore workaround for QtWebkit: do not build with -g, but with -g1")
+ QMAKE_CXXFLAGS_RELEASE -= -g
+ QMAKE_CXXFLAGS_RELEASE += -g1
+}
QT *= network

13
qt.spec
View File

@ -29,7 +29,7 @@ Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.8.5
Release: 2%{?dist}
Release: 3%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
@ -58,6 +58,12 @@ Patch2: qt-everywhere-opensource-src-4.8.0-tp-multilib-optflags.patch
# get rid of timestamp which causes multilib problem
Patch4: qt-everywhere-opensource-src-4.8.5-uic_multilib.patch
# reduce debuginfo in qtwebkit (webcore)
Patch5: qt-everywhere-opensource-src-4.8.5-webcore_debuginfo.patch
# reduce debuginfo in qtscript (javascriptcore)
Patch6: qt-everywhere-opensource-src-4.8.5-javascriptcore_debuginfo.patch
# enable ft lcdfilter
Patch15: qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
@ -476,6 +482,8 @@ and invoke methods on those objects.
# drop backup file(s), else they get installed too, http://bugzilla.redhat.com/639463
rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
%patch4 -p1 -b .uic_multilib
%patch5 -p1 -b .webcore_debuginfo
%patch6 -p1 -b .javascriptcore_debuginfo
%patch15 -p1 -b .enable_ft_lcdfilter
%patch23 -p1 -b .glib_eventloop_nullcheck
%patch25 -p1 -b .qdbusconnection_no_debug
@ -1202,6 +1210,9 @@ fi
%changelog
* Thu Jul 11 2013 Rex Dieter <rdieter@fedoraproject.org> 4.8.5-3
- reduce debuginfo in qtwebkit(webcore) and qtscript(javascriptcore)
* Tue Jul 02 2013 Rex Dieter <rdieter@fedoraproject.org> 4.8.5-2
- qdbusviewer subpkg (#968336)