refresh boost/moc patch (QTBUG-22829)
This commit is contained in:
parent
a9071e838a
commit
7d0674cfd8
@ -1,14 +0,0 @@
|
|||||||
diff -up qt-everywhere-opensource-src-4.8.5/src/tools/moc/main.cpp.QTBUG-22829 qt-everywhere-opensource-src-4.8.5/src/tools/moc/main.cpp
|
|
||||||
--- qt-everywhere-opensource-src-4.8.5/src/tools/moc/main.cpp.QTBUG-22829 2013-06-09 17:04:02.762459323 -0500
|
|
||||||
+++ qt-everywhere-opensource-src-4.8.5/src/tools/moc/main.cpp 2013-06-09 17:08:20.409680813 -0500
|
|
||||||
@@ -188,8 +188,9 @@ int runMoc(int _argc, char **_argv)
|
|
||||||
pp.macros["Q_MOC_RUN"];
|
|
||||||
pp.macros["__cplusplus"];
|
|
||||||
|
|
||||||
- // Workaround a bug while parsing the boost/type_traits/has_operator.hpp header. See QTBUG-22829
|
|
||||||
+ // Workaround a bugs while parsing some boost headers. See QTBUG-22829
|
|
||||||
pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"];
|
|
||||||
+ pp.macros["BOOST_LEXICAL_CAST_INCLUDED"];
|
|
||||||
|
|
||||||
QByteArray filename;
|
|
||||||
QByteArray output;
|
|
15
qt-everywhere-opensource-src-4.8.6-QTBUG-22829.patch
Normal file
15
qt-everywhere-opensource-src-4.8.6-QTBUG-22829.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -up qt-everywhere-opensource-src-4.8.6/src/tools/moc/main.cpp.QTBUG-22829 qt-everywhere-opensource-src-4.8.6/src/tools/moc/main.cpp
|
||||||
|
--- qt-everywhere-opensource-src-4.8.6/src/tools/moc/main.cpp.QTBUG-22829 2014-04-10 13:37:12.000000000 -0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.6/src/tools/moc/main.cpp 2015-01-29 11:12:31.169465097 -0600
|
||||||
|
@@ -188,8 +188,10 @@ int runMoc(int _argc, char **_argv)
|
||||||
|
pp.macros["Q_MOC_RUN"];
|
||||||
|
pp.macros["__cplusplus"];
|
||||||
|
|
||||||
|
- // Workaround a bug while parsing the boost/type_traits/has_operator.hpp header. See QTBUG-22829
|
||||||
|
+ // Workaround a bugs while parsing some boost headers. See QTBUG-22829
|
||||||
|
pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"];
|
||||||
|
+ pp.macros["BOOST_LEXICAL_CAST_INCLUDED"];
|
||||||
|
+ pp.macros["BOOST_NEXT_PRIOR_HPP_INCLUDED"];
|
||||||
|
|
||||||
|
QByteArray filename;
|
||||||
|
QByteArray output;
|
7
qt.spec
7
qt.spec
@ -35,7 +35,7 @@ Summary: Qt toolkit
|
|||||||
Name: qt
|
Name: qt
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.8.6
|
Version: 4.8.6
|
||||||
Release: 20%{?dist}
|
Release: 21%{?dist}
|
||||||
|
|
||||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||||
@ -166,7 +166,7 @@ Patch90: qt-everywhere-opensource-src-4.8.6-system-clucene.patch
|
|||||||
Patch102: qt-everywhere-opensource-src-4.8.5-qgtkstyle_disable_gtk_theme_check.patch
|
Patch102: qt-everywhere-opensource-src-4.8.5-qgtkstyle_disable_gtk_theme_check.patch
|
||||||
# workaround for MOC issues with Boost headers (#756395)
|
# workaround for MOC issues with Boost headers (#756395)
|
||||||
# https://bugreports.qt-project.org/browse/QTBUG-22829
|
# https://bugreports.qt-project.org/browse/QTBUG-22829
|
||||||
Patch113: qt-everywhere-opensource-src-4.8.5-QTBUG-22829.patch
|
Patch113: qt-everywhere-opensource-src-4.8.6-QTBUG-22829.patch
|
||||||
|
|
||||||
# aarch64 support, https://bugreports.qt-project.org/browse/QTBUG-35442
|
# aarch64 support, https://bugreports.qt-project.org/browse/QTBUG-35442
|
||||||
Patch180: qt-aarch64.patch
|
Patch180: qt-aarch64.patch
|
||||||
@ -1298,6 +1298,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 29 2015 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.6-21
|
||||||
|
- refresh boost/moc patch (QTBUG-22829)
|
||||||
|
|
||||||
* Sun Jan 18 2015 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.6-20
|
* Sun Jan 18 2015 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.6-20
|
||||||
- fix %%pre scriptlet (#1183299)
|
- fix %%pre scriptlet (#1183299)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user