- 4.7.0-beta1

- -webkit-devel : it lives! brainz!
This commit is contained in:
Rex Dieter 2010-05-06 14:05:58 +00:00
parent 30f06196dc
commit 7c848ff441
7 changed files with 36 additions and 193 deletions

View File

@ -7,5 +7,4 @@ hi22-phonon-gstreamer.png
hi32-phonon-gstreamer.png
hi48-phonon-gstreamer.png
hi64-phonon-gstreamer.png
qt-everywhere-opensource-src-4.6.2.tar.gz
qt-everywhere-opensource-src-4.7.0-tp.tar.gz
qt-everywhere-opensource-src-4.7.0-beta1.tar.gz

View File

@ -1,60 +0,0 @@
diff -up qt-everywhere-opensource-src-4.6.0/src/3rdparty/phonon/gstreamer/audiooutput.cpp.gst-pulsaudio qt-everywhere-opensource-src-4.6.0/src/3rdparty/phonon/gstreamer/audiooutput.cpp
--- qt-everywhere-opensource-src-4.6.0/src/3rdparty/phonon/gstreamer/audiooutput.cpp.gst-pulsaudio 2009-11-27 02:27:50.000000000 +0100
+++ qt-everywhere-opensource-src-4.6.0/src/3rdparty/phonon/gstreamer/audiooutput.cpp 2009-12-01 13:36:43.000000000 +0100
@@ -148,7 +148,9 @@ bool AudioOutput::setOutputDevice(int ne
// Save previous state
GstState oldState = GST_STATE(m_audioSink);
const QByteArray oldDeviceValue = GstHelper::property(m_audioSink, "device");
- const QByteArray deviceId = deviceList.at(deviceIdx).gstId;
+ const QByteArray deviceId = (deviceList.at(deviceIdx).gstId == "PulseAudio"
+ ? "default"
+ : deviceList.at(deviceIdx).gstId);
m_device = newDevice;
// We test if the device can be opened by checking if it can go from NULL to READY state
diff -up qt-everywhere-opensource-src-4.6.0/src/3rdparty/phonon/gstreamer/devicemanager.cpp.gst-pulsaudio qt-everywhere-opensource-src-4.6.0/src/3rdparty/phonon/gstreamer/devicemanager.cpp
--- qt-everywhere-opensource-src-4.6.0/src/3rdparty/phonon/gstreamer/devicemanager.cpp.gst-pulsaudio 2009-11-27 02:27:50.000000000 +0100
+++ qt-everywhere-opensource-src-4.6.0/src/3rdparty/phonon/gstreamer/devicemanager.cpp 2009-12-01 13:04:18.000000000 +0100
@@ -50,6 +50,8 @@ AudioDevice::AudioDevice(DeviceManager *
//get name from device
if (gstId == "default") {
description = "Default audio device";
+ } else if (gstId == "PulseAudio") {
+ description = QObject::tr("Pass all audio through the PulseAudio Sound Server.\n").toUtf8();
} else {
GstElement *aSink= manager->createAudioSink();
@@ -178,6 +180,18 @@ GstElement *DeviceManager::createAudioSi
}
}
+ if (!sink) {
+ sink = gst_element_factory_make ("pulsesink", NULL);
+ if (canOpenDevice(sink)) {
+ m_backend->logMessage("AudioOutput using pulse audio sink");
+ m_audioSink = "pulsesink";
+ }
+ else if (sink) {
+ gst_object_unref(sink);
+ sink = 0;
+ }
+ }
+
#ifdef USE_ALSASINK2
if (!sink) {
sink = gst_element_factory_make ("_k_alsasink", NULL);
@@ -311,8 +325,12 @@ void DeviceManager::updateDeviceList()
QList<QByteArray> list;
if (audioSink) {
- list = GstHelper::extractProperties(audioSink, "device");
- list.prepend("default");
+ if (m_audioSink == "pulsesink") {
+ list.append("PulseAudio");
+ } else {
+ list = GstHelper::extractProperties(audioSink, "device");
+ list.prepend("default");
+ }
for (int i = 0 ; i < list.size() ; ++i) {
QByteArray gstId = list.at(i);

View File

@ -1,15 +0,0 @@
diff -up qt-everywhere-opensource-src-4.6.2/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h.sparc qt-everywhere-opensource-src-4.6.2/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h
--- qt-everywhere-opensource-src-4.6.2/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h.sparc 2010-03-23 10:39:06.138490870 -0400
+++ qt-everywhere-opensource-src-4.6.2/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h 2010-03-23 10:42:09.660492875 -0400
@@ -729,7 +729,10 @@
#endif
#if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
-#if (PLATFORM(X86_64) && (PLATFORM(UNIX) || PLATFORM(WIN_OS))) || PLATFORM(IA64) || PLATFORM(ALPHA)
+#if (PLATFORM(X86_64) && (PLATFORM(UNIX) || PLATFORM(WIN_OS))) \
+ || PLATFORM(IA64) \
+ || PLATFORM(ALPHA) \
+ || PLATFORM(SPARC64)
#define WTF_USE_JSVALUE64 1
#elif PLATFORM(ARM) || PLATFORM(PPC64)
#define WTF_USE_JSVALUE32 1

View File

@ -1,13 +0,0 @@
diff -ur qt-everywhere-opensource-src-4.7.0-tp/src/corelib/kernel/qmetaobject_p.h qt-everywhere-opensource-src-4.7.0-tp-QTBUG-9354/src/corelib/kernel/qmetaobject_p.h
--- qt-everywhere-opensource-src-4.7.0-tp/src/corelib/kernel/qmetaobject_p.h 2010-03-10 14:56:51.000000000 +0100
+++ qt-everywhere-opensource-src-4.7.0-tp-QTBUG-9354/src/corelib/kernel/qmetaobject_p.h 2010-04-04 00:14:37.000000000 +0200
@@ -287,7 +287,8 @@
}
// cv qualifers can appear after the type as well
- if (t != e && (e - t >= 5 && strncmp("const", t, 5) == 0)) {
+ if (!is_ident_char(c) && t != e && (e - t >= 5 && strncmp("const", t, 5) == 0)
+ && (e - t == 5 || !is_ident_char(t[5]))) {
t += 5;
while (t != e && is_space(*t))
++t;

View File

@ -1,69 +0,0 @@
From f1e39e7dea8634695263435f0bf912ce19c43195 Mon Sep 17 00:00:00 2001
From: Thomas Zander <t.zander@nokia.com>
Date: Thu, 4 Mar 2010 13:16:09 +0100
Subject: [PATCH] Make tablet detection work with new wacom drivers
wacom driver fixed a bug in assigning atom names where it messed
up the device names. Their solution apparently renamed the atoms
The type names used now are "STYLUS", "CURSOR", "ERASER", "PAD"
and "TOUCH" for each respective device. This change detects
those as our tablet input devices.
Reviewed-by: Benjamin Poulain <benjamin.poulain@nokia.com>
Task-number: QTBUG-8599
---
src/gui/kernel/qapplication_x11.cpp | 9 +++++++--
src/gui/kernel/qt_x11_p.h | 3 +++
2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/src/gui/kernel/qapplication_x11.cpp b/src/gui/kernel/qapplication_x11.cpp
index 121e9ec..25a7750 100644
--- a/src/gui/kernel/qapplication_x11.cpp
+++ b/src/gui/kernel/qapplication_x11.cpp
@@ -320,9 +320,14 @@ static const char * x11_atomnames = {
"_XEMBED\0"
"_XEMBED_INFO\0"
+ // Wacom old. (before version 0.10)
"Wacom Stylus\0"
"Wacom Cursor\0"
"Wacom Eraser\0"
+
+ // Tablet
+ "STYLUS\0"
+ "ERASER\0"
};
Q_GUI_EXPORT QX11Data *qt_x11Data = 0;
@@ -2366,12 +2371,12 @@ void qt_init(QApplicationPrivate *priv, int,
gotStylus = true;
}
#else
- if (devs->type == ATOM(XWacomStylus)) {
+ if (devs->type == ATOM(XWacomStylus) || devs->type == ATOM(XTabletStylus)) {
deviceType = QTabletEvent::Stylus;
if (wacomDeviceName()->isEmpty())
wacomDeviceName()->append(devs->name);
gotStylus = true;
- } else if (devs->type == ATOM(XWacomEraser)) {
+ } else if (devs->type == ATOM(XWacomEraser) || devs->type == ATOM(XTabletEraser)) {
deviceType = QTabletEvent::XFreeEraser;
gotEraser = true;
}
diff --git a/src/gui/kernel/qt_x11_p.h b/src/gui/kernel/qt_x11_p.h
index d110084..14e04bb 100644
--- a/src/gui/kernel/qt_x11_p.h
+++ b/src/gui/kernel/qt_x11_p.h
@@ -675,6 +675,9 @@ struct QX11Data
XWacomCursor,
XWacomEraser,
+ XTabletStylus,
+ XTabletEraser,
+
NPredefinedAtoms,
_QT_SETTINGS_TIMESTAMP = NPredefinedAtoms,
--
1.6.1

67
qt.spec
View File

@ -9,13 +9,13 @@
# enable kde-qt integration/patches
%define kde_qt 1
%define pre tp
%define pre beta1
Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.7.0
Release: 0.8.%{pre}%{?dist}
Release: 0.9.%{pre}%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: LGPLv2 with exceptions or GPLv3 with exceptions
@ -45,7 +45,6 @@ Patch16: qt-x11-opensource-src-4.5.1-kde4_plugins.patch
# make PulseAudio the default device in Phonon
Patch17: qt-x11-opensource-src-4.5.2-pulseaudio.patch
Patch19: qt-x11-opensource-src-4.5.1-phonon.patch
Patch21: qt-everywhere-opensource-src-4.6.0-gst-pulsaudio.patch
# use system ca-bundle certs, http://bugzilla.redhat.com/521911
Patch22: qt-x11-opensource-src-4.5.3-system_ca_certificates.patch
Requires: ca-certificates
@ -60,28 +59,11 @@ Patch53: qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
Patch54: qt-x11-opensource-src-4.5.1-mysql_config.patch
# http://bugs.kde.org/show_bug.cgi?id=180051#c22
Patch55: qt-everywhere-opensource-src-4.6.2-cups.patch
# fix webkit platform definitions for sparc64
Patch56: qt-everywhere-opensource-src-4.6.2-sparc64-webkit-fix.patch
# security patches
# upstream patches
# http://qt.gitorious.org/qt/qt/commit/ff870dbf9106f2bbb2cf64f5aa35fc5917e5f4f2
# http://bugreports.qt.nokia.com/browse/QTBUG-9354
#
# From ff870dbf9106f2bbb2cf64f5aa35fc5917e5f4f2 Mon Sep 17 00:00:00 2001
# From: Olivier Goffart <ogoffart@trolltech.com>
# Date: Fri, 26 Mar 2010 11:26:42 +0100
# Subject: [PATCH] QMetaObject::normalizeType: Fix parsing of type which contains "const" in names
#
# Regression since b881d8fb99972f1bd04ab4c84843cc8d43ddbeed
#
# Task-number: QTBUG-9354
# Reviewed-by: Kent Hansen
Patch100: qt-everywhere-opensource-src-4.7.0-tp-QTBUG-9354.patch
# kde-qt git patches
Patch201: 0001-This-patch-uses-object-name-as-a-fallback-for-window.patch
Patch202: 0002-This-patch-makes-override-redirect-windows-popup-men.patch
@ -93,7 +75,6 @@ Patch207: 0007-When-using-qmake-outside-qt-src-tree-it-sometimes-ge.patch
Patch208: 0008-This-patch-makes-the-raster-graphics-system-use-shar.patch
Patch209: 0009-Restore-a-section-of-the-file-that-got-removed-due-t.patch
Patch212: 0012-Add-context-to-tr-calls-in-QShortcut.patch
Patch213: qt-x11-opensource-src-4.6.2-tablet-wacom-QTBUG-8599.patch
Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
Source11: hi16-phonon-gstreamer.png
@ -131,7 +112,7 @@ Source31: hi48-app-qt4-logo.png
# if -phonon-backend, include in packaging (else it's omitted)
%define phonon_backend_packaged 1
%endif
%define phonon_version 4.3.50
%define phonon_version 4.3.80
%define phonon_version_major 4.3
%define phonon_release 1
%define webkit -webkit
@ -263,12 +244,6 @@ Summary: Development files for the Qt toolkit
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: %{name}-x11%{?_isa}
%if 0%{?webkit:1}
Requires: %{name}-webkit%{?_isa}
Obsoletes: WebKit-qt-devel < 1.0.0-1
Provides: WebKit-qt-devel = 1.0.0-1
Provides: QtWebKit-devel = 1.0-1
%endif
Requires: %{x_deps}
Requires: libpng-devel
Requires: libjpeg-devel
@ -374,11 +349,21 @@ Provides: qt4-tds = %{version}-%{release}
Summary: Qt WebKit library
Group: System Environment/Libraries
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
#Provides: QtWebKit = 1.0.0-1
Obsoletes: WebKit-qt < 1.0.0-1
Provides: WebKit-qt = 1.0.0-1
Provides: QtWebKit = 1.0.0-1
%description webkit
%{summary}.
%package webkit-devel
Summary: Development files for %{name}-webkit-devel
Group: System Environment/Libraries
Requires: %{name}-webkit%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
#Provides: QtWebKit-devel = 1.0.0-1
Obsoletes: WebKit-qt < 1.0.0-1
Provides: WebKit-qt = 1.0.0-1
%description webkit-devel
%{summary}.
%endif
%package x11
@ -417,7 +402,6 @@ Qt libraries used for drawing widgets and OpenGL items.
%patch16 -p1 -b .kde4_plugins
%patch17 -p1 -b .phonon-pulseaudio
%patch19 -p1 -b .servicesfile
%patch21 -p1 -b .gst-pulsaudio
%patch22 -p1 -b .system_ca_certificates
%patch51 -p1 -b .qdoc3
## TODO: still worth carrying? if so, upstream it.
@ -425,12 +409,10 @@ Qt libraries used for drawing widgets and OpenGL items.
## TODO: upstream me
%patch54 -p1 -b .mysql_config
%patch55 -p1 -b .cups-1
%patch56 -p1 -b .sparc
# security fixes
# upstream patches
%patch100 -p1 -b .QTBUG-9354
# kde-qt branch
%if 0%{?kde_qt}
@ -443,7 +425,6 @@ Qt libraries used for drawing widgets and OpenGL items.
# doesn't apply, does look like much of a big deal though
#patch207 -p1 -b .kde-qt-0007
%patch212 -p1 -b .kde-qt-0012
%patch213 -p1 -b .tablet-wacom-QTBUG-8599
%endif
# drop -fexceptions from $RPM_OPT_FLAGS
@ -961,6 +942,14 @@ fi
%{_datadir}/applications/*linguist.desktop
%{_datadir}/icons/hicolor/*/apps/linguist*
%{?docs:%{_qt4_docdir}/qch/linguist.qch}
%if 0%{?webkit:1}
%exclude %{_qt4_headerdir}/Qt/QtWebKit
%exclude %{_qt4_headerdir}/QtWebKit/
%exclude %{_qt4_libdir}/libQtWebKit.prl
%exclude %{_qt4_libdir}/libQtWebKit.so
%exclude %{_qt4_libdir}/libQtWebKit_debug.so
%exclude %{_libdir}/pkgconfig/QtWebKit.pc
%endif
%if 0%{?docs}
%files doc
@ -1016,6 +1005,14 @@ fi
%files webkit
%defattr(-,root,root,-)
%{_qt4_libdir}/libQtWebKit.so.4*
%files webkit-devel
%{_qt4_headerdir}/Qt/QtWebKit
%{_qt4_headerdir}/QtWebKit/
%{_qt4_libdir}/libQtWebKit.prl
%{_qt4_libdir}/libQtWebKit.so
%{_qt4_libdir}/libQtWebKit_debug.so
%{_libdir}/pkgconfig/QtWebKit.pc
%endif
%files x11
@ -1060,6 +1057,10 @@ fi
%changelog
* Thu May 06 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-0.9.beta1
- 4.7.0-beta1
- -webkit-devel : it lives! brainz!
* Fri Apr 30 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-0.8.tp
- prepping for separate QtWebKit(-2.0)
- -webkit subpkg, Provides: QtWebKit ...

View File

@ -7,4 +7,4 @@ d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
12db12c009b722a6dc141f78feb7e330 hi32-phonon-gstreamer.png
86c34a1b81d44980b1381f94ed6b7a23 hi48-phonon-gstreamer.png
153505c71ec021b0a3bd4b74f2492e93 hi64-phonon-gstreamer.png
5cac7354181408375b04213e1a6a6ffc qt-everywhere-opensource-src-4.7.0-tp.tar.gz
128dae41b23bb427b735548c7864703a qt-everywhere-opensource-src-4.7.0-beta1.tar.gz