omit qdbusconnection warnings in release/no-debug mode
This commit is contained in:
parent
20e8a01183
commit
6ede3a7f87
@ -1,21 +0,0 @@
|
||||
diff -up qt-everywhere-opensource-src-4.8.0/src/corelib/tools/qlocale_icu.cpp.icu_no_spam qt-everywhere-opensource-src-4.8.0/src/corelib/tools/qlocale_icu.cpp
|
||||
--- qt-everywhere-opensource-src-4.8.0/src/corelib/tools/qlocale_icu.cpp.icu_no_spam 2011-12-07 23:06:03.000000000 -0600
|
||||
+++ qt-everywhere-opensource-src-4.8.0/src/corelib/tools/qlocale_icu.cpp 2011-12-20 10:20:19.659502966 -0600
|
||||
@@ -83,7 +83,7 @@ bool qt_initIcu(const QString &localeStr
|
||||
// resolve libicui18n
|
||||
QLibrary lib(QLatin1String("icui18n"), QLatin1String(U_ICU_VERSION_SHORT));
|
||||
if (!lib.load()) {
|
||||
- qWarning() << "Unable to load library icui18n" << lib.errorString();
|
||||
+ // qWarning() << "Unable to load library icui18n" << lib.errorString();
|
||||
status = ErrorLoading;
|
||||
return false;
|
||||
}
|
||||
@@ -112,7 +112,7 @@ bool qt_initIcu(const QString &localeStr
|
||||
// resolve libicuuc
|
||||
QLibrary ucLib(QLatin1String("icuuc"), QLatin1String(U_ICU_VERSION_SHORT));
|
||||
if (!ucLib.load()) {
|
||||
- qWarning() << "Unable to load library icuuc" << ucLib.errorString();
|
||||
+ // qWarning() << "Unable to load library icuuc" << ucLib.errorString();
|
||||
status = ErrorLoading;
|
||||
return false;
|
||||
}
|
23
qt-everywhere-opensource-src-4.8.1-icu_no_debug.patch
Normal file
23
qt-everywhere-opensource-src-4.8.1-icu_no_debug.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -up qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp.icu_no_spam qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp
|
||||
--- qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp.icu_no_spam 2012-03-14 09:01:17.000000000 -0500
|
||||
+++ qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp 2012-04-17 07:30:01.652251482 -0500
|
||||
@@ -83,7 +83,9 @@ bool qt_initIcu(const QString &localeStr
|
||||
// resolve libicui18n
|
||||
QLibrary lib(QLatin1String("icui18n"), QLatin1String(U_ICU_VERSION_SHORT));
|
||||
if (!lib.load()) {
|
||||
+#ifndef QT_NO_DEBUG
|
||||
qWarning() << "Unable to load library icui18n" << lib.errorString();
|
||||
+#endif
|
||||
status = ErrorLoading;
|
||||
return false;
|
||||
}
|
||||
@@ -112,7 +114,9 @@ bool qt_initIcu(const QString &localeStr
|
||||
// resolve libicuuc
|
||||
QLibrary ucLib(QLatin1String("icuuc"), QLatin1String(U_ICU_VERSION_SHORT));
|
||||
if (!ucLib.load()) {
|
||||
+#ifndef QT_NO_DEBUG
|
||||
qWarning() << "Unable to load library icuuc" << ucLib.errorString();
|
||||
+#endif
|
||||
status = ErrorLoading;
|
||||
return false;
|
||||
}
|
16
qt.spec
16
qt.spec
@ -11,7 +11,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.8.1
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||
@ -46,6 +46,10 @@ Patch23: qt-everywhere-opensource-src-4.6.3-glib_eventloop_nullcheck.patch
|
||||
# workaround for a MOC issue with Boost 1.48 headers (#756395)
|
||||
Patch24: qt-everywhere-opensource-src-4.8.0-rc1-moc-boost148.patch
|
||||
|
||||
# hack out largely useless (to users) warnings about qdbusconnection
|
||||
# (often in kde apps), keep an eye on https://git.reviewboard.kde.org/r/103699/
|
||||
Patch25: qt-everywhere-opensource-src-4.8.1-qdbusconnection_no_debug.patch
|
||||
|
||||
## upstreamable bits
|
||||
# fix invalid inline assembly in qatomic_{i386,x86_64}.h (de)ref implementations
|
||||
Patch53: qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
|
||||
@ -93,8 +97,8 @@ Patch75: qt-ppc64-crash.patch
|
||||
# add missing method for QBasicAtomicPointer on s390(x)
|
||||
Patch76: qt-everywhere-opensource-src-4.8.0-s390-atomic.patch
|
||||
|
||||
# don't spam if libicu is not present at runtime
|
||||
Patch77: qt-everywhere-opensource-src-4.8.0-icu_no_spam.patch
|
||||
# don't spam in release/no_debug mode if libicu is not present at runtime
|
||||
Patch77: qt-everywhere-opensource-src-4.8.1-icu_no_debug.patch
|
||||
|
||||
# fix qvfb build
|
||||
Patch79: qt-everywhere-opensource-src-4.8.0-qvfb.patch
|
||||
@ -415,6 +419,7 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
||||
%patch15 -p1 -b .enable_ft_lcdfilter
|
||||
%patch23 -p1 -b .glib_eventloop_nullcheck
|
||||
%patch24 -p1 -b .moc-boost148
|
||||
%patch25 -p1 -b .qdbusconnection_no_debug.patch
|
||||
## TODO: still worth carrying? if so, upstream it.
|
||||
%patch53 -p1 -b .qatomic-inline-asm
|
||||
## TODO: upstream me
|
||||
@ -435,7 +440,7 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
||||
%patch74 -p1 -b .tds_no_strict_aliasing
|
||||
%patch75 -p1 -b .ppc64-crash
|
||||
%patch76 -p1 -b .s390-atomic
|
||||
%patch77 -p1 -b .icu_no_spam
|
||||
%patch77 -p1 -b .icu_no_debug
|
||||
%patch79 -p1 -b .qvfb
|
||||
%patch80 -p1 -b .ld.gold
|
||||
%patch81 -p1 -b .gcc-4.7
|
||||
@ -1067,6 +1072,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Apr 17 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-6
|
||||
- omit qdbusconnection warnings in release/no-debug mode
|
||||
|
||||
* Tue Apr 03 2012 Jaroslav Reznik <jreznik@redhat.com> - 4.8.1-5
|
||||
- Fix a crash in cursorToX() when new block is added (QTBUG-24718)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user