auto-import qt-3.3.3-3 from qt-3.3.3-3.src.rpm

This commit is contained in:
cvsdist 2004-09-09 11:20:15 +00:00
parent c8a617c2fe
commit 66a4e1165d
2 changed files with 39 additions and 1 deletions

View File

@ -0,0 +1,30 @@
--- qt-x11-free-3.3.3/src/opengl/qgl_x11.cpp.orig 2004-08-18 14:55:20.629068213 +0200
+++ qt-x11-free-3.3.3/src/opengl/qgl_x11.cpp 2004-08-18 15:00:43.090260739 +0200
@@ -125,7 +125,7 @@
if (gl_syms_resolved)
return TRUE;
- QLibrary gl("GL");
+ QLibrary gl("GL.so.1");
gl.setAutoUnload(FALSE);
qt_glCallLists = (_glCallLists) gl.resolve("glCallLists");
@@ -283,7 +283,7 @@
typedef Status (*_XmuLookupStandardColormap)( Display *dpy, int screen, VisualID visualid, unsigned int depth,
Atom property, Bool replace, Bool retain );
_XmuLookupStandardColormap qt_XmuLookupStandardColormap;
- qt_XmuLookupStandardColormap = (_XmuLookupStandardColormap) QLibrary::resolve("Xmu", "XmuLookupStandardColormap");
+ qt_XmuLookupStandardColormap = (_XmuLookupStandardColormap) QLibrary::resolve("Xmu.so.6", "XmuLookupStandardColormap");
if (!qt_XmuLookupStandardColormap)
qFatal("Unable to resolve Xmu symbols - please check your Xmu library installation.");
#define XmuLookupStandardColormap qt_XmuLookupStandardColormap
--- qt-x11-free-3.3.3/src/tools/qlibrary.cpp.orig 2004-08-18 14:56:00.322185890 +0200
+++ qt-x11-free-3.3.3/src/tools/qlibrary.cpp 2004-08-18 14:57:51.939637946 +0200
@@ -425,6 +425,7 @@
} else {
tmpfilename = QString( "lib%1" ).arg( filename );
}
+ if ( !filename.contains(".so") )
tmpfilename += filter;
if(QFile::exists(tmpfilename) || it == filters.end()) {
filename = tmpfilename;

10
qt.spec
View File

@ -73,7 +73,7 @@
Summary: The shared library for the Qt GUI toolkit.
Name: qt
Version: %{ver}
Release: 2
Release: 3
Epoch: 1
License: GPL/QPL
Group: System Environment/Libraries
@ -94,6 +94,8 @@ Patch9: qt-x11-free-3.3.3-qmake.patch
Patch10: qt-x11-free-3.3.1-lib64.patch
Patch12: qt-uic-nostdlib.patch
Patch13: qt-x11-free-3.3.1-qfontdatabase_x11.patch
Patch14: qt-x11-free-3.3.3-gl.patch
Patch15: qt-x11-free-3.3.3-qimage.patch
# feature patches
Patch50: qt-x11-immodule-bc-qt3.3.3.patch
@ -288,6 +290,8 @@ for the Qt toolkit.
%patch10 -p1
%patch12 -p1 -b .nostdlib
%patch13 -p1 -b .fonts
%patch14 -p1 -b .gl
%patch15 -p1 -b .image
%if %{immodule}
%patch50 -p1 -b .im
@ -693,6 +697,10 @@ rm -rf %{buildroot}
%changelog
* Wed Aug 18 2004 Than Ngo <than@redhat.com> 1:3.3.3-3
- add patch to fix dlopen issue (#126422)
- add image handling fix
* Thu Aug 12 2004 Than Ngo <than@redhat.com> 1:3.3.3-2
- fix qmake broken link (#129723)