build tds sql driver with -fno-strict-aliasing

This commit is contained in:
Rex Dieter 2011-11-03 12:29:47 -05:00
parent 62de8242b5
commit 651f62b07b
2 changed files with 21 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up qt-everywhere-opensource-src-4.8.0/src/sql/drivers/tds/qsql_tds.pri.tds_no_strict_aliasing qt-everywhere-opensource-src-4.8.0/src/sql/drivers/tds/qsql_tds.pri
--- qt-everywhere-opensource-src-4.8.0/src/sql/drivers/tds/qsql_tds.pri.tds_no_strict_aliasing 2011-10-03 22:44:31.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.0/src/sql/drivers/tds/qsql_tds.pri 2011-11-03 12:06:16.333816559 -0500
@@ -4,7 +4,7 @@ SOURCES += $$PWD/qsql_tds.cpp
unix|win32-g++*: {
LIBS *= $$QT_LFLAGS_TDS
!contains(LIBS, .*sybdb.*):LIBS += -lsybdb
- QMAKE_CXXFLAGS *= $$QT_CFLAGS_TDS
+ QMAKE_CXXFLAGS *= $$QT_CFLAGS_TDS -fno-strict-aliasing
} else:win32-borland {
LIBS *= $(BCB)/lib/PSDK/NTWDBLIB.LIB
} else {

10
qt.spec
View File

@ -11,7 +11,7 @@ Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.8.0
Release: 0.23.rc1%{?dist}
Release: 0.24.rc1%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
@ -90,6 +90,10 @@ Patch72: qt-everywhere-opensource-src-4.8.0-QUrl_toLocalFile.patch
# fixes FTBFS: https://bugs.webkit.org/show_bug.cgi?id=69840
Patch73: qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231.patch
# workaround
# sql/drivers/tds/qsql_tds.cpp:341:49: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
Patch74: qt-everywhere-opensource-src-4.8.0-tds_no_strict_aliasing.patch
# upstream patches
# Applications crash when using a visual with 24 bits per pixel
# https://bugreports.qt.nokia.com/browse/QTBUG-21754
@ -417,6 +421,7 @@ popd
# See https://bugs.webkit.org/show_bug.cgi?id=69840 for the gory details.
%patch73 -p1 -b .qtwebkit-glib231
%endif
%patch74 -p1 -b .tds_no_strict_aliasing
# upstream patches
%patch100 -p1 -b .QTBUG-21754
@ -1050,6 +1055,9 @@ fi
%changelog
* Thu Nov 03 2011 Rex Dieter <rdieter@fedoraproject.org> 4.8.0-0.24.rc1
- build tds sql driver with -fno-strict-aliasing
* Fri Oct 28 2011 Rex Dieter <rdieter@fedoraproject.org> 4.8.0-0.23.rc1
- crash when using a visual with 24 bits per pixel (#749647,QTBUG-21754)